WS_FTP Pro

User’s Guide

Software Version 6

Ipswitch, Inc.
Viewing Only Certain Types of Files ........................................... 24
Displaying Folder Information in a Window ................................. 25
The Right Mouse Menu ............................................................... 25
Sorting Files and Folders ............................................................... 26
Opening (Executing) a File on an FTP Site .................................... 26
Editing Files on an FTP site .......................................................... 27
Viewing Text Files .................................................................... 28
Naming and Renaming Files ........................................................ 28
Changing Permissions on UNIX Sites (chmod) ................................. 28
Deleting Files .......................................................................... 30
Deleting Folders ...................................................................... 30
Transferring Files and Folders ...................................................... 31
  Downloading Files and Folders .................................................. 31
  Uploading Files and Folders ..................................................... 31
  Moving Files and Folders ........................................................ 32
  Appending Files ................................................................... 32
  Using Drag and Drop ............................................................... 32
  Using Transfer Modes ............................................................. 33
Program Options ..................................................................... 33
  General Options .................................................................. 33
  Advanced Options ................................................................ 35
  Display Options ................................................................... 36
  Sounds Options .................................................................... 38
  Session Options ................................................................... 39
  More Session Options ............................................................ 41
  Converting File Extensions .................................................... 43
  Setting ASCII (Text) Extensions .............................................. 44
  Setting Associations ............................................................... 44
  Editing Pro Options ............................................................... 46

Chapter 3: Using the Explorer Interface ........................................ 49
Starting WS_FTP Pro Explorer ....................................................... 49
Using Configured FTP Sites ....................................................... 50
  Configuring a New Site ........................................................... 50
  Saving and Deleting FTP Sites ................................................ 51
Editing Site Properties ............................................................... 52
  Editing the General Properties for Sites .................................... 52
  Editing the Session Options (for Sites and Folders) ..................... 53
  Editing the Startup Options for FTP Sites ................................. 53
  Editing the Advanced Network Functions ................................. 54
  Editing the Firewall Options for Configured Sites ....................... 56
Organizing Sites in Folders ........................................................ 56
Connecting and Disconnecting .................................................... 57
Chapter 5: Troubleshooting

Problems Connecting to an FTP Site
Problems Viewing and Deleting Files and Folders
Problems Transferring Files
Problems with WS_FTP Pro Settings
Problems Renaming and Deleting Files
Chapter 1: Introduction

This chapter begins with a basic introduction to the 32-bit version of WS_FTP Pro, a brief description of File Transfer Protocol (for newcomers), and a list of the product’s main features.

To prepare you for the product installation, we’ve included high level overviews and screen images of the two interfaces you’ll be offered when you install WS_FTP Pro. In addition, you’ll find system requirements, the installation procedure, information about software updates, and instructions for giving feedback to Ipswitch, Inc.

If you have the 16-bit version of WS_FTP Pro, refer to online Help.

What is WS_FTP Pro?

WS_FTP Pro allows you to use Windows 95, Windows 98, and Windows NT to copy to your PC the vast store of software applications, games, images, and other files made available on a continuing basis by organizations all over the world.

WS_FTP Pro is based on File Transfer Protocol (FTP), a method of intercomputer communication developed for the Internet. FTP offers fast and accurate transfer of large files or collections of files between computers on the Internet.

How FTP Works

FTP is based on the client–server model of communication between computers: one computer runs a server program “serving up” information to other computers. The other computers run client programs that request information and receive replies from the server. The computer running the server program is an FTP server, also known as an FTP site.

Organizations such as corporations, governments, and educational institutions often post material of general interest on FTP sites; to access these FTP sites, users must have the ability to connect to the Internet (via a modem or local area network) and an FTP client program (WS_FTP Pro).
Main Features

WS_FTP Pro turns your PC into an FTP client, allowing it to communicate with virtually all types of FTP sites. This allows you to transfer files from an FTP site to your PC, from your PC to an FTP site, or even from one remote FTP site to another.

WS_FTP Pro lets you:
- Connect to practically any FTP site on the Internet.
- Browse the site’s files and folders.
- Open or execute files to evaluate them.
- Point and click, or drag and drop, to transfer files.
- Create and retain configurations for FTP sites you use repeatedly.

Interfaces for Windows 95, 98, and NT

WS_FTP Pro provides two user interfaces for 32-bit environments: the “classic” user interface, which runs like a stand-alone Windows application, and the “Explorer” interface, which integrates with Windows Explorer. The 32-bit interfaces of WS_FTP Pro are designed for Windows 95, 98, and NT 4.0 or later.

The “Classic” Interface of WS_FTP Pro

The classic interface is very similar to previous versions of WS_FTP Pro:
When your local PC connects to an FTP site, the WS_FTP Pro classic interface displays a window with your PC’s files and folders on the left and the FTP site’s files and folders on the right. With the contents of both systems displayed, you can easily locate files on one system and transfer them to a specific folder on the other system.

When you install the classic interface, you get the ability to use command line parameters to launch and run WS_FTP Pro. This is covered in “Chapter 4: Using the Command Line” on page 75.

The “Explorer” Interface of WS_FTP Pro

The other 32-bit interface of WS_FTP Pro is the “Explorer” interface, which is fully integrated with Windows Explorer:

The Explorer interface uses the same core engine as the classic interface, but it lets you copy and move files within Windows Explorer. You don’t even have to be aware that you’re using FTP or that the icons you see are FTP sites.

In addition, the Explorer interface provides a capability not yet part of the classic interface: the ability to copy from one FTP site to another (the “remote-to-remote” capability).

The Explorer interface has just about all the functionality of the classic interface. However, there are a few features in the classic interface that are not in the Explorer interface: remote edit (using ShellExecute), the command line options, L8 mode transfers of non-text files, the ability to set buffer size and transfer rate display, specification of the text editor, and appending files.
Logging Onto an FTP Site

The FTP process begins when a connection is made between an FTP client and an FTP site. After establishing communication, the client logs on with a user name and password. The user name and password identify your account on the site.

Most public FTP sites are set up with an “Anonymous” account: when you connect to an FTP site over the Internet, you need only identify yourself as “Anonymous” and use an e-mail address as a password. Normally, when you log on anonymously, you see the public folder (usually named something like /pub or /apps) containing the information and software that can be downloaded to your PC. (Access to other folders on the site is usually restricted.)

On anonymous FTP sites, look for files called readme, readme.txt, index, or 00index. Many sites use a file like this to provide a catalog of the information available on the site as well as other information about the site, such as a mission statement or operating hours.

In addition, an FTP site can also be set up (by the site administrator) to give certain users “accounts” with special permissions. For example, a user with an account may be able to add, delete, and edit files, while an “anonymous” user can only download files. To log on to a site on which you have an account, you’ll need to enter the user name and password that the site administrator has assigned to your account.

Preconfigured FTP Sites

WS_FTP Pro comes with a number of preconfigured popular FTP sites. You can use these configured sites right out of the box to log you on anonymously. For example, you can select the site named EpicMegaGames to access an FTP site that contains various computer games you can download for free.
System Requirements

WS_FTP Pro requires the following system resources:

- An Intel 386, 486, or Pentium processor; or a Digital Alpha processor
- Windows 95, Windows 98, or Windows NT
- A TCP/IP protocol stack.

You need a 32-bit stack to use the 32-bit version of WS_FTP Pro. Microsoft Windows 95, 98, and NT all come with their own 32-bit TCP/IP stacks, but note that some TCP/IP stacks for Windows 95 (such as Trumpet 1.0 and 2.0) can also be 16-bit.

For the 16-bit version, you can use either a 32- or 16-bit stack.

Installation

The installation of WS_FTP Pro is the same for new users as it is for those who are upgrading from a previous version of WS_FTP Pro.

If you purchased WS_FTP Pro online, install it by double-clicking the file you downloaded, accepting the defaults, and following the prompts on your screen.

To install WS_FTP Pro from a disk:

1 Insert the WS_FTP Pro disk into a disk drive.
2 If you are running Windows 95, 98, or NT 4.0 or later, click the Start button and select Run. If you are running Windows NT 3.51, select Run from the File menu.
3 Enter the drive letter followed by install.exe. For example, a:install.exe.
4 Choose WS_FTP Pro Installation, when asked.
5 Follow the instructions on your screen.
**Note**

If you are upgrading from a previous version of WS_FTP Pro, do not replace the `WS_FTP.ini` file, as this file contains all the FTP sites you have configured.

Please refer to the file named `whatsnew.txt` for information regarding enhancements or changes that may have been made to the software since this manual was printed.

---

**Uninstalling**

The uninstall function removes all files associated with WS_FTP Pro from your PC, including your configured sites. It also removes the WS_FTP Pro Explorer icon from your desktop.

To uninstall WS_FTP Pro:

1. If you are running Windows 95, 98, or NT 4.0 or later, click the **Start** button and select **Run.** If you are running Windows NT 3.51, select **Run** from the **File** menu.

2. Enter the appropriate drive letter (and path) followed by `install.exe`. For example, `a:install.exe`.

3. Choose **Uninstall WS_FTP Pro**, when asked.

4. Follow the on–screen instructions to uninstall WS_FTP Pro.

---

**Other Ipswitch WS_FTP Products**

Ipswitch provides several products to meet your file transfer needs. The “Bonus Pack” that ships with WS_FTP Pro 6.0 includes the WS_FTP Find Utility, the WS_FTP Scripting Utility, and the WS_FTP Synchronize Utility.

The WS_FTP Server and the WS_FTP Pro Development Kit must be purchased separately.
WS_FTP Find Utility

The WS_FTP Find Utility lets users search an FTP site for files that match the user’s criteria. This is especially useful for anyone who is looking for one file on a large, complex FTP site.

WS_FTP Scripting Utility

The WS_FTP Scripting Utility automates the transfer and management of files through basic FTP commands. For example, you can create a script that instructs WS_FTP Pro to upload certain files at the same time each week.

WS_FTP Synchronize Utility

The WS_FTP Synchronize Utility is designed to allow you to “mirror” folders and directories between your PC and a remote FTP server. It lets you keep remote sites up-to-date by automatically uploading files which have changed while deleting files that have been removed from the master directory. This is especially useful for quickly and efficiently updating web sites.

WS_FTP Server

The WS_FTP Server is a full-featured FTP server for Windows NT systems. WS_FTP server lets you create an FTP site that makes files and folders on your PC available to other users. WS_FTP Server offers many features not found in most commercial servers today, including automatic resumption of interrupted transfers.

WS_FTP Pro Development Kit

You can develop custom applications using the WS_FTP Pro Development Kit. It lets you create programs to work with WS_FTP Pro for transferring files to or from FTP sites or between FTP sites. You can use the Development Kit to create an application without being concerned with the intricacies of network programming.

Getting Updates and Giving Feedback

If a software patch is created to fix a bug in the currently shipping version of WS_FTP Pro, Ipswitch will make it available on our FTP and web sites. Product upgrades to extend capabilities are also made available on our FTP and web sites. Note, however, that most
upgrades require a valid service agreement. Check our FTP or web site for current software patches and upgrades.

To download software from the Ipswitch FTP site:

1. Do one of the following:
   - In the classic interface, click the Connect button. In the WS_FTP dialog box, select Ipswitch and then click OK.
   - In the Explorer interface, double-click the Ipswitch site. WS_FTP Pro connects to the Product_Downloads folder on the Ipswitch FTP site.
2. Navigate up one level to the Ipswitch folder, and then open the Product_Support folder. Open the WS_FTP_Pro folder.
3. Select the patch file for your platform type: Intel = x86 or DEC Alpha = AXP. The last three digits of the file name indicate the version number. (For example, x86_404.exe is the patch file for version 404 on the Intel platform.)
4. Transfer the patch file, and place it in your WS_FTP Pro folder. Run the patch file to update WS_FTP Pro.

To download software from the Ipswitch web site:

1. In your web browser, go to: http://www.ipswitch.com.
2. Click the Downloads link.
3. Click Patches and Upgrades, and then click the link for your platform type: Intel or DEC Alpha.
4. Save the patch file in your WS_FTP Pro folder.
5. Run the patch file to update the software.

We welcome your feedback on WS_FTP Pro. Please e–mail any comments and suggestions to feedback@ipswitch.com.
Chapter 2: Using the “Classic” Interface

The “classic” interface of WS_FTP Pro is a stand–alone Windows application that comes in two versions: 16–bit and 32–bit. The information in this chapter refers to the 32–bit version. If you are using the 16-bit version, see online Help.

Starting WS_FTP Pro

To start WS_FTP Pro, do one of the following:

• In Windows 95, 98, and NT 4.0 or later, click the Start button and select Programs-->WS_FTP Pro-->WS_FTP Pro.
• Double-click the WS_FTP Pro icon wherever you installed it.
• In Windows NT 3.51, open the WS_FTP Pro folder and double-click the WS_FTP95 Pro icon.

The main window and WS_FTP Sites dialog box appear.
Using Configured FTP Sites

A configured site is a collection of information about an FTP site that you have saved in WS_FTP Pro. Generally, you’ll use a configured site to connect to an FTP site using parameters that you have set up. The configured site information includes the name of the site, how you’ll log on, and what folders you see when you first connect.

WS_FTP Pro comes with a number of preconfigured popular FTP sites grouped by type in folders. To learn more about organizing your sites in folders, see “Organizing Sites in Folders” on page 19.

Configuring a New Site

You configure a new site as follows:

1. If you’re connected to an FTP site, click Close to disconnect.
2. Click Connect to view the WS_FTP Sites dialog box (shown on the first page of this chapter).
3. Click New to view the New Site/Folder dialog boxes.
4. Enter a name to identify the site configuration, and click Next.
5. In the Host Name/Address text box, enter the fully qualified Internet host name or IP address of the FTP site to which you want to connect. Then click Next.
6. For Login Information, do one of the following:
   - To log in anonymously, select Anonymous. For your password, WS_FTP Pro enters the e–mail address you used when installing the product.
   - If you have an account on the FTP site, make sure Anonymous is not selected, and enter the User ID and Password for your account.

Note

Passwords are stored in the WS_FTP.INI file in an encrypted form, but the encryption is easy to break. Do not select Save Password unless no one else has access to your WS_FTP folder!
7 Click **Finish**. You now see the newly configured site selected in your list of WS_FTP sites. Leave the site selected and click **OK** to connect to it.

When you connect to an FTP site, the area at the bottom of the WS_FTP Pro window displays messages similar to the following:

150 Opening ASCII mode data connection for dir
Received 2046 bytes in 1.0 secs.
226 Transfer complete.

WS_FTP Pro connects you to the FTP site and displays the default folder as determined by the **User ID** in the site configuration. For example, if you connect using "Anonymous" as your user ID, you see the default folder for anonymous logins.

WS_FTP Pro assigns a number of commonly-used default settings to the configured site. You can edit these as described in the sections named “Editing...” below.

**Saving and Deleting Configured FTP Sites**

As described above, a configured FTP site is automatically saved when you click **Finish** in the New Site dialog box. WS_FTP Pro does not limit the number of configured sites you can have.

To delete a configured site:

1 If you’re connected to an FTP site, click **Close** to disconnect.
2 Click **Connect** to view the WS_FTP Sites dialog box (shown on the first page of this chapter).
3 Select the site.
4 Click **Delete**.

**Using an Existing Configured Site**

Once you have configured an FTP site, the next time you want to connect to the same site:

1 If you’re connected to an FTP site, click **Close** to disconnect.
2 Click **Connect** to view the WS_FTP Sites dialog box (shown on the first page of this chapter).
3 Select the site and click **OK**.
Editing Site Properties

You can edit the properties of a site by selecting the site and then selecting **Properties** from the right mouse menu.

Editing the General Properties for FTP Sites

You use the **General** tab of Site Properties to edit the site name, host name or IP address, and host type. You can edit Site Properties only when you are not connected to any site.

1. If you’re connected to an FTP site, click **Close** to disconnect.
2. Click **Connect** to view the WS_FTP Sites dialog box.
3. Select the site.
4. Click **Properties**. The **General** tab of Site Properties appears.

5. (Optional) In the **Site Name** text box, enter a new name.
6. (Optional) Enter a new host name or address in the **Host Name/Address** box.
7. (Optional) Select a new **Host Type** from the drop–down list.
8. (Optional) Do one of the following:
   - To log in anonymously, select **Anonymous**. WS_FTP Pro
enters your e-mail address as your password.

- If you have an account on the site, make sure **Anonymous** is not selected, enter the **User ID** and **Password** for your account, and then enter your **Account** information.

---

**Note**

Encrypted passwords are stored in the `ws_ftp.ini` file, but the encryption is easy to break. Do not select **Save Pwd** unless no one else has access to your WS_FTP folder!

---

9  (Optional) In the **Comment** text box, enter or edit comments.

**Editing the Session Options (for Sites or Folders)**

You use the **Session** tab of Site Properties to specify how you want WS_FTP to handle transfers to and from the site. The seven settings on the Session tab can also be set for folders as well as for the program defaults. For tips on how you might set folder permissions, see “Organizing Sites in Folders” on page 19.

1  If you’re connected to an FTP site, click **Close** to disconnect.

2  Click **Connect** to view the WS_FTP Sites dialog box.

3  Select the site.

4  Click **Properties** and then click the **Session** tab.

![Site Properties](image.png)
5 (Optional) Select **Prompt for Destination File Names** to enable file name prompting: as each file is transferred, you are shown the proposed destination file name and allowed to change the name, the path, or both.

6 (Optional) Select **Force Lowercase Remote Names** to convert all file names to lower case when doing uploads.

7 (Optional) Select **Show Transfer Progress Dialog** to display a Transfer Status dialog box during file transfers. This dialog box displays the status of the transfer (percent done) and provides a **Cancel** button that lets you cancel the transfer at any time. Note that the percent done is displayed only if the file size is sent by the FTP site. (Not all FTP sites send this information.)

8 (Optional) Select **Verify Deletions** to have WS_FTP Pro prompt you for confirmation when you delete files.

9 (Optional) When **Prompt for overwrite of same or newer files** and you transfer a folder or file for which there is the same or a newer version (by date and time) in the destination folder, WS_FTP Pro asks if you want to overwrite the file. Note that this feature does not work with some FTP sites.

10 (Optional) Select **Enable auto reget of failed transfers** to try to resume interrupted transfers. Most, but not all, FTP sites allow the “auto reget” option. It works like this: when a file transfer is interrupted because of a lost connection or because it was cancelled, WS_FTP Pro tries to resume the transfer the next time you reconnect to the FTP site.

11 (Optional) Select **Preserve file time on transfer from remote** if you want files downloaded from an FTP site to maintain their original creation dates and times. If not selected, the file date and time are updated to the date and time of the download.

**Editing the Startup Options for FTP Sites**

You use the **Startup** tab of Site Properties to specify what you view when you first log onto an FTP site.

1 If you’re connected to an FTP site, click **Close** to disconnect.

2 Click **Connect** to view the WS_FTP Sites dialog box.

3 Select the site.
4 Click **Properties** and then click the **Startup** tab.

5 (Optional) In the **Remote Site Folder** text box, specify the folder you want to view whenever you first connect to the FTP site.

6 (Optional) In the **Local Folder** text box, specify the folder you want to be current when you log onto this FTP site.

7 (Optional) In the **Initialize Command** text box, enter any commands that you want to issue to the FTP site when you connect to it. (For example, on a UNIX FTP site, the command `SITE UMASK 022` changes the UMASK used when creating files). Use a semicolon to separate multiple commands, but not more than a total of 250 characters.

8 (Optional) If the **Remote Site Folder** or the **Local Folder** contains a large number of files, you can limit the files displayed to just one type by entering a filter in the **Local file mask** and **Remote file mask** text boxes. For example, if you enter `*.txt`, only files with the .txt extension are displayed.

*Tip: On UNIX FTP sites, enter `–al` or `–la` to view all files, including hidden (.) ones. [For those who have used DOS command line FTP clients: You can also enter any argument string you would use with a “Dir” command]*
9 (Optional) Use the **Time offset in hours** text box to adjust the display of file dates and times on an FTP site so they represent the times and dates in your time zone.

Enter the difference in whole hours between your time zone and the time zone of the FTP site. Use a positive number if the FTP site is in an earlier time zone (west), a negative number for a later time zone (east). For example, if the FTP site is in a time zone three hours earlier than your time zone, you can enter −3 to have WS_FTP Pro adjust a date and time of 11/10/98 1:00 AM to 11/9/98 10:00 PM.

Note that no standard exists for specification of date and time, but it is sometimes displayed in Greenwich Mean Time (GMT).

**Editing the Advanced Network Functions**

You use the **Advanced** tab of Site Properties to specify advanced network functions.

1 If you're connected to an FTP site, click **Close** to disconnect.
2 Click **Connect** to view the WS_FTP Sites dialog box.
3 Select the site.
4 Click **Properties** and then click the **Advanced** tab.
5  (Optional) Use the **Connection Retry** text box to enter the number of times WS_FTP Pro tries again to connect if it fails on the first attempt.

6  (Optional) Enter the **Network Timeout**, the number of seconds that elapses before WS_FTP Pro stops waiting for an FTP site to respond. Normally, the network timeout is determined by your Winsock DLL. (You can set it to *less* time than your Winsock DLL, but setting it higher won’t affect anything.)

7  (Optional) The **Remote Port** for the FTP protocol is normally 21, however, it may be something different if you are going through a firewall, or if the FTP site administrator has assigned the FTP protocol to another port.

8  (Optional) Select **Passive transfers** to have your PC establish the data connection to the FTP site (if the site allows passive transfers). (Normally, when you connect to an FTP site, the FTP site establishes the data connection to your PC.)

Use passive transfers for local area networks behind some types of router–based firewalls or behind a gateway requiring passive transfers.

**Editing the Firewall Options for Configured Sites**

If your network uses a firewall to block FTP transfers, use the **Firewall** tab of Site Properties to enter firewall information so transfers can go through the firewall.

To do this, you’ll need information about your firewall from your network administrator. Depending on the type of firewall, you’ll need the following:

- For a “SITE hostname” firewall type, you’ll need **Host Name** (or IP Address) and **User ID**.
- For a “Transparent” firewall type, you’ll need **User ID** and **Password**.
- For “USER with no logon” or “Proxy OPEN” firewall types, you’ll need the **Host Name** (or IP Address). (The **User ID** and **Password** are ignored.)
- For “USER after logon,” “USER remoteID@remoteHost fireID,” or “USER fireID@remoteHost” firewall types, you’ll need **Host Name**, **User ID**, and **Password**.
To enter the firewall information for an existing site:

1. If you’re connected to an FTP site, click **Close** to disconnect.
2. Click **Connect** to view the WS_FTP Sites dialog box (shown on the first page of this chapter).
3. Select the site.
4. Click **Properties** and then click the **Firewall** tab.

5. Make sure **Use Firewall** is selected, and enter the firewall information required by your firewall type.

6. (If required) Enter the **Host Name** of your firewall. This must be either a fully qualified Internet host name or an IP address.

7. (If required) Enter your **User ID** and **Password** for the firewall.

8. (Optional) Select **Save Password** to save the password.

---

**Note**

Do not select **Save Password** unless you’re the only user of your computer and no one else has access to your WS_FTP folder!

9. (If required) Enter the **Port** number for the firewall.

10. Select the **Firewall Type**.
Organizing Sites in Folders

You can organize your configured sites in hierarchical folders. For example, you might have one folder for FTP sites that offer games, and another folder for FTP sites from which you download software updates.

Since folders also have the session options described in “Editing the Session Options (for Sites or Folders)” on page 13, you may also want to organize your sites in folders that have session options set to complement the way you work with the sites inside the folder.

For example, you might have a folder for FTP sites on which you have permission to upload files; for that folder, you could select the option **Force lower case remote names**. You could also have a folder for busy sites that take a long time to download from; for that folder, you might want to make sure **Show Transfer Progress Dialog** is not selected.

To create a folder for organizing sites,

1. If you’re connected to an FTP site, click **Close** to disconnect.
2. Click **Connect** to view the WS_FTP Sites dialog box (shown on the first page of this chapter).
3. Click **New**. The New Site/Folder dialog box appears.
4. Click **Folder for organizing configured sites**.

   In the text box, enter a name for the folder, and then click **Finish**.
Connecting and Disconnecting

As described above, you connect to an FTP site by clicking Connect, selecting the Site, and clicking OK.

To disconnect from an FTP site, click Close. When you disconnect from the site, the Close button toggles to Connect and WS_FTP Pro is ready to connect to another FTP site.

Connecting to Sites You Have Not Configured

You can connect to an FTP site without saving configuration information about the site; for example, you might want to connect to a site that you expect to visit only once.

To connect to an FTP site you have not configured:

1. If you’re connected to an FTP site, click Close to disconnect.
2. Click Connect to view the WS_FTP Sites dialog box (shown on the first page of this chapter).
3. Click Quick Connect. The Quick Connect dialog box appears.

4. In the Name/IP Address text box, enter the name of the FTP site to which you want to connect, and then click Next. (This must be either a fully qualified Internet host name or an IP address.)
5. (Optional) Select a Host Type from the drop-down list.
6. Do one of the following:
• To log in anonymously, select **Anonymous**. WS_FTP Pro enters your e-mail address as your password.

• If you have an account on the FTP site, make sure **Anonymous** is *not selected*, and enter the **User ID** and **Password** for your account, and then enter or change your Account information.

**The WS_FTP Pro Window**

When you successfully connect to an FTP site, you see the WS_FTP Pro main window.

The current folder for your PC is shown in the text box at the top left, under the words **Local System**. The current folder on the FTP site is shown in the text box at the top right, under the words **Remote Site**. The left list box shows the files and folders in the current local folder. The right list box shows the files and folders in the current folder on the FTP site. The list boxes may also show the disk drives you can access.

The buttons to the right of each list box provide file and folder operations.
A message area at the bottom of the window displays all messages generated during the FTP session. These messages can tell you if a command executed successfully and help you determine the cause of a failure or a disconnect.

To view the messages in a window, click LogWnd.

Some FTP sites also display messages about the site in the FTP log. The message may describe the site’s hours of operation, an e-mail contact, or list other sites that contain the same information (called “mirror” sites).

---

**Working with Files and Folders**

You can navigate disk drives, folders, and files in several ways. You can:

- Use standard Windows techniques.
- Use the command buttons to the right of each list box.
- Use the right mouse menu.

**Changing Disk Drives and Folders**

The current drives and paths are shown in the text boxes under the words **Local System** and **Remote Site**. To change to another disk drive or folder, do one of the following:

- Use the current drive/path text box:
  - Use the drop-down list of drives and paths. (If you select **Remember folders** on the Session tab of Program Options, the lists show the folders you last visited. For more
• Type a new drive and path into the text box.
• Use standard Windows techniques.
• Use the ChgDir button, but note that not all FTP sites have the concept of folders, so the site may not accept this command. To use ChgDir, do one of the following:
  • Select the desired disk drive or folder and click ChgDir.
  • Click Refresh to make sure nothing is selected, then click ChgDir. You see the following dialog box.

Enter the desired path, or the desired drive and path.

---

**Note**

To change to the root level of another drive, enter just the drive letter followed by a semicolon (for example, d:). Do not enter a trailing slash (\).

---

**Creating Folders**

If you have permission to create folders on an FTP site, do the following:

1. Navigate to the location where you want to place the new folder.
2. Click MkDir. You are prompted for a folder name that is valid for
the current FTP site.

**Refreshing the Display**

To refresh the folder display after folder or file operations outside of WS_FTP Pro, or to cancel selections you’ve made, click **Refresh**.

**Locating Files and Folders**

If you’re new to FTP, you’ll need to know how to determine what files are available on a site. Look for a file called *readme*, *readme.txt*, *index*, or *00index to get a description of the available files, as well as other site information. You can also try the *pub* directory.

---

**Note**

You can use the WS_FTP Find Utility to locate a particular file or folder on a large, complex FTP site. To run the WS_FTP Find Utility, click the **Start** button and select Programs -> WS_FTP Pro -> WS_FTP Find Utility. Detailed information about the Find Utility can be found in its online Help.

---

**Viewing Only Certain Types of Files**

If a folder contains a large number of files, you can limit the files displayed by using the **File Mask** text box, located below the **MkDir** button. There are two **File Mask** text boxes, one for your PC and one for the FTP site.

In the **File Mask** text box, enter a filter that is valid for the FTP site and press Enter. For example, to display only files with the extension *.txt, enter *

Tip: If you’re connected to a UNIX FTP site, you can use –al or –la

---

*Using the “Classic” Interface*
in the File Mask of the Remote Site panel to view all files, including hidden (.) ones. [For those who are familiar with DOS FTP clients: You can also enter any argument string you would use with a “Dir” command.]

**Displaying Folder Information in a Window**

Click DirInfo. The Windows Notepad appears and lists the files and folders in the current folder, as well as the size, creation date, creation time, and protections.

**The Right Mouse Menu**

The right mouse menu allow you to access the same functionality as the command buttons. In addition, you can use it to sort files and folders, transfer or append files, change the permissions on UNIX files, and send FTP commands. For example, when you’re connected to an FTP site and have a file selected, you see a menu similar to this:

<table>
<thead>
<tr>
<th>Sort...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change Folder</td>
</tr>
<tr>
<td>Make Folder...</td>
</tr>
<tr>
<td>Delete Folder</td>
</tr>
<tr>
<td>Transfer file</td>
</tr>
<tr>
<td>Append file</td>
</tr>
<tr>
<td>View file</td>
</tr>
<tr>
<td>Edit file</td>
</tr>
<tr>
<td>Execute file</td>
</tr>
<tr>
<td>Rename file...</td>
</tr>
<tr>
<td>Move files...</td>
</tr>
<tr>
<td>Delete files</td>
</tr>
<tr>
<td>chmod [UNIX]</td>
</tr>
<tr>
<td>Refresh list</td>
</tr>
<tr>
<td>Folder list</td>
</tr>
</tbody>
</table>

**FTP Commands**
Sorting Files and Folders

You can sort files and folders in the list boxes, using the column headings (Name, Date, Size) or the right mouse menu. You can:

- Click the Name, Date, or Size column heading to toggle the sorting of that column between ascending and descending order.
- Click Ctrl+Name to sort the file names by file extension.
- ^ — This button, to the left of the Name column, toggles the display between showing folders on top (before all files), on the bottom, or intermixed with files.
- Use the right mouse button in either list box, and select Sort from the pop–up menu. The Sort dialog box appears.

Opening (Executing) a File on an FTP Site

To open (execute) a file in its associated application, do one of the following:

- Select the file on the FTP site and then click Exec.
- Select Ctrl+Exec to display a prompt where you can enter the executable file name for the application.

WS_FTP Pro downloads the file to the Temp folder in your Windows folder prior to opening it. If it’s a large file, it may take some time for the file to download.

You can associate a specific file extension with a particular application; this allows you to open (execute) the file in the associated application from within WS_FTP Pro. For example, you can associate
the extension .pdf with the Adobe™ Acrobat™ Reader; then, when you open a file named myfile.pdf, it is opened in the Adobe Acrobat Reader. For more information, see “Setting Associations” on page 44.

If an association does not exist, you are prompted to provide that association when you try to open the file. This association is saved in the win.ini file and in the Windows registry.

Editing Files on an FTP site

You can edit a file on an FTP site using either the application indicated on the Associations tab, or the application that Windows associates with the file extension. The Remote Edit uses ShellExecute option controls whether the editing application is determined by WS_FTP Pro or by Windows.

To edit a file on an FTP site:

1. Select the file and select Edit file from the right–mouse menu.

   If Remote Edit uses ShellExecute is not selected, the file is opened in the application associated with the extension on the Associations tab or in the default text viewer (if no association is on the Associations tab). In this case, the file is copied to your PC with a name assigned by WS_FTP Pro.

   If Remote Edit uses ShellExecute is selected, the file is opened in the application that Windows associates with the file extension (via the Windows API ShellExecute function). The file is copied to your PC with the original file name.

2. Edit the file, and then choose Save from the File menu of the application that opened the file.

   If you have permission to edit files, the file will be saved on the FTP site with the original name when you exit the application.

   If you don’t have permission to edit files on the FTP site, but can upload files to the site, you may want to save the file with a new name on your PC and then transfer the new file to the site.

3. Exit from the application that opened the file.

For information on having WS_FTP Pro determine which application opens a specific file type, see “Setting Associations” on page 44.


Viewing Text Files

You can view text (ASCII) files. Notepad is the default text viewer. You can specify a different text viewer if you like; see “General Options” on page 33.

To view a text file, select the file and do one of the following:

• Click the View button on the Remote Site side of the window.
• Click Ctrl+View to display a prompt where you can enter the executable file name for another viewer program.

WS_FTP Pro downloads the file to the Temp folder in your Windows folder. If it’s a large file, it may take some time for the file to download.

Naming and Renaming Files

Not all FTP sites allow you to rename files and folders. For those that do, you can:

1 Select one or more files.
2 Click Rename.

You are prompted for the new name.

3 Enter the new name and click OK.

If you selected multiple files, you are prompted to rename the next file.

You can also rename files as you transfer them. For more information, see “Session Options” on page 39.

Changing Permissions on UNIX Sites (chmod)

You can change modes for a file or folder on a UNIX FTP site, provided you have permission. Select the file and then select chmod.
Using the “Classic” Interface

from the right–mouse menu. You see the following dialog box:

Permissions are also expressed as three-digit values; for example, the permissions shown above correspond to the value 751. The first digit expresses Owner permissions; the second, Group permissions; the third, Other. Three-digit values are used in the WS_FTP Pro log, in the message area, and by some system administrators and ISPs. The table below shows how WS_FTP Pro options correspond to each digit. The third column shows the possible values for Owner, Group, and Other as viewed in the ten-position value in the first column of a directory list for a UNIX site.

<table>
<thead>
<tr>
<th>Selected options in WS_FTP Pro</th>
<th>1st, 2nd, or 3rd digit of 3-digit number</th>
<th>Permissions in directory list</th>
</tr>
</thead>
<tbody>
<tr>
<td>none</td>
<td>0</td>
<td>---</td>
</tr>
<tr>
<td>Execute</td>
<td>1</td>
<td>--x</td>
</tr>
<tr>
<td>Write</td>
<td>2</td>
<td>-w-</td>
</tr>
<tr>
<td>Write, Execute</td>
<td>3</td>
<td>-wx</td>
</tr>
<tr>
<td>Read</td>
<td>4</td>
<td>r--</td>
</tr>
<tr>
<td>Read, Execute</td>
<td>5</td>
<td>r-x</td>
</tr>
<tr>
<td>Read, Write</td>
<td>6</td>
<td>rw-</td>
</tr>
<tr>
<td>Read, Write, Execute</td>
<td>7</td>
<td>rwx</td>
</tr>
</tbody>
</table>

Note
The selected options do not indicate necessarily indicate the current permissions for the selected file or folder!
In the directory list, the first position indicates whether the item is a file or directory, while positions two through ten show the permissions for Owner, Group, and Other.

<table>
<thead>
<tr>
<th>File</th>
<th>Owner</th>
<th>Group</th>
<th>Others</th>
<th>Permissions</th>
</tr>
</thead>
<tbody>
<tr>
<td>drwxr-x--x</td>
<td>root</td>
<td>ftp</td>
<td>1824 Jun 26 04:48</td>
<td>File</td>
</tr>
<tr>
<td>drwxr-x--x</td>
<td>root</td>
<td>root</td>
<td>1824 Sep 27 16:01</td>
<td>Directory</td>
</tr>
<tr>
<td>drwxr-x--x</td>
<td>ftp</td>
<td>ftp</td>
<td>1824 Jun 7 15:08</td>
<td>Folder</td>
</tr>
<tr>
<td>drwxr-x--x</td>
<td>500</td>
<td>500</td>
<td>1824 May 21 04:00</td>
<td>Empty Folder</td>
</tr>
<tr>
<td>drwxr-x--x</td>
<td>4500</td>
<td>ftp</td>
<td>1824 Mar 24 1998</td>
<td>Folder</td>
</tr>
<tr>
<td>drwxr-x--x</td>
<td>2 root</td>
<td>ftp</td>
<td>1824 Sep 15 18:54</td>
<td>Folder</td>
</tr>
</tbody>
</table>

For example, the value 751 corresponds to `drwxr-x--x` in the directory list. This expression is comprised of four parts:

- **d**: First position indicates whether item is a file (-) or directory (d)
- **rwx**: Positions 2-4 indicate Owner permissions: read, write, execute.
- **r-x**: Positions 5-7 indicate Group permissions: read and execute.
- **--x**: Positions 8-10 indicate Other permissions: execute only.

---

**Note**
If you attempt to change permissions, check the message area or the log to see if you were successful.

**Deleting Files**
You can delete files from an FTP site only if your permissions allow you to do so; you usually cannot delete files if you have logged on as an Anonymous user. If you have deletion permission, select the file and click **Delete**.

**Deleting Folders**
You can delete folders from an FTP site, if you have permission. To remove a folder, select the folder and click **Delete**. Or, click **Delete** with nothing selected and enter the name of a folder when prompted.

If the folder is not empty, you can’t delete it unless you select **Allow deletion of non-empty folders** on the **Pro** tab of Program Options.
Transferring Files and Folders

Before you transfer a file or files to or from an FTP site, you will display the files and folders on your PC in the left list box and the files and folders of the FTP site in the right list box.

Downloading Files and Folders

Copying folders or files from the FTP site to your PC is known as downloading.

To download files (or folders):

1. Select one or more files on the FTP site.
2. Select the file transfer mode (ASCII, Binary, or Auto) at the bottom of the WS_FTP Pro window. For more information, see “Using Transfer Modes” on page 33.
3. Click the left arrow in the center of the window.

When the transfer is complete, the names of the transferred files appear in your PC’s list box.

Uploading Files and Folders

Copying folders or files from your PC to the FTP site is known as uploading.

To upload files (or folders):

1. Select one or more files on your PC.
2. Select the file transfer mode (ASCII, Binary, or Auto) at the bottom of the WS_FTP Pro window. For more information, see “Using Transfer Modes” on page 33.
3. Click the right arrow in the center of the window.

When the transfer is complete, the names of the transferred files appear in the FTP site’s list box.
Moving Files and Folders
You can move files or folders from one folder to another folder on the same system (either your PC or an FTP site). To move files:

1. Select one or more files.
2. Select Move files from the right–mouse menu.
   You are prompted for the folder to which you want to move the files.
3. Enter the path and folder and click OK.

Appending Files
You can select one or more files on the source system (either your PC or the FTP site) and transfer those files to the destination system, appending them to another file. To append files:

1. On the destination system, make sure the name of the destination folder appears in the text box under either Local System or Remote Site (depending on which is the destination).
2. Select one or more files on the source system.
3. In the source system list box, select Append file from the right–mouse menu.

   A dialog box prompts you to enter the destination file name.
4. Enter the name of the file to which you want to append the selected file, and click OK.

Using Drag and Drop
In all versions of the classic interface, you can use the mouse to drag and drop files and folders between your PC and an FTP site.

Furthermore, you can:

• Drag and drop between the Windows Explorer and WS_FTP Pro.
• Drag and drop between the desktop and WS_FTP Pro.

To transfer multiple folders or files, drag and drop the selected items. The drag and drop feature is enabled by default, but you can disable it: see “Session Options” on page 39.
Using Transfer Modes

WS_FTP Pro transfers files as follows, depending on the transfer mode that is currently selected:

- **Auto** mode selected — Checks to see if the file extension is listed on the **Extensions** tab of the Program Options. If so, the file is transferred in ASCII format. If it is not listed, or if no file extension is found, the file is transferred in binary format.

- **Auto** mode off — Transfers the file in the selected mode, either binary or ASCII.

For more information on transfer modes, see “More Session Options” on page 41.

Program Options

You can set and edit default program options to customize how WS_FTP Pro works. Click **Apply** to save your changes. Click **OK** to save your changes and close the dialog box.

General Options

To edit the general settings for WS_FTP Pro operations:

1. In the main window, click **Options**. The **General** tab appears.

2. (Optional) Edit your **E-mail Address**. This will be used as the default password for anonymous logins, as required by most anonymous FTP sites.
3 (Optional) Enter the name of the **Text Viewer** invoked by the **DirInfo** and **View** buttons. The default is Windows Notepad.

4 (Optional) Enter the **Log filename**, the name of the file to which WS_FTP Pro writes the information in the message log when **Enable Log** is selected. The log records all requests from WS_FTP Pro and all responses from the FTP site. This file is created in each folder to which you download files, unless you enter a full path in this text box.

5 (Optional) Select **Enable Log** to have WS_FTP Pro write the message log to the file specified in the **Log filename** text box.

6 (Optional) Select **Verify Deletions** to have WS_FTP Pro prompt you for confirmation when you delete files.

7 (Optional) Select **Debug Messages** to have WS_FTP Pro place extra debug messages in the message log window at the bottom of the main window and in the log file (if selected).

8 (Optional) Select **Remote Edit uses ShellExecute** to have WS_FTP Pro open a file on an FTP site in the application that Windows associates with the file extension (via the Windows API ShellExecute function). The file is copied to your PC with the original file name.

9 (Optional) Select **Reset Window Locations** to reset the current main window size and location to the original settings.

10 (Optional) Select **Save Window Locations** to save the current main window size and location. Note that WS_FTP Pro saves the window locations only if the main window is not fully maximized.
Advanced Options

To edit the settings for advanced WS_FTP Pro operations:

1. Click Options, and then click the Advanced tab.

2. (Optional) Select Show Full Folder Information to display additional file information when available. WS_FTP Pro does not attempt to decipher or interpret this information. (Not all host types are supported for this option.)

3. (Optional) If Auto Save Site Configurations is selected, the site configuration is automatically saved when you connect to an FTP site by clicking OK in the Site Properties dialog box.

   If Auto Save Site Configurations is not selected, clicking the OK button in the Site Properties dialog box simply connects you to the FTP site. (The site configuration is not saved.)

4. (Optional) Select Show WS_FTP Sites on Startup to display the WS_FTP Sites dialog box (shown on the first page of this chapter) when WS_FTP Pro first starts.

5. (Optional) Use Double-click Action to determine what happens when you double-click a file name. Transfer file transfers the file to the other system (either your PC or the FTP site). View file displays the file using the text viewer. If the file is on an FTP site, it is transferred in ASCII mode (to the Temp folder in the Windows folder on your PC) and then displayed. Nothing means no action is taken when you double-click a file name.

6. (Optional) Use the Network Buffer Size text box to determine how many bytes of information are received and transmitted.
**Receive Size** — Controls how many bytes are included in each read (recv). This varies from 80 to 4096, with best results from 4096. On slow connections, try lower values and work your way up until you find the optimum rate. Note that the actual number of bytes in each read is determined by the TCP/IP stack and the amount of information.

**Transmission Size** — Controls how many bytes are written in each send. This can vary from 80 to 4096, with the optimum dependent on your TCP/IP stack. If you have a direct connection, 4096 is best. If you have a SLIP or PPP connection, you probably want to set it to the MTU size. On slow connections, try lower values and work your way up until you find the optimum rate.

7 Set the **Transfer Rate Display** to bits or bytes per second. The transfer rate is displayed in the Transfer Status dialog box.

**Display Options**

To edit the settings for the WS_FTP Pro window display:

1 In the main window, click the **Options** button, and then click the **Display** tab.

2 (Optional) Select **Alternate Screen Layout** to split the WS_FTP Pro main window horizontally, with the **Local System** list box on top and the **Remote Site** list box below. (Make sure this option is not selected if you want the window split vertically.)

3 (Optional) Select **Show Buttons at Top of Screen** to move to the top of the window the buttons that are normally across the bottom.
4. (Optional) Select **Hide Command Buttons** to hide the buttons (ChgDir, MkDir, etc.) for file and folder operations. These operations are then available only from the right–mouse menu.

5. (Optional) Select **Auto Scale Fonts** to reduce the size of fonts outside the list boxes when you reduce the window size. The font used will always be the ANSI Variable font.

6. (Optional) Select **Enable button balloon help** to show a descriptive popup when the cursor is placed over one of the buttons in the main window.

7. (Optional) Select the desired **Date Format** options to determine how WS_FTP Pro displays dates.

8. (Optional) Use **List Box Font** to change the font used in the list boxes. **System Variable**, a variable font, is the default. **System Fixed**, a fixed font, improves the alignment of columns in the boxes. **ANSI Variable** and **ANSI Fixed** are narrower than the System fonts. Selecting **Custom Font** displays the Windows Font dialog box from which you can select a specific font family, style, and size.
Sounds Options

To edit the default settings for the audio files that notify you of FTP events, do as follows:

1. In the main window, click the **Options** button, and then click the **Sounds** tab.

2. (Optional) Select **Connection Success** to play the specified wave file (or sound a beep) when a connection succeeds.

3. (Optional) Select **Connection Failure** to play the specified wave file (or sound a beep) when a connection fails.

4. (Optional) Select **Transfer Complete Success** to play the specified wave file (or sound a beep) when a file transfer succeeds.

5. (Optional) Select **Transfer Complete Failure** to play the specified wave file (or sound a beep) when a file transfer fails.

6. (Optional) Select **Other Failures** to play the specified wave file (or sound a beep) when an error occurs during the retrieval of folders, renaming or deleting files or folders, or at other times. To have the same sounds as earlier versions of WS_FTP Pro, make sure this option is not selected.
7 (Optional) Use **Sounds** to specify the sounds to use on connection, completion of file transfer, or an error. **None** means no sound is played. **Beeps** means the system beep sound will be used. **Wave** means the specified `.wav` files will play.

**Session Options**

Changes to the Session options can be set to affect just the current site (or, if you’re not currently connected, the last site you connected to), or can be set to affect all sites (if you click **Set as default**).

To edit the settings for the current FTP site:

1. In the main window, click the **Options** button, and then click the **Session** tab.

2. (Optional) Select the **Host Type** of the FTP site from the drop-down list.

3. (Optional) Select **Update Folders After Transfer** to automatically refresh the Remote Site listing after uploading a file, deleting a file or folder, or creating a folder. If this option is not selected, you can always use the **Refresh** button to update the list boxes.

4. (Optional) Select **Show Transfer Progress Dialog** to display a Transfer Status dialog box during file transfers. This dialog box displays the status of the transfer (percent done) and provides a **Cancel** button that lets you cancel the transfer at any time. Note that the percent done is displayed only if the file size is sent by the FTP site. (Not all FTP sites send this information.)
5 (Optional) Select **Use Passive Transfer Mode** to have your PC establish the data connection to the FTP site. (Normally, when you connect to an FTP site, the site establishes the data connection).

You’ll want to use passive transfers for local area networks that are behind some types of router–based firewalls or behind a gateway that requires passive transfers. You should also use passive transfers if you keep getting “failed data channel” errors.

6 (Optional) Select **Use Firewall** to activate the Firewall properties for all sites. Note that you can also set this property on a per-site basis using the **Firewall** tab of the Site Properties box.

7 (Optional) Select **Force Lowercase Remote Names** to convert all file names to lower case when doing uploads.

8 (Optional) Select **Convert Extensions** to enable the automatic conversion of the file extensions set up on the **Convert** tab.

9 (Optional) Select **Remember Folders (Pro)** to show the folders you’ve visited in the current folder drop–down lists.

These folders are added to the lists as long as you click the **Close** button to disconnect from an FTP site.

10 (Optional) Select **Save Current Folders as Connection Folders** to save the local and FTP site folder names on the Startup tab of the current site use them the next time you connect to the site.
More Session Options

Changes to the Session (cont’d) options can be set to affect just the current site (or, if you’re not currently connected to a site, the last site you connected to), or can be set to affect all sites (if you click Set as default).

To access more session options, do as follows:

1. In the main window, click the Options button and then click the Session (cont’d) tab.

2. (Optional) For a UNIX FTP site, select Send Unique (FTP Site assigns name) to cause uploaded file names to not conflict with existing files (if the FTP site supports the STOU FTP command). The new file name is determined by the FTP site.

3. (Optional) Select Receive Unique (WS_FTP assigns name) to cause downloaded file names to not conflict with existing local files. The sixth through eighth characters of the file name will be a number from 000 to 999.

4. (Optional) Select Prompt for Destination File Names to enable file name prompting: as each file is transferred, you are shown the proposed destination file name and allowed to change the name, the path, or both.

5. (Optional) The Startup Transfer Mode area is where you determine transfer modes.

ASCII is used to transfer text files. The end–of–line character in text files is different on different types of computers. ASCII mode insures that the end–of–line character is translated properly. Tip:
If you’re certain that the FTP site uses the same operating system as your PC, you can use binary mode for text files.

*Binary* is used to transfer non–text files. Executable programs, word processing documents, spreadsheets, databases, graphics files, and sound files are some examples of files that must be transferred in binary mode. If you know that your PC and the FTP site use the same operating system, you can always use binary mode and never use ASCII.

*L8* is used to transfer VMS non–text files.

*Auto Detect* When this option is selected, WS_FTP Pro transfers in binary mode unless the file extension is listed on the *Extensions* tab, in which case it transfers the file in ASCII mode.

- Note that extensions can be up to 10 characters long and can contain periods. These are not DOS extensions, but the ending characters of a file name.
- If you expect the extension to match on a period, you must specify a period. Some example extensions are: `.lst .txt, .me, readme`.
- For more information, see “Setting ASCII (Text) Extensions” on page 44.
Converting File Extensions

You can convert file extensions of transferred files to a new extension. For example, if an FTP site uses `.html` for HTML files and your PC uses `.htm`, you can specify that all files with the extension `.html` are converted to `.htm` when you download them.

To add an extension conversion:

1. In the main window, click the **Options** button, and then click the **Convert** tab.

   ![Image of WS_FTP95 Pro Properties with Convert tab selected]

   Note that the **Source** and **Destination** are dependent on the file transfer direction. When downloading files, the source is the FTP site, and the destination is your PC. When uploading files, the source is your PC and the destination is the FTP site.

2. In the **Source** text box, enter the file extension of the source file.

3. In the **Destination** text box, enter the file extension to convert to.

4. Click **Add**.

   The extension conversion appears in the list box. The list box shows all the defined extension conversions.

WS_FTP Pro automatically converts these extensions when transferring, if **Convert Extensions** on the **Session** tab of Program Options is selected.

To delete an extension conversion, select it and click **Delete**.
Setting ASCII (Text) Extensions

You can specify the transfer mode for different file extensions. When Auto is selected for the transfer mode, WS_FTP Pro transfers all files in binary mode, unless the extension is entered on this tab (which stores entries in the ws_ftp.ext file). The extensions listed here use the ASCII transfer mode.

In the main window, click the Options button and then click the Extensions tab.

The list box lists all file extensions that WS_FTP Pro transfers in ASCII mode when using Auto transfer mode. To add a file extension to the list box:

1. In the ASCII Filenames and Extensions text box, enter the file extension. The extension can be up to nine characters long and can contain periods.
2. Click Add. The extension appears in the list box.
3. Click Apply to save your changes. Click OK to save your changes and close the dialog box.

To delete a file extension from the list box, select it and click Delete.

Setting Associations

When Remote edit uses ShellExecute is selected on the General tab of Program Options, a file is opened in the application that Windows associates with the file extension (via the Windows API ShellExecute
function). Prior to opening the file, the file is copied to your PC with its original file name.

When **Remote edit uses ShellExecute** is *not* selected, a file is opened in the application associated with the extension on the **Associations** tab. If no association exists on the **Associations** tab, the file is opened in the default text viewer. In this case, prior to opening the file, WS_FTP Pro copies the file to your PC with a name and assigns it a new name.

To set your own associations for particular file extensions, click the **Options** button and then click the **Associations** tab.

To set up an association:

1. In the **Files with Extension** text box, select the file extension to be associated with a particular executable program.

2. In the **Associate With** text box, enter the path and file name of the executable program to run when the **Exec** button is clicked.

3. Click **Apply** to save your changes. Click **OK** to save your changes and close the dialog box.
Editing Pro Options

The “Pro” options determine your preferences for how WS_FTP Pro works. To set these options, in the main window, click the Options button and then click the Pro tab.

Enable drag and drop between windows. When selected, you can transfer files and folders between your PC and an FTP site by dragging them with the mouse from one list box to the other.

Enable auto reget of failed transfers. Most, but not all, FTP sites allow the “auto reget” option. It works like this: when a file transfer is interrupted because of a lost connection or because it was cancelled, WS_FTP Pro tries to resume the transfer the next time you reconnect to the FTP site.

When you reconnect, you are asked if you want to resume the transfer:

Note

If you choose not to resume the transfer, you will be left with a partial file in the destination folder. You should delete this file.
Preserve file time on transfer from remote. When this is selected and you download a file from an FTP site, the file maintains its original creation date and time. If not selected, the file date and time are updated to the date and time of the download.

Prompt for overwrite of same or newer files. When this is selected and you transfer a folder or file for which there is the same or a newer version (by date and time) in the destination folder, WS_FTP Pro asks if you want to overwrite the file. Note that this feature does not work with some FTP sites.

Don’t transfer older or same date files during folder transfer. When this is selected and you download a folder, WS_FTP Pro downloads only those files having a later date and time than files in the destination folder with the same names.

Allow deletion of non-empty folders. When this is selected, you can delete non-empty folders and all their contents.
Chapter 3: Using the Explorer Interface

The Explorer interface of WS_FTP Pro is an extension to Windows Explorer. With the Explorer interface, you can:

- Copy files from an FTP site to your PC (download).
- Copy files from your PC to an FTP site (upload).
- Copy files from one FTP site to another.

Starting WS_FTP Pro Explorer

This section describes how to start WS_FTP Pro Explorer and how to create a connection to an FTP site.

To start WS_FTP Pro Explorer, do one of the following:

- Click the Start button and select Programs –> WS_FTP Pro –> WS_FTP Pro Explorer.
- Click the WS_FTP Pro Explorer icon in Windows Explorer.
- Double-click the WS_FTP Pro Explorer icon wherever you installed it.

If you open WS_FTP Pro Explorer from the Windows Explorer, you see a two–paned window.
If you opened WS_FTP Pro Explorer from the desktop icon or from the Start menu, you see a single–paned window.

The way you navigate differs slightly in the two windows, but both follow standard Windows conventions. Navigating in the two–paned window is exactly like using Windows Explorer; navigating in the single–paned window is exactly like navigating in the window you see when you double-click My Computer or any folder on your Windows desktop.

### Using Configured FTP Sites

A configured site is a collection of information about an FTP site that you have saved in WS_FTP Pro. Generally, you’ll use a configured site to connect to an FTP site using customized parameters that you have set up. The configured site information includes the name of the site, how you will log on to the site, and what folders you want to see when you first connect to the site. WS_FTP Pro comes with a number of preconfigured popular FTP sites.

#### Configuring a New Site

You can configure a new site as follows:

1. Double-click the New... icon, or select New... from the File menu.
2. Follow the prompts in the dialog boxes.
   - Enter a name to identify the site configuration you’re creating and then click Next.
• In the **Host Name or IP Address box**, enter either a fully qualified Internet host name or an IP address. Click **Next**.

• For **Logon Information**, do one of the following:
  • Unless you have an account on this FTP site, check **Anonymous**. This automatically enters “anonymous” as your user name. If your e-mail address is not already entered as the password, enter an e-mail address.
  • If you have an account on the FTP server, make sure **Anonymous** is not checked and enter the user name and password for your account.

---

**Note**

Passwords are stored in the WS_FTP.INI file in an encrypted form, but the encryption is easy to break. Do not select **Save Password** unless no one else has access to the WS_FTP folder on your computer!

---

You now see the newly configured site in your list of WS_FTP sites. Double-click the site to connect to it.

WS_FTP Pro connects you to the FTP site and displays the default folder as determined by the **User ID** in the site configuration. For example, if you connect using “Anonymous” as your user ID, you see the default folder for anonymous logins.

You can change this as well as many other default settings in the Site Properties using the procedures described in the “Editing...” sections below.

**Saving and Deleting FTP Sites**

As described above, a configured FTP site is automatically saved when you click **Finish** in the New Site dialog box. WS_FTP Pro Explorer does not limit the number of configured sites you can have.

To delete a site, select the site and select **Delete** from the **File** menu.
Editing Site Properties

You can edit the properties of a configured site by selecting the site and then selecting Site Properties from the File menu. The site properties are grouped on tabs.

Editing the General Properties for Sites

The general site properties include host name, address, and type.

1. Select the site and select Site Properties from the File menu, and click the General tab.

2. (Optional) To change the name of the site configuration, enter a new name in the Site Name text box.

3. (Optional) To edit the site’s name or address, enter a new name or address in the Host Name/Address text box. (This must be either a fully qualified Internet host name or IP address.)

4. (Optional) To change the server type, use the Host Type drop-down list. If you don’t know the type, try “automatic detect.”

5. (Optional) Do one of the following:
   • To log in anonymously, select Anonymous. For a password, WS_FTP Pro enters the e–mail address you used when installing WS_FTP Pro.
• If you have an account on the site, make sure Anonymous is not selected, enter the User ID and Password for your account, and then enter your Account information.

Note
Encrypted passwords are stored in the ws_ftp.ini file, but the encryption is easy to break. Don’t select Save Pwd unless no one else has access to the WS_FTP folder on your computer!

6 (Optional) To add a comment, type into the Comment text box.

Editing the Session Options (for Sites and Folders)
The session properties for sites and folders are closely related to the overall preferences for the WS_FTP Pro Explorer application, so these are covered together in “Session Options” on page 67.

Editing the Startup Options for FTP Sites
Use the Startup tab to specify what you view when you first log on.
1 Select the site, select Site Properties from the File menu, and then click the Startup tab.

2 (Optional) In the Remote Site Folder text box, specify the folder you want to view whenever you first connect to the FTP site.

3 (Optional) In the Local Folder text box, specify the folder you
want to be current when you log onto this FTP site.

4 (Optional) In the **Initialize Command** text box, enter any commands that you want to issue to the FTP site when you connect to it. (For example, on a UNIX FTP site, the command SITE UMASK 022 changes the UMASK used when creating files). Use a semicolon to separate multiple commands, but not more than a total of 250 characters.

5 (Optional) If the **Remote Site Folder** or the **Local Folder** contains a large number of files, you can limit the files displayed to just one type by entering a filter in the **Local file mask** and **Remote file mask** text boxes. For example, if you enter *.txt, only files with the .txt extension are displayed.

*Tip:* On UNIX FTP sites, enter –al or –la to view all files, including hidden (.) ones. [*For those who have used DOS command line FTP clients: You can also enter any argument string you would use with a “Dir” command.*]

6 (Optional) Use the **Time offset in hours** text box to adjust the display of file dates and times on an FTP site so they represent the times and dates in your time zone.

Enter the difference in whole hours between your time zone and the time zone of the FTP site. Use a positive number if the FTP site is in an earlier time zone (west), a negative number for a later time zone (east). For example, if the FTP site is in a time zone three hours earlier than your time zone, you can enter –3 to have WS_FTP Pro adjust a date and time of 11/10/98 1:00 AM to 11/9/98 10:00 PM.

Note that no standard exists for specification of date and time, but it is sometimes displayed in Greenwich Mean Time (GMT).

**Editing the Advanced Network Functions**

You use the **Advanced** tab of Site Properties to specify advanced network functions.
1. Select the site, select **Site Properties** from the **File** menu, and then click the **Advanced** tab.

![Site Properties dialog box](image)

2. (Optional) Use the **Connection Retry** text box to enter the number of times WS_FTP Pro tries again to connect if it fails on the first attempt.

3. (Optional) Enter the **Network Timeout**, the number of seconds that elapses before WS_FTP Pro stops waiting for an FTP site to respond. Normally, the network timeout is determined by your Winsock DLL. (You can set it to *less* time than your Winsock DLL, but setting it higher won’t affect anything.)

4. (Optional) The **Remote Port** for the FTP protocol is normally 21, however, it may be something different if you are going through a firewall, or if the FTP site administrator has assigned the FTP protocol to another port.

5. (Optional) Select **Passive transfers** to have your PC establish the data connection to the FTP site (if the site allows passive transfers). (Normally, when you connect to an FTP site, the FTP site establishes the data connection to your PC.)

Use passive transfers for local area networks behind some types of router–based firewalls or behind a gateway requiring passive transfers.
Editing the Firewall Options for Configured Sites

The firewall options for individual sites are closely related to the overall firewall options for WS_FTP Pro Explorer, so these are discussed in “Using a Firewall” on page 70.

Organizing Sites in Folders

You can organize your configured sites in hierarchical folders. For example, you might have one folder for FTP sites that offer games, and another for FTP sites from which you download software updates.

Since folders also have the properties described in “Session Options” on page 67, you may also want to organize your sites in folders that have properties set to complement the way you work with the sites inside the folder.

For example, you might have a folder for FTP sites on which you have permission to upload files; for that folder, you could select the option **Force lower case remote names.** You could also have a folder for busy sites that take a long time to download from; for that folder, you might want to make sure **Show Transfer Progress Dialog** is not selected.

To create a folder for organizing sites,

1. Select **New...** from the **File** menu to view the New Site/Folder dialog box.

2. Click **Folder for organizing configured sites.**

3. In the text box, enter a name for the folder, and then click **Finish.**
Connecting and Disconnecting

Once you have configured an FTP site, the next time you want to connect to the same site, just double-click it. WS_FTP Pro Explorer comes with a number of preconfigured popular FTP sites. Double-click the preconfigured sites to connect to any of these sites. You can customize these sites and add new ones.

To disconnect from an FTP site, select the site and select Disconnect from the File menu. To disconnect from all sites to which you are connected, select Disconnect All.

Working with Files and Folders

After connecting to an FTP site, you use standard Windows Explorer techniques to view and browse files and folders on the site.

Changing Disk Drives and Folders

If the FTP site allows it, you can change disk drives: select Change Folder from the File menu, enter the drive letter and a semicolon (for example, d:;), and click OK. Don’t enter a trailing slash (\).

To change folders, do one of the following:

• Use standard Windows techniques.
• Select Change Folder from the File menu.
Creating Folders

Usually, FTP clients who log on to a site anonymously can view and copy folders, but not create them. However, the actual permissions for a user depend on how the site administrator has set up the rules. If you’re allowed to, you create a folder by selecting New Folder from the File menu.

Locating and Viewing Files and Folders

If you’re new to FTP, you’ll need to know how to determine what files are available on a site. Look for a file called readme, readme.txt, index, or 00index to get a description of the available files, as well as other site information. You can also try the pub directory.

Note

You can use the WS_FTP Find Utility to locate a particular file or folder on a large, complex FTP site. To run the WS_FTP Find Utility, click the Start button and select Programs -> WS_FTP Pro -> WS_FTP Find Utility. Detailed information about the Find Utility can be found in its online Help.

After performing folder or file operations outside of WS_FTP Pro Explorer, you can refresh the window to display any recent changes to the current folder, or to deselect any selected files or folders. To refresh, select Refresh from the View menu (or press F5).

Viewing Only Certain Types of Files

If the FTP site has a large number of files, you can limit the types of files displayed by using a remote file mask. However, this option also masks folders, so don’t use it if you’ll need to browse the hierarchy on the site to find the files you want.

If you use a remote file mask, you should know exactly which folder you want to work with on the site and enter it as the Initial Remote Folder on the Startup tab of Site Properties.

To view only certain types of files:

1. Select Site Properties from the File menu, and then click the Startup tab.

2. Enter the file extension in the Remote file mask text box. For
example, to display only files with the extension .txt, enter *
.txt as the remote file mask.

If you are connected to a UNIX host, you can use –al or –la in
the remote file mask to view all files, including hidden (.) ones.
Or, you can use –altr to receive file names in date sequence.

[For those who are familiar with DOS FTP clients: You can also
enter any argument string you would use with a “Dir” command.]

3 Select Refresh from the View menu (or press F5).

Opening (Executing) a File on an FTP Site

When you open (execute) a file on an FTP site, WS_FTP Pro Explorer
transfers the file to the Temporary Directory of your PC (indicated on
the Directories tab of WS_FTP Pro Explorer Properties) and then
opens the file in the associated application.

To open (execute) a file:

1 Connect to the FTP site and locate the file you want to open.

2 Do one of the following:
   • Double-click the file.
   • Select Open from the File menu.
   • Select Open... to change the file transfer mode.

   Select the desired transfer mode and then select Open it.

WS_FTP Pro Explorer copies the file to your temporary folder with a
new unique name and then opens it in the application associated with
the file extension. (To see where the temporary folder is located, check
the Directories tab of WS_FTP Pro Explorer Properties.)
If you want to keep the file you opened, you can usually save it with a new name by selecting **Save As...** from the **File** menu of the application that opened it. (If you do this, delete the temporary file as described below.) Or, you can just close the file and leave it in the temporary folder, but the file has the name assigned by WS_FTP Pro Explorer. You can also rename the file and move it somewhere else.

If you don’t want to keep the file you opened, locate the file in the temporary folder, and delete it. (To see where your Temporary Directory is located, select **WS_FTP Pro Explorer Properties** from the **File** menu and click the **Directories** tab.)

**Editing Files on an FTP Site**

You can edit a file on an FTP site if you have permission to do so. When you edit a file on an FTP site, WS_FTP Pro Explorer transfers the file to the Temporary Directory (indicated in the **Directories** tab of **WS_FTP Pro Explorer Properties**) and then opens the file in the associated application.

To edit a file on an FTP site:

1. Connect to the FTP site and locate the file you want to open.
2. Do one of the following:
   - Select **Open** from the **File** menu. The file is copied to your temporary directory with a new unique name, and then opened in the application associated with its file extension.
   - Select **Open...** to change the file transfer mode.

Select the desired transfer mode and select **Open it**.

---

*Using the Explorer Interface*
3 Edit the file and save it with its original name by choosing `Save As...` from the `File` menu of the application that opened the file.

4 Upload the file to the FTP site, as described in “Uploading Files and Folders” on page 63.

**Naming and Renaming Files**

You can rename a file on an FTP site if you have permission to write to that site. To rename a file, highlight the file and select `Rename` from the `File` menu. Enter the new name for the file and click `OK`. If you selected multiple files, you are prompted to rename each file.

You can also have WS_FTP Pro Explorer prompt you for a path/ filename at the time of transfer. For more information, see “Session Options” on page 67.

**Changing Permissions on UNIX Sites (chmod)**

To change the mode or permissions for a UNIX file on an FTP site (provided you have permission):

1 Select the file.

2 Select `chmod` from the right–mouse menu.

   The Remote File Permissions dialog box appears. Select whatever options you want and click `OK`. For detailed information on changing the modes, see “Changing Permissions on UNIX Sites (chmod)” on page 28.

**Deleting Files**

If you are permitted to delete files from a particular FTP site, highlight the file and select `Delete` from the right–mouse menu.

**Deleting Folders**

To remove an empty folder, select the folder and click `Delete`. Or, click `Delete` with nothing selected and enter the name of a folder when prompted.

If the folder is not empty, you will not be able to delete it unless you have selected `Allow deletion of non-empty folders` on the `Preferences` tab of WS_FTP Pro Properties.
Transferring Files and Folders

Before you transfer a file or files, open a window showing the source files, as well as a window on the destination folder.

1. Select the file(s) you want to transfer and select Open... from the right–mouse menu.

2. Click Save it to disk, and enter the appropriate information.

Downloading Files and Folders

Downloading a file or folder copies it from an FTP site to your PC. To download files from an FTP site to the Default Download Directory (on the Directories tab of WS_FTP Pro Explorer Properties):

1. Select the file(s) you want to transfer and select Open... from the right–mouse menu.

2. Click Save it to disk, and enter the appropriate information.
To transfer files (or folders) from an FTP site to a location other than the Default Download Directory:

1. Select the file(s) to download, and then select **Copy** from the **Edit** menu.
2. Locate and select the folder to which you want to copy the file(s), and then select **Paste** from the **Edit** menu.

For information on dragging and dropping instead of copying and pasting, see “Using Drag and Drop” on page 64.

### Uploading Files and Folders

Uploading a file or folder copies it from your PC to an FTP site.

1. Connect to the FTP site to which you want to upload the file(s), then locate the desired destination folder.
2. Locate and select the file(s) you want to upload, and select **Copy** from the **Edit** menu.
3. Highlight or open the destination folder on the FTP site, and select **Paste** from the **Edit** menu.

For information on dragging and dropping instead of copying and pasting, see “Using Drag and Drop” on page 64.

### Moving Files and Folders

You are able to move a file only when you have permission to delete files from the source location, and permission to write to the destination location. Moving a file copies the file to a destination location and then deletes it from the source location.

---

**Note**

You can move files *only* by dragging and dropping. You can not move files using menu commands.

---

By default, the move option is disabled; to turn it on:

1. Select **WS_FTP Pro Explorer Properties** from the **File** menu.
2. Click the **Preferences** tab.
3. Make sure **Allow files and directories to be moved** is checked.
To move a file, do one of the following:

- Hold the Shift key down while you drag the file.
- Drag the file using the right–mouse button, and then select **Move Here** from the right–mouse menu. (To get prompted for path/file name while moving files, see “Session Options” on page 67.)

---

**Note**

To specify the file transfer mode when you move a file, you’ll need to first copy the file using the procedure in “Using Transfer Modes” on page 65. After the file is copied, delete it from the source location.

---

**Using Drag and Drop**

For uploads, downloads, and the moving of files, you can use drag and drop. This is handy if it’s easy to arrange the source and destination locations so you can see them both. You have these options:

- Drag and drop with the left mouse button.
- Drag and drop with the right–mouse button to get a pop–up menu with various options on it.
- Shift–drag to move the file. For more information, see “Moving Files and Folders” on page 63.

The cursor changes when you drag and drop, depending on whether you’re moving or copying.

![Cursor when moving](image)

![Cursor when copying](image)

If it’s difficult to display both the source and destination locations at the same time, use **Copy** and **Paste** for uploading or downloading.

To use **Copy** and **Paste**:

1. Select the file(s) you want to transfer.
2. Select **Copy** from the **Edit** menu.
3. Highlight or open the destination folder.
4. Select **Paste** from the **Edit** menu.
Most procedures in this chapter tell you to use **Copy** and **Paste**, but you can always drag and drop instead. Likewise, most procedures tell you to select a command from the menu bar, but you can also use the right–mouse menu or a keyboard shortcut whenever you like.

**Using Transfer Modes**

Files can be transferred in ASCII or binary transfer mode. *Binary transfer mode* transfers a file as an exact copy of the original. A binary file can run only on the machine for which it was compiled. Binary mode contrasts with *ASCII mode*, which treats a file as text, translating the end–of–line characters during the transfer to accommodate differing operating systems. ASCII transfer mode is used for plain text, postscript, HTML, or other ASCII format.

Binary transfer mode is used for data, images, executables, or compressed files. Binary mode should also be used if there is no file extension, the file extension is not registered, or you are unsure of the file type. (If you know that the FTP site and your PC use the same operating system, you can use binary mode for all files.)

*Auto mode* transfers all files in binary mode unless the extension is entered on the **Extensions** tab of the **WS_FTP Pro Explorer Properties**, in which case the file is transferred in ASCII mode.

To enter the file extensions that indicate ASCII files, select **WS_FTP Pro Explorer Properties** from the **File** menu and click the **Extensions** tab.
To specify the transfer mode when copying or saving:

1. Select the file.
2. Select **Open...** (with ellipses) from the **File** menu.

3. Select the desired transfer mode (**ASCII**, **Binary**, or **Auto**).

4. Do one of the following:
   - To open the file, select **Open it**.
   - To copy the file to the Default Download Directory, select **Save it to disk**.

**Remote–to–Remote Transfers**

You can transfer files from one FTP server to another if the destination site supports third–party transfers.

1. Connect to the destination site and locate the desired destination folder.
2. Connect to the source site and open the folder from which you want to copy the file(s).
3. Locate and select the file(s) you want to copy, and select **Copy** from the **Edit** menu.
4. Select the folder to which you want to copy the file(s), and select **Paste** from the **Edit** menu.
Program Options

You can set a number of options to determine how WS_FTP Pro Explorer works.

Session Options

There are a number of session options you can set to make WS_FTP Pro Explorer work just the way you like. These options are on the Preferences tab in the WS_FTP Pro Explorer Properties, the Session tab in Site Properties (for a site), and in Site Properties for a folder. (For tips on how you might set folder properties, see “Organizing Sites in Folders” on page 56.)

Thus, you can determine the way the application performs all transfers, as well as customize the way it works with particular sites.

1 Do one of the following:

- To set an option for a particular site, select the site, select Site Properties from the File menu, and click the Session tab.
- To set an option for a group of sites in a folder, select the folder and select Site Properties from the right mouse menu.
• To set an option for all sites, select **WS_FTP Pro Explorer Properties** from the **File** menu and click the **Preferences** tab.

2 (Optional) Select **Prompt for Destination File Names** to enable file name prompting: as each file is transferred, you are shown the proposed name and allowed to change the name, the path, or both.

3 (Optional) Some UNIX sites support only file names that are all lower case letters. For example, if you want to upload *MyText.txt* to one of these sites, you want the file name on the FTP site to be *mytext.txt*. Select **Force Lowercase Remote Names** to convert all file names to lower case when doing uploads.

---

**Note**

You can not automatically convert file names to lower case when downloading files. However, you can do the automatic conversion when transferring from one FTP site to another.

---

4 (Optional) Select **Show Transfer Progress Dialog** to display a dialog box during transfers. It displays the status of the transfer and provides a **Cancel** button that lets you cancel the transfer.

![File Transfer Dialog](image)

5 (Optional) Select **Verify Deletions** to have WS_FTP Pro prompt you for confirmation when you delete files.

6 (Optional) When **Prompt for overwrite of same or newer files** is selected and you transfer a file, WS_FTP Pro checks to see if there is already a file in the destination folder with the same or newer date and time. If so, WS_FTP Pro asks if you want to overwrite the file.
7 (Optional) Select **Enable auto reget of failed transfers** to try to resume interrupted transfers. Most, but not all, FTP sites allow the “auto reget” option. It works like this: when a transfer is interrupted due to a lost connection or cancellation, WS_FTP Pro tries to resume the transfer the next time you connect to the site.

8 (Optional) Select **Preserve file time on transfer from remote** if you want files downloaded from an FTP site to maintain their original creation dates and times. If *not* selected, the file date and time are updated to the date and time of the download.

**Note**
You can not retain the date and time when uploading unless you are uploading to an FTP site which is using Ipswitch WS_FTP Server.

If you choose not to resume the transfer, you are left with a partial file in the destination folder. You should delete this file.

**Directory/Folder Options**
To check the location of your WS_FTP Pro Explorer folders, select **WS_FTP Pro Explorer Properties** from the *File* menu and click the *Directories* tab.

![WS_FTP Pro Explorer Properties](image)

The **Program Directory** shows where the WS_FTP Pro Explorer application is installed.
The **Temporary Directory** is the folder on your PC to which WS_FTP Pro Explorer copies files you open. By default, this directory is named WS_FTPE and is located in your Temp folder.

The **Default Download Directory** is the folder on your PC to which a file is copied if you open it using the Open... command and then select **Save it to disk** in the dialog box.

**Logging**

The **Logging** tab lets you keep a log of FTP messages showing the date, time, source, and destination of all file transfers.

**Using a Firewall**

Some organizations separate their networks from the rest of the Internet with a firewall. If your company uses a firewall, and the firewall is configured to block FTP transfers, you can configure WS_FTP Pro Explorer to go through the firewall. To do this, you’ll need to get information about your firewall from your network administrator; you’ll need the **Firewall Type**, as well as the following information.
• For a “SITE hostname” firewall type, you’ll need **Host Name** (or IP Address) and User Name (User ID).

• For a “Transparent” firewall type, you’ll need **User Name** (User ID) and Password.

• For “USER with no logon” or “Proxy OPEN” firewall types, you’ll need the **Host Name** (or IP Address). The User Name and Password are ignored.

• For “USER after logon,” “USER remoteID@remoteHost fireID,” or “USER fireID@remoteHost” firewall types, you’ll need **Host Name** (or IP Address), **User Name** (User ID), and **Password**.

Use the **WS_FTP Pro Explorer Properties** to set the same firewall settings for all sites. Use the **Site Properties** to specify the firewall settings for a particular site.

1. Select either **WS_FTP Pro Explorer Properties** or **Site Properties** from the File menu

2. Click the **Firewall** tab. (If you are setting firewall properties for a site, check **Use Firewall**.)

3. Enter the **Host Name or IP Address** of the firewall.

4. Enter the firewall **User Name** and **Password**.

5. Enter the **Port** number of the firewall.
6. Select the **Firewall Type**.

**Note**
Do not select **Save Password** unless you are the only one who has access to the WS_FTP folder on your computer!

The next time you attempt to connect to an FTP site, your PC connects to your firewall, and (usually) the firewall actually makes the connection to the FTP site.

**Setting ASCII (Text) Extensions**

When **Auto** is the transfer mode, WS_FTP Pro Explorer transfers all files in binary mode, unless the file extension is listed as ASCII. Select **WS_FTP Pro Explorer Properties** and then click the **Extensions** tab.

The list box lists all file extensions that WS_FTP Pro Explorer transfers in ASCII mode when Auto mode is selected. The list displayed here is store in the `ws_ftp.ext` file.
To add a file extension to the list:

1. In the ASCII Filenames and Extensions text box, enter the file extension. The extension can be up to nine characters long and can contain periods.
2. Click the Add button.
   The extension appears in the list box.

To delete a file extension from the list box, select the extension and click the Delete button.

**Working with Sounds**

You use the Windows Control Panel to change or turn off sounds in WS_FTP Pro Explorer.

1. Click the Start button on the Windows taskbar.
2. Select Settings, and then Control Panel.
3. Double-click the Sounds icon.
4. Locate the WS_FTP Pro Explorer area of the scrolling list box.
5. Select the sound you want to change.
6. Select (none) or a new sound from the Sound Name drop–down list, or Browse to find another sound.
Using the Explorer Interface
Chapter 4: Using the Command Line

You can use the command line from the MS-DOS prompt to run the WS_FTP Pro classic interface under Windows 95, Windows 98, or Windows NT. This chapter covers the use of the command line for running the 32-bit version of WS_FTP Pro. If you are running the 16-bit version, see the online Help for instructions on using the command line.

When you use the command line, you are actually running a subset of the functionality of the classic interface. Using the command line, you can:

- Upload and download files
- Specify ASCII or binary transfer mode
- Convert file names to lowercase when uploading
- Set up pre-scheduled transfers

However, the command line doesn’t provide the means to rename files on an FTP site, delete files from an FTP site, or create folders on an FTP site. Nor can you preserve time stamps or convert file extensions when transferring files.

In order to be able to use the command line from any location on your hard disk, we recommend that you place the WS_FTP Pro folder in the Path statement in your Autoexec.bat file – if you are running Windows 95 or Windows 98. If you’re using Windows NT, add the WS_FTP Pro folder to the path variable in the System Environment. Otherwise, change to your .ini file folder when you use the commands described below.
Basic Command Line Syntax

To use the command line, you type the command name `ftp95pro` followed by whatever arguments you need to complete your task.

```
ftp95pro -p Damion -s local:c:\Tag.doc -d Damion:/Tag.doc
```

The three arguments used most often are `-p`, `-s`, and `-d`. These three arguments tell WS_FTP Pro, respectively, the name of the site configuration, the source of the transfer, and the destination of the transfer.

**Note:** The `-p` argument must be the first argument after the `ftp95pro` command, unless you have more than one `ws_ftp.ini` file on your computer.

WS_FTP automatically logs you off the FTP site when the transfer is done.

Using the Names of Configured Sites

You can use names of configured sites to do FTP transfers from the command line. If your site names have no spaces in them, type the commands as shown below. If, however, your site names have spaces, enclose the entire command in quotes, or “Transferring Files with Spaces in the File Names” on page 82.

Uploading Files

Let’s suppose that in the classic interface of WS_FTP Pro, you have configured a collection of site properties and named the configured site Damion. This site name logs you on to an FTP site whose host name is `ftp.Damion.com`. Let’s also suppose that on your C: drive, you have a folder named `Sports` and a file named `Tag.doc` in that folder. To upload the `Tag.doc` file to a folder named Drop on the Damion site, you enter the command name followed by the site name, the source location, and the destination location. At the MS-DOS prompt, type:

```
ftp95pro -p Damion -s local:c:\Sports\Tag.doc -d Damion:/Drop/Tag.doc
```

You’ll notice that the second option omits the file name from the destination location. You can do this when you want the transferred file to have the same name as it does in the source location. However, note that you must enter the trailing slash after the destination folder in order for this to work.

Renaming Files

To rename a file as you upload it, enter a new file name after the destination
folder. For example, to upload the Tag.doc file and rename it NewTag.doc on the FTP site, type:

ftp95pro -p Damion -s local:c:\Sports\Tag.doc -d Damion:/Drop/NewTag.doc

**Downloading Files**

Use the same command syntax as described above for downloading files, except that, for clarity, you might want to place the FTP site before the local system. (WS_FTP Pro will transfer the file from the location following -s to the location following -d, no matter which you enter first in the command line.)

Let’s suppose you want to download a file named War.doc from a folder named Pub on the Damion site, and let’s assume you want to copy it to the Games folder on your hard disk. Type:

ftp95pro -p Damion -s Damion:/Pub/War.doc -d local:c:\Games\War.doc

**Tip:** You can leave off the -s and -p, but when you do so, you must enter the source location first, and the destination second. For example,

ftp95pro -p Damion Damion:/Pub/War.doc local:c:\Games\War.doc

**FTP Site Accounts and Passwords**

When you use a configured site from the command line, WS_FTP Pro uses the User ID, Password, and Account Name you saved in the site configuration.

If you have saved a password with the site, the command line logs you on using the saved password. If you have not saved a password with the site, you will receive the regular password prompt.

If you have saved an account name in the site configuration, the command line logs you on using the saved account name. If you have not saved an account name, you can use the -c argument to specify the account name when you enter the command line. Assuming you are trying to do the first transfer described in this chapter, but want to use an account named pisa, you would enter:

ftp95pro -p Damion -c pisa -s local:c:\Sports\Tag.doc -d Damion:/Drop/Tag.doc
Using a Batch File

Instead of typing the command at the MS-DOS prompt, you may find it more expedient to enter the command line into a batch file (a text file with the file extension .bat). This makes it easier to correct mistakes and to run the same command again.

You run the command by invoking the .bat file at MS-DOS prompt, double-clicking the icon for the .bat file from within Windows, or running the .bat file from another application (such as a program scheduler).

Here is a batch file (for the example at the beginning of this chapter) as viewed from a Windows text editor:

When you run the batch file named Tag.bat, WS_FTP Pro uploads the Tag.doc file to the Damion FTP site.

Note that using a batch file involves placing the command name ftp95pro at the beginning of each line in the file. Since each instance of the command name starts the WS_FTP Pro application (and connects to the FTP site), you would only use a batch file to work with one command at a time. If, on the other hand, you want to issue a group of commands, follow the procedure in “Multiple Folders or Commands” on page 79.

Remember that if a file name has a space in it, you must enclose the entire command in quotes. Furthermore, you must include the -i argument if the WS_FTP Pro folder is not in your path statement, or if the .ini file you want to use is not in the same folder as the WS_FTP Pro application. For more information, “Specifying the .ini File” on page 84.

File Transfer Modes

You can transfer files in binary mode or in ASCII mode. You’ll want to use binary mode to transfer all files unless you know the file contains only text, then you’ll want to use ASCII mode.

To specify the transfer mode, you use the -binary or -ascii argument in
the command. To be sure that you transfer the *Tag.doc* file (the first example in this chapter) using binary mode, enter (at the MS-DOS prompt or in a batch file):

```
ftp95pro -p Damion -s local:C:\Sports\Tag.doc -d Damion:/Drop/Tag.doc -binary
```

If however, the file were a text file named *Tag.txt*, and you want to be sure it is transferred correctly, you’d enter (at the MS-DOS prompt or in a batch file):

```
ftp95pro -p Damion -s local:C:\Sports\Tag.txt -d Damion:/Drop/Tag.txt -ascii
```

---

### Note

When you don’t specify the transfer mode in the command line, WS_FTP Pro transfers the file in whatever file transfer mode is the default in the WS_FTP Pro classic interface. Therefore, if you plan on using the command line more than just occasionally, set the **Startup Transfer Mode** to Auto Detect. (To do this in the WS_FTP Pro classic interface, go to the **Session** (cont’d) tab of the Options dialog box.)

---

### Transferring Multiple Files from the Same Location

*If all the files you want to transfer are in the same folder*, you can use the wildcard characters, *, and ?, in the file name. To transfer all files in the Sports folder (described in the first example in this chapter), enter (at the MS-DOS prompt or in a batch file):

```
ftp95pro -p Damion -s local:C:\Sports\*.* -d Damion:/Drop/
```

Or, to transfer all .doc files in the same folder, enter (at the MS-DOS prompt or in a batch file):

```
ftp95pro -p Damion -s local:C:\Sports\*.doc -d Damion:/Drop/
```

To transfer multiple files not in the same folder, see the next section.

---

### Multiple Folders or Commands

To transfer files to or from multiple source or destination folders, or to issue multiple commands, use the `-m` argument followed by the name of a text file that contains the commands. To transfer files from several locations on the hard
disk described in the first example in this chapter, enter (at the MS-DOS prompt or in a batch file) something like:

```
ftp95pro -m xferall.txt
```

where the content of `xferall.txt` (as viewed in Windows Notepad) is:

```
-p Damion -s local:c:\Sports\Frisby.doc -d Damion:/Dropoff/
-p Damion -s local:c:\Party\Invite.bmp -d Damion:/ToPrint/
-p Peapod -s local:c:\Recipes\Goulash.txt -d Peapod:/Incoming/
```

Note that:

- The command name `ftp95pro` must not appear in the text file.
- Each line of text must contain only one command line.
- Each command line can contain any of the arguments described in this chapter.
- If a file name has a space in it, the entire command line must be enclosed in quotes.

---

**Pre-scheduled Transfers ("Automated Transfers")**

You can use the command line to set up transfers that you want to run automatically at a certain time. To do this, you create a batch file as described above, and then run the batch file using a scheduler such as the AT command in Windows NT, the Task Scheduler in Windows 98 or Internet Explorer 4, or the System Agent in Windows 95 w/plus.

You can use the `-quiet` parameter in pre-scheduled transfers to prevent WS_FTP Pro from displaying a message box if and when an error occurs. This is particularly useful for avoiding a situation in which WS_FTP Pro might otherwise prompt for user input, such as clicking the OK button in an error message. This way, you can pre-schedule transfers to run automatically when you’re not at your computer. (When you return to the computer, you can always check the log file to see if there were any problems.)
To use the examples shown above, you could do a pre-scheduled transfer by creating the following batch file:

```
\ftp95pro -m \xferall.txt
```

as well as the following text file:

```
-p Damion -s localc:\Sports\Frisby.doc -d Damion:\Dropoff/
p Damion -s localc:\Party\Invite.bmp -d Damion:\ToPrint/
p Peapod -s localc:\Recipes\Goulash.txt -d Peapod:\Incoming/
```

Then, you could run the `auto10.bat` file at 10:00 PM each night using a scheduler.

Remember that if a file name has a space in it, you must enclose the entire command in quotes.

---

### Transferring a Folder Containing Subfolders

Since you can’t create folders using the command line, you won’t be able to transfer a folder by simply specifying the folder name in the command line, or by using wildcards.

To transfer a folder using the command line, you’ll need to use some other method to create the folder and its subfolders in the destination location. Then, you can use the same procedure as described in “Multiple Folders or Commands” on page 79. In the text file, you’ll have one command line for each subfolder.

For example, let’s suppose you want to transfer the entire folder named `Sports` to the `Damion` FTP site. The `Sports` folder contains a number of files as well as three subfolders named `News`, `Stats`, and `History`.

Once you have created the `Sports` folder and its subfolders in the destination location, create the following text file:
Using the Command Line

The command you enter (at the MS-DOS prompt or in a batch file) is:

```
ftp95pro -DirStruct.txt
```

Converting File Names to Lower Case

When uploading files, you can have WS_FTP Pro convert file names to lower case by adding the `-lower` argument at the end of the command line. For example, if the file you want to transfer is named `Tag.doc`, WS_FTP Pro can upload it as `tag.doc`. To do this (as described in the first example in this chapter), enter (at the MS-DOS prompt or in a batch file):

```
ftp95pro -p Damion -s local:c:\Sports\Tag.doc -d Damion:/Drop/ -lower
```

Transferring Files with Spaces in the File Names

If you are transferring a file whose name has spaces in it, you have three options. You can enclose the entire command line in quotes, use the MS-DOS name of the file (as shown in the Dir listing you get from the MS-DOS prompt), or you can do a wildcard transfer using asterisks.

**Enclosing the command line in quotes.** If the file you want to transfer is named `Tag Top.doc`, enter (at the MS-DOS prompt or in a batch file):

```
"ftp95pro -p Damion -s local:c:\Sports\Tag Top.doc -d Damion:/Drop/Tag Top.doc"
```

**Using the MS-DOS name.** If the file you want to transfer is named `Tag Top.doc` in Windows 95, but appears as `Tag~1.doc` when you use the Dir command at the MS-DOS prompt, you can use the MS-DOS file name to
transfer the file. To do this (using the first example in this chapter), enter (at the MS-DOS prompt or in a batch file):

```
ftp95pro -p Damion -s local:c:\Sports\Tag~1.doc -d Damion:/Drop/Tag~1.doc
```

This creates a file on the FTP site named `Tag~1.doc`.

**Doing a wildcard transfer.** If the file (with spaces in its file name) is the only file in its folder, you can use a wildcard transfer to retain the Windows name (with the spaces). So, if `Tag Top.doc` were the only file in the `Sports` folder on your hard disk, you could enter (at the MS-DOS prompt or in a batch file):

```
ftp95pro -p Damion -s local:c:\Sports\*.* -d Damion:/Drop/
```

This creates a file named `Tag Top.doc` on the FTP site.

---

**Using an IP Address, Host Name, or FTP URL**

Instead of using the name of a configured site as described in all the previous examples, you can use an IP address, host name, or URL. Note, however, that when you do this, you will automatically be logged on *anonymously*; you will not be logged on to an account, nor will you be prompted for a password. So, if you want to use an account, you must use the name of a configured site.

However, let’s suppose that you want to log on anonymously, and that the host name of the `Damion` FTP site is ftp.Damion.com and its IP Address is 111.222.333.444. You can perform the transfer described at the beginning of this chapter by omitting the `-p` (site name) argument and typing the host name, IP Address, or URL in place of the site name.

For example, enter (at the MS-DOS prompt or in a batch file):

```
ftp95pro -s local:c:\Sports\Tag.doc -d ftp.Damion.com:/Drop/Tag.doc
```

or,

```
ftp95pro -s local:c:\Sports\Tag.doc -d 111.222.333.444:/Drop/Tag.doc
```

or,

```
```

or,

```
ftp95pro -s local:c:\Sports\Tag.doc -d ftp://damion:/Drop/Tag.doc
```

---
Specifying the .ini File

The \(-i\) argument lets you specify the .ini file that the WS_FTP Pro command line will use. You need to use the \(-i\) argument to identify the WS_FTP Pro .ini file if:

- You have more than one .ini file for WS_FTP Pro on the same computer
- The .ini file you want to use is in a different folder than the WS_FTP Pro application
- You are running a batch file and the WS_FTP Pro folder is not in your Path statement

For example, enter (at the MS-DOS prompt or in a batch file):

\[
\text{ftp95pro } -i \text{ C:/Programs/WS_FTP/mywsftp.ini ftp95pro } -p \text{ Damion } -s \text{ local:c:\Sports\Tag.doc } -d \text{ Damion:/Drop/Tag.doc}
\]

\textbf{Note:} If you use the \(-i\) argument, it must be the very first argument following the \texttt{ftp95pro} command.

Extras

There are a few more arguments and uses of the command line that some users have found helpful. These are listed below.

To have WS_FTP Pro display a dialog box that prompts you for the command line, type: \texttt{ftp95pro } \(-\text{ask}\)

To launch the WS_FTP Pro classic interface and default to the site configuration for the Damion site: \texttt{ftp95pro } \(-p \text{ Damion}\)

To prevent WS_FTP Pro from displaying error messages, use the \(-\text{quiet}\) argument. This is useful if you want to do automated transfers when no-one is around to respond to a message. An example:

\[
\text{ftp95pro } -p \text{ Damion } -s \text{ local:c:\Sports\Tag.doc } -d \text{ Damion:/Drop/Tag.doc}
\]
Summary

Here is a list of all arguments you can use in the command line. Note that the `-i` argument must precede the `-p` argument when both are used, and that both of these arguments must precede any other arguments.

<table>
<thead>
<tr>
<th>Arguments (alphabetical)</th>
<th>When to use</th>
<th>Important restrictions</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>-ascii</code></td>
<td>Use <code>-ascii</code> when transferring text files.</td>
<td></td>
</tr>
<tr>
<td><code>-binary</code></td>
<td>Use <code>-binary</code> when transferring non-text files such as executable programs, word processing documents, and so on.</td>
<td></td>
</tr>
<tr>
<td><code>-c account</code></td>
<td>Use <code>-c</code> to work with sites that require an account for the user to log in, or to access partitions. <code>account</code> is the name of your account on the FTP site.</td>
<td></td>
</tr>
<tr>
<td><code>-d path_and_filename</code></td>
<td>Use <code>-d</code> to indicate the destination path and desired file name of the file you want to upload or download.</td>
<td></td>
</tr>
<tr>
<td><code>-i infile</code></td>
<td>Use <code>-i</code> if you have more than one <code>.ini</code> file for WS_FTP Pro, the <code>.ini</code> file is in a folder other than that of WS_FTP Pro, or you are running a batch file and the WS_FTP Pro path is not in your Path statement. <code>ini-file</code> is the path and name of the <code>.ini</code> file.</td>
<td>If you use the <code>-i</code> argument, it must precede all other arguments.</td>
</tr>
<tr>
<td><code>-lower</code></td>
<td>Use <code>-lower</code> to have WS_FTP Pro convert file names to lower case letters when you transfer from your PC to an FTP site.</td>
<td>If you use the <code>-lower</code> argument, it must be at the very end of the command.</td>
</tr>
<tr>
<td><code>-m text_file</code></td>
<td>Use <code>-m</code> to do transfers that involve multiple source locations, multiple destinations, or multiple commands. <code>text_file</code> is the name of the file that contains the commands.</td>
<td></td>
</tr>
<tr>
<td><code>-p site_name</code></td>
<td>Use <code>-p</code> to connect to a configured site, where <code>site_name</code> is the name of the site configuration. The site configuration must be in the default <code>.ini</code> file or in the <code>.ini</code> file specified with the <code>-i</code> argument.</td>
<td>The <code>-p</code> argument must precede all arguments except <code>-i</code>.</td>
</tr>
<tr>
<td><code>-quiet</code></td>
<td>Use <code>-quiet</code> to prevent WS_FTP Pro from displaying message boxes.</td>
<td></td>
</tr>
<tr>
<td><code>-s path_and_filename</code></td>
<td>Use <code>-s</code> to indicate the source path and file name of the file you want to upload or download.</td>
<td></td>
</tr>
</tbody>
</table>
Chapter 5: Troubleshooting

This chapter lists some of the common FTP connection and file transfer problems. For more information, see our KnowledgeBase in the Support area of the Ipswitch web site, www.ipswitch.com.

Problems Connecting to an FTP Site

Problem: I cannot connect to an FTP site.
Solution: Make sure you have an active dial-up or direct Internet connection. WS_FTP Pro is not a dialer; it calls the Winsock DLL and uses the dialer or direct connection specified there.

Problem: I cannot log on to an FTP site.
Solution: Check your file and folder access permissions on the FTP site. These permissions may only be set by the FTP site administrator; they cannot be changed by WS_FTP Pro.

Problem: My connection closes after n minutes of inactivity.
Solution: The FTP site determines the connection timeout, and most FTP sites close the connection after a few minutes of inactivity. This setting can be changed only by the FTP site administrator, not from WS_FTP Pro.

Problem: WS_FTP Pro can only connect to the Ipswitch FTP site and nothing else.
Solution: You are using a pre-release version of WS_FTP Pro which has timed out. It connects to ftp.ipswitch.com to allow you to download the current version of WS_FTP Pro.

Problem: WS_FTP Pro can only connect to sites using the IP address, for example, 111.222.333.444.
Solution: Configure the DNS (Domain Name Server) in your stack. Talk to your network administrator or your Internet provider for the proper values for DNS.

Problem: WS_FTP Pro doesn’t work with my AOL connection.
Solution: Older versions of AOL uses a 16-bit TCP/IP stack and will not work with 32-bit TCP/IP applications. For more information on AOL’s Winsock support, see the FTP section in your AOL application.
If you have a 16-bit version of AOL, you will need to run the 16-bit version of WS_FTP (FTPPRO.EXE).

**Problems Viewing and Deleting Files and Folders**

*Problem:* When I connect to an FTP site, the list box for the site is blank or contains garbage.

*Solution:* Change the host type. Try looking in the message log to see if the host type of the FTP site is identified. If you can’t figure out the host type, you can try common types such as “UNIX (standard),” “Sun Solaris,” or “WinQVT/Net.” If those don’t work, try “Auto-detect.” If you are still having problems, see the Folder Display Problems topic in the on-line help.

*Problem:* When I connect to an FTP site, the list box for the site is blank. In the status window the last thing I see is “DoDirList returned 4”.

*Solution:* Contact your Internet provider to get the proper setting for the Maximum Transfer Unit (MTU) of your network stack. (You can try 552 or 576 as they seem to be common proper values.)

*Problem:* Why can’t I delete a folder?

*Solution:* If a folder is not empty, you can delete it only if you have selected Allow deletion of non-empty folders on the Pro tab of Program Options.

**Problems Transferring Files**

*Problem:* I’ve received one or more “Blocking call cancelled” messages and the file transfer is incomplete.

*Solution:* You can try selecting Passive transfers on the Advanced tab of Site Properties. If that doesn’t help and you are using the Microsoft TCP/IP stack (which is part of the Windows 95 and NT operating systems), try setting the Maximum Transfer Unit (MTU) to 576.

*Problem:* I cannot open a folder on an FTP site or transfer a file.

*Solution:* Make sure you are using a valid login name and password. Otherwise, try selecting the Anonymous check box in the Site Properties; or, contact the system administrator of the FTP site to which you are trying to connect.
**Problem:** WS_FTP Pro only returns NNNNN bytes of a file and can never retrieve the whole file.

**Solution:** Set your Maximum Transfer Unit (MTU) in your program stack to 576.

**Problem:** WS_FTP Pro does not always return a complete file and leaves off from 50 to 512 bytes.

**Solution:** Some network stacks do not properly handle data packets that have the FIN flag set. If you're not using the Microsoft TCP/IP stack (part of the Windows 95 and NT operating systems), contact your network stack provider for an updated version of the network stack.

**Problem:** How can I transfer a hidden file or a file with a file name containing special characters?

**Solution:** In the classic interface, make sure nothing is selected, and then click the transfer arrow; you will be prompted for the file name.

**Problem:** The files I transferred are corrupted.

**Solution:** You may have transferred a binary file in ASCII transfer mode; this can damage the file. Make sure you transfer text files in ASCII mode and most other files in BINARY mode. If you still have problems, verify that you have hardware flow control enabled on your modem. If you are not using the Microsoft TCP/IP stack (part of the Windows 95 or NT operating system), contact your stack vendor.

**Problem:** Running Windows 3.x, I find that uploading any file over 25K often takes more than 30 minutes, after which I am timed out and disconnected.

**Solution:** You can solve the slow transfer problem by adding the following to your SYSTEM.INI file (for WIN3.x):

```
[VNTSP5D]
MaxFramesSize=1000
```

**Problem:** I keep getting failed data channel errors.

**Solution:** Try passive transfers.
Problems with WS_FTP Pro Settings

Problem: WS_FTP Pro won’t save the internal window sizes when I press the Save Window Locations button.

Solution: When WS_FTP Pro starts, it may be using an erroneous .ini file. Search your Windows folder and your executables folder for multiple ws_ftp.ini files. Determine which one you want and copy it into the WS_FTP executable folder. Delete or rename any other ones.

Problems Renaming and Deleting Files

Problem: I can’t rename a file on an FTP site.

Solution: You may not have renaming privileges on the site.

Problem: I can’t rename a file on an FTP site, even though I have renaming privileges.

Solution: You may be trying to use a long name on an FTP site that doesn’t allow long names. Try a name of eight characters or less.

Problem: I can’t delete a file from an FTP site.

Solution: You may not have deletion privileges on the FTP site.
 Numerics
16-bit version of WS_FTP Pro 1, 9, 75

A
accounts on FTP sites 4, 10, 21, 51
adding a configured site 10, 50
alerts
before deleting 14, 68
before overwriting 14, 68
anonymous FTP 4, 10, 11, 21, 51, 52
appending files 32
ASCII (text) files 41
transfer mode 33, 41, 44, 65, 72
viewing files 28
associating file extensions with applications 26, 59, 60
auto reget 14, 46
auto transfer mode 33, 72
automating file transfers 80

B
balloon help 37
batch files 78
binary files
transfer mode 33, 42
buffer 35

C
changing
default folders 69
disk drives 22, 57
e-mail address 51
folders 57
folders on an FTP site 23, 57
host name 12
host type 12, 52
IP address 12
mode (permissions) on UNIX sites 28
name of site configuration 12
names of files 61
site properties 52, 56
sounds 38, 73
chmod 28, 61
client-server 1
commands, initialization 15, 54
commenting on an FTP site 13, 53
connecting
problems 55, 87
retry 55
to an unconfigured FTP site 20
converting file extensions 40, 43
converting file names to lower case 14, 40, 82
creating
a folder on an FTP site 23, 58
configured sites 10, 50
folders for storing configured sites 19, 56
dates and times 37
format 37
older or same 47
retaining 14, 69
updating 14, 69
default
download folder 62, 70
program properties 67
temporary folder 70
default settings
for configured sites 11, 51
deleting
configured sites 11, 51
confirming before 14, 34, 68
a file from an FTP site 30, 61
files from the temporary folder 60
folders from an FTP site 30, 61
non-empty folders 47
subfolders 47
directories. See folders disconnecting from an FTP site 20, 57
disk drives
changing 22, 57
displaying
alternate screen layout 36
buttons at top of screen 36
command buttons 36
transfer rate 36
double-click action 35
downloading files 31, 62
using the command line 77
dragging and dropping 32, 46, 64
drives. See disk drives
editing
files on an FTP site 27, 60
e-mail address 4, 10, 51
executing files 44, 59
failed transfers, resuming 14, 46, 69
file extensions
converting 40, 43
transfer modes 44, 72
finding files and folders 7, 24,
firewalls 17, 40, 70
folders
  changing 69
  creating on FTP sites 58
  default 11, 62, 69
  deleting 30, 61
  downloading 62
  information 25
  properties 19, 56, 67
  remembering 22, 40
  startup 51
  for storing configured sites 19, 56
  with subfolders 81
  temporary 59, 60, 70
  updating after transfer 39
  uploading 63
  viewing 51, 57, 58
fonts 37
FTP (File Transfer Protocol) 1, 55
  client 1, 2
  commands 25
  server 1
FTP sites
  accounts on 4, 10, 51
  commenting on 13, 53
  configuring 10, 50
  deleting configured sites 11, 51
  disconnecting from 20, 57
  host name 12, 51
  IP address 12, 51
  naming site configurations 12, 50
  preconfigured 4, 10
  remote-to-remote transfers 66
  renaming site configurations 12, 12, 52
  using configured sites 10, 11, 50
  viewing contents of 21, 51
H
  help, balloon 37
  hidden files 24, 59
  hiding
    command buttons 36
  hierarchical folders. See folders
  host
    IP address 10, 20, 52
    name 10, 18, 20, 52
    type 39, 52
I
  ini file (ws_ftp.ini) 6
    and command line 84
  initialization command 15, 54
  installing WS_FTP Pro 5
  interrupted transfers
    resuming 14, 46, 69
Ipswitch, Inc.
  getting software updates 7
  giving feedback 7
  web site 7
L
  L8 transfer mode 42
  logs 22, 34, 70
  lower case letters in file names
    14, 40, 82
M
  mask, file 15, 24, 58
  messages
    See also alerts
    FTP 22, 70
    suppressing with the
    command line 84
    mode
  changing on UNIX sites 28, 61
  transfer 33, 66
  transfer (defined) 65
  moving files 32, 63
N
  naming and renaming
    assigning unique file names 41
    files as you transfer 14, 41, 68
    files on FTP site 28, 61
    files using lower case letters 14, 40, 68, 82
    files using the command line 76
    site configurations 12, 52
  network buffer size 35
  network timeout, setting 55
O
  opening a file 26, 44, 59
  overwriting
    confirming before 14, 68
P
  passive transfers 40, 55
  passwords 10, 53
    and the command line 77
  patches 7
  permissions
    changing on UNIX sites 28
  port
    firewall 18
    remote 17, 55
  pre-scheduled transfers 80
  progress, monitoring 14, 39, 68
  properties
classic interface 46
Explorer interface 69, 70, 72, 73

R
rate, display 36
recursive deletion of folders 47, 61
refreshing the display 23, 24, 58
remote-to-remote transfers 66
resuming failed or interrupted transfers 14, 69
retrying a connection 17, 55
right mouse menu 25

S
scheduling transfers 80
scripting 7, 75
searching 7
server 1
   See also FTP site
   Ipswitch WS_FTP 7
session options 13, 39, 41, 53
ShellExecute 3, 27, 34, 45
site. See FTP sites
sixteen-bit version of WS_FTP Pro 1, 9, 75
software patches 7
sorting 26
sounds 38, 73
spaces in file names
   transferring with command line 82
status. See progress
suppressing error messages
   using the command line 84
synchronize 7
syntax
   command line 76
system requirements 5

T
Temp folder 26
temporary folder 60, 70
text files. See ASCII files
text viewer 34
time zone 16, 54
time. See dates and times
   timeout, network, setting 17, 55
transfer modes 33
   ASCII 44, 72
   auto 42, 65
   binary 42, 65
   changing 31, 66
   command line 78
defined 41, 65
file extensions 44, 72
L8 42
passive 55
startup 41
transfer rate display 36
transferring files
   See also downloading files, uploading files
   automated 80
   by dragging and dropping 32
   multiple files using the command line 79
   at a particular time 80
   with spaces, using command line 82

U
uninstalling 6
UNIX 15, 24, 59, 68
   chmod 28
upgrades 7
uploading files 31, 63
user ID 10, 51, 53
   and the command line 77

V
viewing
   ASCII (text) files 28
   viewing files and folders 21, 58

W
warnings. See alerts
wildcards
   in command line 81, 83
window locations 34
window, main 21
writing scripts 7
WS_FTP
   Find Utility 7, 24
   Scripting Utility 7, 75
   Server 7
   Synchronize Utility 7
WS_FTP Pro
   16-bit version 1, 9, 75
   Development Kit 7

Bold page numbers refer to the Explorer interface.
Bold page numbers refer to the Explorer interface.