# Contents

Chapter 1: Introduction ................................................................. 1
  What is WS_FTP Pro? ............................................................. 1
  How FTP Works ........................................................................... 1
  Main Features ............................................................................. 2
  32-Bit Interfaces for Windows 95 and NT ............................... 3
    The “Classic” Interface of WS_FTP Pro ................................. 3
    The “Explorer” Interface of WS_FTP Pro ............................... 4
  16-bit Version for Windows 3.x ................................................. 5
Logging Onto an FTP server ........................................................... 5
  Preconfigured FTP Server Profiles ........................................... 6
System Requirements .................................................................. 6
Installation ................................................................................... 7
Uninstalling ................................................................................. 8
Files Installed ............................................................................... 8
Read Me First .............................................................................. 9
WS_FTP Pro Development Kit ....................................................... 10
Getting Updates and Giving Feedback ......................................... 10

Chapter 2: Using the “Classic” Interface ......................................... 13
Starting WS_FTP Pro ................................................................. 13
Using Session Profiles ............................................................... 14
  Creating a New Session Profile ............................................... 14
  Editing the General Tab of a Session Profile ......................... 15
  Saving and Deleting Session Profiles ..................................... 17
  Using an Existing Session Profile .......................................... 17
  Editing the Startup Options for Session Profiles .................. 18
  Editing the Advanced Options for Session Profiles .............. 19
  Editing the Firewall Options for Session Profiles ............... 20
The WS_FTP Pro Window ............................................................ 22
Connecting and Disconnecting ................................................... 24
Working with Directories and Files .............................................. 24
  Changing Disk Drives ............................................................. 25
  Changing Directories ............................................................. 25
  Creating andRemoving Directories ...................................... 26
  Viewing Only Certain Types of Files ...................................... 27
Editing the Preferences for Site Profiles ......................... 57
Editing the Advanced Options for Site Profiles .................. 57
Connecting and Disconnecting ........................................... 58
Working with Files and Folders ....................................... 59
Changing Disk Drives .................................................... 59
Changing Folders ......................................................... 59
Creating and Removing Folders ....................................... 59
Viewing Directories and Files ......................................... 59
Viewing Only Certain Types of Files ................................. 60
Sorting Files and Folders ................................................ 61
Transferring Files and Folders ......................................... 61
Downloading Files and Folders ......................................... 61
Uploading Files and Folders ............................................ 62
Moving Files and Folders ................................................ 63
Using Drag and Drop ..................................................... 64
Using Transfer Modes ................................................... 65
Opening (Executing) a File ............................................. 66
Remote-to-Remote Transfers ............................................ 67
Editing Files ............................................................... 68
Naming and Renaming Files ............................................ 69
Using chmod ............................................................... 69
Deleting Files ............................................................. 69
Program Options ........................................................... 70
Editing the Directories Options ....................................... 70
Editing the Site Profile List Options ................................. 71
Editing the Logging Options ............................................ 72
Setting Extensions ........................................................ 72
Preferences ............................................................... 73
Monitoring the Status of a Transfer .................................... 74
Displaying a Notice When a Transfer is Complete ................ 75
Getting an Alert Before You Overwrite a File ....................... 75
Getting a Confirmation Before You Delete a File ................. 76
Getting a Path/Filename Prompt ....................................... 77
Updating or Retaining File Date and Time ......................... 77
Converting Filenames to Lower Case ................................. 78
Resuming a File Transfer after Failure ............................... 79
Using Firewalls .......................................................... 79
Working with Sounds ..................................................... 81
Chapter 1: Introduction

This chapter begins with a basic introduction to WS_FTP Pro, a brief description of File Transfer Protocol (for newcomers), and a list of the product’s main features.

To prepare you for the product installation, we’ve included high level overviews of the 32-bit and 16-bit versions of WS_FTP Pro, as well as screen images of the two interfaces you’ll be offered if you install the 32-bit version.

In addition, you’ll find system requirements, the installation procedure, information about software updates, and instructions for giving feedback to Ipswitch, Inc.

What is WS_FTP Pro?

WS_FTP Pro allows you to use Windows 3.x, Windows 95, and Windows NT to copy to your PC the vast store of software applications, games, images, and other files made available on a continuing basis by organizations all over the world.

WS_FTP Pro is based on File Transfer Protocol (FTP), a method of intercomputer communication developed for the Internet. FTP offers fast and accurate transfer of large files or collections of files between computers on the Internet.

How FTP Works

FTP is based on the client-server model of communication between computers: one computer runs a server program “serving up” information to other computers. The other computers, or systems, run client programs that request information and receive replies from the server. The system running the server program is an FTP server, also known as an FTP site or as the “remote system.”
Organizations such as corporations, governments, and educational institutions often post material of general interest on FTP servers; to access these FTP servers, users must have the ability to connect to the Internet (via a modem or local area network) and an FTP client program (WS_FTP Pro).

**Main Features**

WS_FTP Pro turns your PC, also known as the “local system,” into an FTP client, allowing it to communicate with virtually all types of FTP servers. This allows you to transfer files from an FTP server to your PC (download files), from your PC to an FTP server (upload files), or even from one remote FTP server to another (remote-to-remote transfers).

WS_FTP Pro lets you:

- Connect to practically any FTP server on the Internet, no matter what type it is (Windows, OS/2, or UNIX).
- Browse the server’s directories and files.
- Open or execute files to evaluate them.
- Point and click to transfer files.
- Drag and drop to transfer files.
- Create and retain connection profiles of FTP servers you use repeatedly.
32-Bit Interfaces for Windows 95 and NT

WS_FTP Pro provides two user interfaces for 32-bit environments: the “classic” user interface, which runs like a stand-alone Windows application, and the “Explorer” interface, which integrates with Windows Explorer. The 32-bit interfaces of WS_FTP Pro are designed for Windows 95 and NT 4.0 or later.

The “Classic” Interface of WS_FTP Pro

The classic interface is very similar to previous versions of WS_FTP Pro:

When your local PC connects to a remote FTP server, the WS_FTP Pro classic interface displays a window with your local directories and files on the left and the remote directories and files on the right. With both file systems displayed, you can easily locate files on one system and transfer them to a specific directory on the other system.

When you install the “classic” interface, you also get the ability to use command line parameters to launch and run WS_FTP Pro. This is covered in Chapter 4.
The “Explorer” Interface of WS_FTP Pro

On the other hand, the Explorer interface of WS_FTP Pro is fully integrated with Windows Explorer:

The Explorer interface uses the same core engine as the classic interface of WS_FTP Pro, but it lets you copy and move files within Windows Explorer. You don’t even have to be especially aware that you’re using FTP or that the servers you’re seeing are FTP servers (as opposed to standard file servers).

In addition, the Explorer interface provides a capability not yet part of the classic interface: the ability to copy from one FTP server to another (the “remote-to-remote” capability).

The Explorer interface has just about all the functionality of the classic interface. However, there are a few features in the classic interface that are not in the Explorer interface: remote edit (using ShellExecute), the command line options, L8 mode transfers of non-text files, the ability to set buffer size and transfer rate display, specification of the text editor, and appending files.

**Note:**

You can install both the classic and Explorer interfaces and use them interchangeably. The two interfaces can share the information you save about FTP servers.
16-bit Version for Windows 3.x

WS_FTP Pro also provides a 16-bit version for Windows 3.x users:

The 16-bit version uses a four-pane window showing directory names in the two upper list boxes, and filenames in the two lower list boxes.

The 16-bit Windows 3.x version has just about all the functionality of the 32-bit version. The features in the 32-bit version that are not in the 16-bit version are: preservation of file date and time; a warning about overwriting newer files; red logon error messages; sorting of files and directories; checking of extensions when viewing or executing; prompting for application when viewing, editing, or executing; and tabbed dialogs for session or program properties.

Logging Onto an FTP server

The FTP process begins when a connection is made between an FTP client and an anonymous FTP server. After establishing communication, the client logs on with a user name and password. The user name and password identify your account on the server.
Most public FTP servers are set up with an “Anonymous” account: when you connect to an FTP server over the Internet, you need only identify yourself as “Anonymous” and use an e-mail address as a password. Normally, when you log on anonymously, the server displays the public directory (usually named something like /pub or /apps) containing the information and software that can be downloaded to your local system. (Access to other directories on the server is usually restricted.)

On anonymous FTP sites, look for files called readme, readme.txt, index, or 00index. Many sites use a file like this to provide a catalog of the information available on the site as well as other information about the site, such as a mission statement or operating hours.

In addition, an FTP server can also be set up (by the server administrator) to give certain users “accounts” with special access privileges. For example, a user with an account may be able to add, delete, and edit files, while an “anonymous” user can only download files. To log on to a server on which you have an account, you’ll need to enter the user name and password that the server administrator has assigned to your account.

**Preconfigured FTP Server Profiles**

WS_FTP Pro comes with a number of preconfigured profiles of popular FTP sites. You can use these profiles right out of the box to log you on anonymously to these sites. For example, you can select the profile (or site icon) named EpicMegaGames to access an FTP site that contains various computer games you can download for free.

**System Requirements**

WS_FTP Pro requires the following system resources:

- An Intel 386, 486, or Pentium processor; or a Digital Alpha processor
- Windows 95, Windows NT, or Windows 3.x
- A TCP/IP protocol stack.
You need a 32-bit stack to use the 32-bit version of WS_FTP Pro. Microsoft Windows 95 and Windows NT both come with their own 32-bit TCP/IP stacks, but note that some TCP/IP stacks for Windows 95 (such as Trumpet 1.0 and 2.0) can also be 16-bit.

For the 16-bit version, you can use either a 32- or 16-bit stack.

---

**Installation**

The installation of WS_FTP Pro is the same for new users as it is for those who are upgrading from a previous version of WS_FTP Pro.

To install any version of WS_FTP Pro:

1. Insert the WS_FTP Pro disk into a disk drive.
2. If you are running Windows 95 or NT 4.0 or later, click the Start button and select **Run**. If you are running Windows 3.x or Windows NT 3.51, select **Run** from the File menu.
3. Enter the drive letter followed by install.exe.
   For example, a:install.exe.
5. Follow the instructions on your screen.

---

**Note:**

If you are upgrading from a previous version of WS_FTP Pro, do **not** replace the **WS_FTP.ini file**, as this file contains all your session/site profiles.
Uninstalling

The uninstall function removes all files associated with WS_FTP Pro from your PC, including your site and session profiles. It also removes the WS_FTP Pro Explorer icon from your desktop.

To uninstall WS_FTP Pro:

1. Insert the WS_FTP Pro disk into a disk drive.
2. If you are running Windows 95 or NT 4.0 or later, click the Start button and select Run. If you are running Windows 3.x or Windows NT 3.51, select Run from the File menu.
3. Enter the drive letter followed by install.exe.
   For example, a:install.exe.
4. Choose Uninstall WS_FTP Pro, when asked.
5. Follow the on-screen instructions to uninstall WS_FTP Pro.

Files Installed

When you install WS_FTP Pro, the following files are placed on your hard disk, depending on the version and interface(s) you select.

For all interfaces:

- **complete.wav**, a sound file to indicate a transfer is complete
- **connect.wav**, a sound file to indicate a connection has been made
- **error.wav**, a sound file to indicate an error
- **whatsnew.txt**, release notes for this version of WS_FTP Pro
- **WS_FTP.ini**, the initialization file (with FTP server information)
- **prorder.wri**, order form
For the classic interface:

*FTP_PRO32.dll* or *FTP_PRO16.dll*, the application file for the classic interface

*WS_FTP.hlp*, the Help file

For the Explorer interface:

*WS_FTP Pro Explorer*, the icon that appears on your desktop and in the Windows Explorer program group

*FTPPRO32.DLL*, a Dynamic Link Library to extend the Windows Explorer

*nsftp.hlp*, the Help topics

*nsftp.cnt*, the Help table of contents

For the 16-bit version:

*FTPPRO16.DLL*, the application file for the 16-bit version

*wsftp16.hlp*, the Help file

---

**Read Me First**

Please refer to the file named *whatsnew.txt* for information regarding enhancements or changes that may have been made to the software since this manual was printed.
WS_FTP Pro Development Kit

WS_FTP Pro offers support for custom applications developed using the WS_FTP Pro Development Kit.

The WS_FTP Pro Development Kit lets you create programs to work with WS_FTP Pro for transferring files to or from remote systems or between remote systems. For example, you can use the Development Kit to create an application that automates your regular downloads or uploads from an authoring system or a database system. The Development Kit lets a developer write custom FTP applications without being concerned with the intricacies of network programming.

Getting Updates and Giving Feedback

If a software patch is created to extend capabilities or fix a bug in the currently shipping version of WS_FTP Pro, Ipswitch will make it available on our FTP and web sites. You can check our download FTP directory or the download directory on our web site for current software patches.

To download software from the Ipswitch FTP site:

1. Do one of the following:
   - In the classic interface, click the Connect button. In the Session Profile dialog box, select Ipswitch from the Profile Name drop-down list, and then click OK. WS_FTP Pro connects to the Ipswitch FTP server.
   - In the Explorer interface, double click the Ipswitch site icon.

2. Open the Product_Support folder. Open the WS_FTP_Pro folder.

3. Select the patch file for your platform type: Intel = x86 or DEC Alpha = AXP. The last three digits of the filename indicate the version number. (For example, x86_404.exe is the patch file for version 404 on the Intel platform.)
4. Transfer the patch file, and place it in your WS_FTP Pro directory. Run the patch file to update WS_FTP Pro.

To download software from the Ipswitch web site:

1. In your web browser, go to: http://www.ipswitch.com.

2. Click the Downloads link.

3. Click Patches and Upgrades, and then click the link for your platform type: Intel or DEC Alpha.

4. Save the patch file in your WS_FTP Pro directory.

5. Run the patch file to update the software.

We welcome your feedback on WS_FTP Pro. Please e-mail any comments and suggestions to feedback@ipswitch.com.
Chapter 2: Using the “Classic” Interface

The “classic” interface of WS_FTP Pro 5 is very similar to the interface of earlier releases. It’s a stand-alone Windows application that comes in two versions: 16-bit and 32-bit. The descriptions in this chapter pertain to both versions unless otherwise noted. Screen images shown here are taken from the 32-bit version.

Starting WS_FTP Pro

This section describes how to start WS_FTP Pro and how to create an FTP connection to a remote system.

To start WS_FTP Pro:

- In Windows 95 and NT 4.0 or later, click the Start button and select Programs->WS_FTP Pro->WS_FTP Pro.
- In Windows 3.x and NT 3.51, open the WS_FTP Pro folder and double click the WS_FTP95 Pro icon.

The WS_FTP Pro main window and Session Properties dialog box appear.
Using Session Profiles

A session profile is a collection of information about a remote system (an FTP server) and how you want to work with it. To create an FTP connection to a remote system, you either use an existing session profile or enter information to create a new session profile. The session profile tells WS_FTP Pro the name of the remote system, its platform or host type, and the login information (among other things).

Creating a New Session Profile

You can create a new session profile as follows:

1. Click the New button to clear the fields in the Session Properties dialog box.

2. In the Profile Name text box, enter a name to identify the profile you are creating. This can be any name you want to use.

3. In the Host Name/Address text box, enter the name of the remote host to which you want to connect. This must be either a fully qualified Internet host name or an IP address.

4. Click the Host Type drop-down list box and select the host type of the remote host.

   If you don’t know the host type, select “Automatic detect” from the list box. Automatic detect will work for most host systems.

5. Do one of the following:

   • To log in anonymously, make sure Anonymous is checked. WS_FTP Pro enters your full e-mail address as your password.

     You can place a minus (-) sign in front of your e-mail address to reduce the number of messages you’ll receive from the site administrator.

   • If you have an account on the remote system, make sure Anonymous is not checked, so you can enter the User ID (Name) and Password for your account.
Note:
Your password is stored in the \texttt{ws\_ftp.ini} file in an encrypted form. Do not check the \textbf{Save Pwd} check box unless you are the only user of your computer and no one else has access to your WS_FTP directory!

6. Enter your \textbf{Account} identification. (Occasionally, an \textbf{Account} is required by a remote host for initial access to the user’s default directory. For example, each time you change directory on a VM/CMS host you are prompted for the password.)

7. (Optional) In the \textbf{Comment} text box, enter any comments you want to store with this session profile.

8. In the 32-bit version of WS_FTP Pro, click the \textbf{Apply} button to save the settings. Click the \textbf{OK} button to save the settings and connect to the remote system. (In the 16-bit version, click \textbf{Save}.)

When you connect to a remote host, the message area at the bottom of the WS_FTP Pro window displays messages similar to the following:

\begin{verbatim}
150 Opening ASCII mode data connection for dir
Received 2046 bytes in 1.0 secs.
226 Transfer complete.
\end{verbatim}

WS_FTP Pro connects you to the remote system and displays the default directory, as determined by the \textbf{User ID} in the session profile. For example, if you connected using "Anonymous" you see the default directory for anonymous logins.

\textbf{Editing the General Tab of a Session Profile}

You can edit the General tab of a session profile whenever you like.

1. Click the \textbf{Connect} button to view the Session Properties dialog box.

2. Select the name of the profile you want to edit in the \textbf{Profile Name} drop-down list.

3. (Optional) In the \textbf{Profile Name} text box, enter a new name for the profile. This can be any name you want to use.
4. (Optional) Enter a new name or IP address in the **Host Name/Address** text box.

5. (Optional) Select a new **Host Type** from the drop-down list.

6. (Optional) Do one of the following:
   - To log in anonymously, make sure **Anonymous** is checked. WS_FTP Pro enters your e-mail address as your password.
     
     You can place a minus (-) sign in front of your e-mail address to reduce the number of messages you’ll receive from the site administrator.

   - If you have an account on the remote system, make sure **Anonymous** is *not* checked, so you can enter the **User ID (Name)** and **Password** for your account.

   __Note:__

   Your password is stored in the *ws_ftp.ini* file in an encrypted form. Do not check the **Save Pwd** check box unless you are the only user of your computer and no one else has access to your WS_FTP directory!

7. (Optional) Enter or change your **Account** identification.

8. (Optional) In the **Comment** text box, enter or edit any comments you want to store with this session profile.

9. In the 32-bit version of WS_FTP Pro, click the **Apply** button to save the settings. Click the **OK** button to save the settings and connect to the remote system. (In the 16-bit version, click **Save**.)
Saving and Deleting Session Profiles

A session profile is automatically saved when you click OK or Apply in the Session Properties dialog box. There is no imposed limit on the number of profiles you can have.

To delete a session profile:

1. Click the Close button if you're logged on to a remote system.
2. Click the Connect button to view the Session Properties dialog box.
3. Select the name in the Profile Name drop-down list.
4. Click the Delete button.

Using an Existing Session Profile

Once you have created a session profile, the next time you want to connect to the same remote system:

1. Click the Connect button to view the Session Properties.
2. Select the name of the profile from the Profile Name list box.
3. Click OK.

In addition, WS_FTP Pro comes with a number of preconfigured session profiles for some of the popular FTP sites. Click the Profile Name list box to show the choices.
Editing the Startup Options for Session Profiles

You can specify what you view when you first log onto an FTP site.

1. Click the **Connect** button.

2. Select the **Profile Name**.

3. Click the Startup tab.

4. (Optional) In the **Initial Remote Host Directory** text box, specify the remote directory you want to view whenever you first connect to the remote system.

5. (Optional) In the **Initial Local Directory** text box, specify the local directory you want to be current when you log onto this remote system.

6. (Optional) In the **Initialize Command** text box, enter any commands that you want to issue to the remote system at the beginning of a session. For example, the command SITE UMASK 022 changes the UMASK used when creating files (on a UNIX system). Use a semicolon (;) to separate multiple commands. You can enter a maximum of 250 characters in this text box.
7. (Optional) If the **Initial Local Directory** or the **Initial Remote Directory** contains a large number of files, you can limit the files displayed to just one type by entering a filter in the **Local file mask** and **Remote file mask** text boxes. For example, if you enter `*.txt`, only files with the `.txt` extension will be displayed in the corresponding list box.

On UNIX remote systems, enter `-al` or `-la` to view all files, including hidden (.) ones. Or, you can enter `-altxr` to receive file names in date sequence (only in the 16-bit version of WS_FTP Pro). *[For those who have used DOS command line FTP clients: You can also enter any argument string you would use with a “Dir” command.]*

8. (Optional) In the 32-bit version of WS_FTP Pro, use the **Time offset in hours** text box to adjust the display of file dates and times on a remote system so they represent the times and dates in your time zone.

Enter the difference in whole hours between your time zone and the time zone of the remote system. Use a positive number if the system is in an earlier time zone (west), a negative number for a later time zone (east). For example, if the remote system is in a time zone three hours earlier than your time zone, you can enter `-3` to have WS_FTP Pro adjust a date and time of 11/10/97 1:00 AM to 11/9/97 10:00 PM.

Note that no standard exists for specification of date and time, but it is sometimes displayed in Greenwich Mean Time (GMT).

**Editing the Advanced Options for Session Profiles**

You can control advanced network functions.

1. Click the **Connect** button.

2. Select the **Profile Name**.
3. Click the Advanced tab.

4. (Optional) Use the **Connection Retry** text box to enter the number of seconds that elapses before WS_FTP Pro tries again to connect if the initial connection fails.

5. (Optional) Enter the **Network Timeout**, the number of seconds that elapses before WS_FTP Pro stops waiting for a remote system to respond. Normally, the network timeout is determined by your Winsock DLL. (You can set it to less time than your Winsock DLL, but setting it higher won’t affect anything.)

6. (Optional) The **Remote Port** for the FTP protocol is normally 21, however, it may be something different if you are going through a firewall, or if the FTP site administrator has assigned the FTP protocol to another port.

7. (Optional) Use the **Passive transfers** text box to specify passive transfers. Normally, when you connect to an FTP site, the FTP server establishes the data connection to your local system. However, if the remote system allows passive transfers, you can have your local system establish the data connection. Use passive transfers for local area networks behind some types of router-based firewalls or behind a gateway requiring passive transfers.

**Editing the Firewall Options for Session Profiles**

If your network uses a firewall to block FTP transfers, you can enter firewall information so transfers can go through the firewall.
To do this, you’ll need information about your firewall from your network administrator; depending on the type of firewall, you’ll need the following:

- For a “SITE hostname” firewall type, you’ll need **Host Name** (or IP Address) and **User Name** (ID).
- For a “Transparent” firewall type, you’ll need **User Name** (ID) and **Password**.
- For “USER with no logon” or “Proxy OPEN” firewall types, you’ll need the **Host Name** (or IP Address). (The User Name and Password are ignored.)
- For “USER after logon,” “USER remoteID@remoteHost fireID,” or “USER fireID@remoteHost” firewall types, you’ll need **Host Name**, **User Name** (ID), and **Password**.

To enter the firewall information for an existing session profile, click the **Connect** button, select the **Profile Name**, and click the Firewall tab.

1. Make sure **Use Firewall** is checked, and enter the firewall information required by your firewall type.

2. Enter the **Host Name** of your firewall. This must be either a fully qualified Internet host name or an IP address.

3. Enter your **User ID** for the firewall.
4. Enter the ** Password ** for the firewall.

5. Check ** Save Password ** to save the firewall password to a file.

---

**Note:**

Do not check ** Save Password ** unless you’re the only user of your computer and no one else has access to your WS_FTP directory!

---

6. Enter the ** Port ** number for the firewall.

7. Select the ** Firewall Type. **

---

**The WS_FTP Pro Window**

When you successfully connect to a remote host (FTP server), you see the WS_FTP Pro main window.

The right side of the window, labeled ** Remote System **, lists the directories and files on the remote system. The left side, labeled ** Local System **, lists the directories and files on your PC.
The current directory is shown at the top of each side. The list box below the current directory shows all directories and files in the current directory as well as any disk drives you can access.

**Note:**

In the 16-bit versions of WS_FTP Pro, each side of the window contains two list boxes: the top list box shows the available directories, the bottom shows the files in the currently selected directory.

The buttons to the right of each listing of directories and files provide file and directory operations for that side of the window.

A message area at the bottom displays all messages generated by the FTP session. These messages can tell you if a command executed successfully and help you determine the cause of a failure or a disconnect. To view the messages in a window, click the LogWnd button.

**Note:**

Some FTP sites also display messages about the site in the FTP log. The message may describe the site’s hours of operation, an e-mail contact, or list other sites that contain the same information (called “mirror” sites).
Connecting and Disconnecting

As described above, you connect to a remote system by clicking the **Connect** button, selecting the **Profile Name**, and clicking **OK**.

To disconnect from a remote system, click the **Close** button. The button toggles to **Connect** and WS_FTP Pro is ready to begin another session.

Working with Directories and Files

After connecting to a remote host, you use the directory and file commands to browse file systems on both the local and remote systems.

Just to the right of each list box is a column of command buttons that perform directory and file operations. You can also access these commands by placing the mouse pointer in the list box of directories and files and clicking the right-mouse button. You see the following pop-up menu:

To refresh the directory display after performing directory or file operations outside of WS_FTP Pro, or to unselect files and directories, click the **Refresh** button.
Changing Disk Drives

The current directories shown at the top of the main window under the words Local System and Remote System indicate the path and directory. To change to another disk drive, do one of the following:

- Use the drop-down arrow next to the current directory to show a list of paths and directories, and then click the desired path/directory listing.
- Click the desired disk drive in the list box (indicated by a drive letter and a disk icon).
- With nothing selected in the list box, click the ChgDir button. You see the following dialog box.

Enter the drive letter followed by a semicolon (for example, d:) and click OK. Do not enter a trailing slash (\).

Changing Directories

In both the local and remote systems’ list boxes, you can use the directory commands to locate files and directories, set the directories you want to use for file transfer, and perform other directory operations. To change directories, do one of the following:

- Select a directory from the current path drop-down list or enter a directory name in the text box where the current path is shown.

If you enable the Remember directories option on the Session tab of Program Options, the drop-down lists for both the local and remote current directories show the directories you visited during the last session. See “Editing the Session Options,” below.
• Scroll down the list box and click the directory you want to display. In the 32-bit version of WS_FTP Pro, directories are indicated by a folder icon.

• Click the ChgDir button. If a name is selected in the list box, the system will change directories to that name. If no name is selected, you are prompted for a directory to change to. (Not all systems have the concept of directories, so the remote system may not accept this command.)

• You can also click the Up button (green arrow), located at the top of the list box, to move up one directory in the directory hierarchy.

Creating and Removing Directories

Not all remote systems allow you to create or remove directories, but for those that do, use the following techniques.

To create a directory, click the MkDir button. You are prompted for a directory name that is valid for the current system.

To remove an empty directory, in the 32-bit version:

• Select the directory and click the Delete button. Or, you can click the Delete button with nothing selected and enter the name of an empty directory when prompted.

To remove a directory, in the 16-bit version:

• Select the directory and click the Rmdir button. Or, you can click the Rmdir button with nothing selected and enter a directory name when prompted.
Viewing Only Certain Types of Files

If a directory contains a large number of files, you can limit the files displayed by using the File Mask text box, located below the MkDir button in the WS_FTP Pro main window. There are two File Mask text boxes, one for the local system and one for the remote system.

In the File Mask text box, enter a filter that is valid for the system that you are on and press Return.

```
*.txt
```

For example, to display only files with the extension .txt, enter `*.txt` as the File Mask and press Return. The list box is refreshed to display only the files with the extension .txt.

If you are connected to a UNIX host, you can use `-al` or `-la` in the remote side to view all files, including hidden (.) ones. Or, you can enter `-altx` in the remote side to receive file names in date sequence (in the 16-bit version of WS_FTP Pro only). [For those who are familiar with DOS FTP clients: You can also enter any argument string you would use with a “Dir” command.]

Displaying Directory Information in a Window

Click the DirInfo button. The Windows Notepad appears and lists the directories and files in the current directory, as well as the size, creation date, creation time, and protections.
Sorting Files and Directories

In the 32-bit version of WS_FTP Pro, you can sort directories and files in the list boxes, using the column headings (Name, Date, Size). The sort options work as follows:

- Click the Name, Date, or Size column heading to toggle the sorting of that column between ascending and descending order.
- Click Ctrl-Name to sort the file names by file extension.
- ^ — This button, to the left of the Name column, toggles the display between showing directories on top (before all files), on the bottom, or intermixed with files.

In both the 32-bit and 16-bit versions of WS_FTP Pro, you can access the sort options in the pop-up menu, as follows:

1. Right click in either list box. The pop-up menu appears.
2. Select Sort from the pop-up menu. The Sort dialog box appears.

![Remote Sort Options](image)

3. Select the Sort options you want to use and click OK.
Transferring Directories and Files

Before you transfer a file or files, display the files in the list box of the source system and display the directory to which you will transfer files on the destination system.

Downloading Directories and Files

Copying directories or files from the remote system to the local system is known as downloading.

To download files (or directories):

1. Select one or more files on the remote system.
   
   To select a single file for transfer, click its name to select it. To select multiple files for transfer, Shift-click or Ctrl-click.

2. Select the file transfer mode (ASCII, Binary, or Auto).
   
   Click the check box next to a transfer mode (at the bottom of the WS_FTP Pro window) to determine how FTP will transfer the files. For more information, see “Using Transfer Modes” later in this chapter.

3. Transfer the files.
   
   To transfer the selected files, click the left arrow (between the Local System and Remote System list boxes). WS_FTP Pro transfers the files to the current directory on the local system.

   When the transfer is complete, the names of the transferred files appear in the local system’s list box.

Uploading Files

Copying directories or files from the local system to the remote system is known as uploading.

To upload files (or directories):

1. Select one or more files on the local system.
To select a single file for transfer, click its name to highlight it. To select multiple files for transfer, Shift-click or Ctrl-click.

2. Select the file transfer mode (ASCII, Binary, or Auto).

Click the check box next to a transfer mode (at the bottom of the WS_FTP Pro window) to determine how FTP transfers the files. See “Using Transfer Modes” later in this chapter for more information.

3. Click the right arrow to transfer the files.

WS_FTP Pro transfers the files to the current directory on the remote system. When the transfer is complete, the names of the transferred files appear in the remote system’s list box.

**Moving Directories and Files**

You can move files or directories from one directory to another directory on the same system. To move files (or directories):

1. Select one or more files.

   To select a single file for moving, click its name to highlight it. To select multiple files, Shift-click or Ctrl-click.

2. Select **Move files** from the right-mouse menu.

   You are prompted for the directory to which you want to move the files.

3. Enter the directory path and click **OK**.

**Appending Files**

In the 32-bit version of the WS_FTP Pro classic interface, you can select one or more files on the source system and transfer those files to the destination system, appending them to another file. To append files:

1. Select one or more files on the source system.

2. In the source system list box, select **Append file** from the right-mouse menu.
A dialog box prompts you to enter the destination filename.

3. Enter the name of the file to which you want to append and click **OK**.

**Using Drag and Drop**

In all versions of the classic interface, you can use the mouse to drag and drop files between the local system and the remote system.

In the 32-bit version, you can also drag and drop directories. Furthermore, you can:

- Drag and drop between the Windows Explorer and the WS_FTP Pro window
- Drag and drop between the desktop and the WS_FTP Pro window

As you drag a file or directory, an FTP icon shows its current location in the WS_FTP Pro window.

To transfer multiple directories or files, Ctrl-click or Shift-click them and then drag and drop one of the selected files.

The drag and drop feature is enabled by default. You can disable this feature. See “Enable Drag and Drop Between Windows” later in this chapter.

**Using Transfer Modes**

A file is transferred as follows, depending on the transfer mode that is currently selected:

- **Auto mode selected** — Checks to see if the file extension is registered (in the Extensions tab of the Options dialog box). If the extension is registered, the file is transferred in ASCII format. If it is not registered, or if no file extension is found, the file is transferred in binary format.
- **Auto mode off** — Transfers the file in the selected mode, either binary or ASCII.

For more information on transfer modes, see “Editing More Session Options” later in this chapter.
Opening (Executing) a Remote File

You can associate a file extension with an application (executable program), which allows you to open (execute) the file in the associated application. For example, you can associate the extension .pdf with the Adobe "Acrobat" Reader; then, when you open a file named myfile.pdf, it is opened in the Adobe Acrobat Reader. See “Setting Associations” later in this chapter.

If an association does not exist, you are prompted to provide that association when you try to open the file. This association is saved in the win.ini file and is also valid for the Windows File Manager.

To open (execute) a file in its associated application, do one of the following:

- Select the remote file and then click the **Exec** button.
- Select **Ctrl+Exec** to display a prompt where you can enter the executable filename for the application.

WS_FTP Pro downloads the file to the Windows temporary directory prior to opening it. If it’s a large file, it may take some time for the file to download from the remote system.

Editing Remote Files

You can edit a remote file using a shell command to open the file on the remote system in its associated application. Then, you can edit the file and save it on the remote system, provided you have permission to edit files on the remote system.

To do this, make sure **Remote Edit uses ShellExecute** is checked (on the General Tab of Program Options).

To edit a remote file:

1. Select the file.
2. Select **Edit file** from the right-mouse menu. WS_FTP copies the file to the local system and opens it in its associated application.
3. Edit the file.
4. Choose **Save** from the File menu of the application that opened the file.

   The file is saved on the remote host with the original name.

5. Exit from the application that opened the file.

If **Remote Edit uses ShellExecute** is *not* checked, or if you don’t have permission to edit a file on the remote system, you can download the file, edit it on your local system, save it (with a new name), and then upload it to the remote system.

See “Setting Associations” later in this chapter for information on determining which application opens a specific file type.

**Viewing Text Files**

You can view text files, that is, files in ASCII format. Notepad is the default text viewer. You can specify a different text viewer if you like; see “Editing the General Options,” below.

To view text files (ASCII format), do one of the following:

- Click the **View** button for the remote system list box.
- Click **Ctrl+View** to display a prompt where you can enter the executable filename for another viewer program.

WS_FTP Pro downloads the file to the Windows temporary directory. If it’s a large file, it may take some time for the file to download from the remote system.

**Naming and Renaming Files**

Not all systems allow you to rename files and directories remotely. For those that do, you can:

1. Select one or more files
2. Click the **Rename** button.

You are prompted for the new name.
3. Enter the new name and click **OK**.

If you selected multiple files, you are prompted to rename the next file.

You can also use the **Rename on transfer** option to rename files as you transfer them. See “Preferences (Pro Options)” later in this chapter for more information.

**Changing the Mode (or Permissions) for a UNIX File**

You can change modes for a UNIX file on a remote system, provided you have file access permission. Select the file and then select **chmod** from the right-mouse menu. Select any of the options in the Remote File Permissions dialog box and click **OK**.

**Deleting Files**

You can delete files from a remote system only if your access privileges allow you to do so; you usually cannot delete files if you have logged on as an Anonymous user. If you have deletion privileges, select the file and click the **Delete** button.

---

**Program Options**

You can set and edit default program options to customize how WS_FTP Pro works. Click the **Apply** button to save your changes. Click the **OK** button to save your changes and close the dialog box.

**Editing the General Options**

To edit the general settings for WS_FTP Pro operations:

1. In the main window, click the **Options** button.
2. Click the General tab.

3. (Optional) Enter your **E-mail Address**. This is default password for anonymous logins, as required by most anonymous FTP sites.

You can place a minus (-) sign in front of your e-mail address to reduce the number of messages you’ll receive from the site administrator.

4. (Optional) Enter the name of the **Text Viewer** invoked by the **DirInfo** and **View** buttons. The default is Windows Notepad.

5. (Optional) Enter the **Log filename**, the name of the file to which WS_FTP Pro writes the information in the message log when **Enable Log** is checked. The log records all requests from WS_FTP Pro and all responses from the FTP server. This should be a full pathname if you want each session’s log file placed in the same directory.

6. (Optional) Check **Enable Log** to have WS_FTP Pro write the message log to the file specified in the **Log filename** text box.

7. (Optional) Check **Verify Deletions** to have WS_FTP Pro prompt you for confirmation when you delete files.

8. (Optional) Check **Debug Messages** to have WS_FTP Pro place extra debug messages in the message log window at the bottom of the main window and in the log file (if enabled).
9. (Optional) Check **Remote Edit uses ShellExecute** to have WS_FTP Pro open a remote file for editing without downloading it to your system.

10. (Optional) Check **Reset Window Locations** to have WS_FTP Pro reset the current main window size and location to the original settings.

11. (Optional) Check **Save Window Locations** to have WS_FTP Pro save the current main window size and location. In order to save column and internal sizes, the main window must not be maximized.

**Editing the Advanced Options**

To edit the settings for advanced WS_FTP Pro operations:

1. In the main window, click the **Options** button.

2. Click the Advanced tab.

3. (Optional) Check **Show Full Directory Information** to display additional file information when possible. (Not all host types are supported for this option.) WS_FTP Pro does not attempt to decipher or interpret this information.
4. (Optional) If **Auto Save Host Configurations** is checked, the session profile is automatically saved when you connect to a remote system by clicking **OK** in the Session Properties dialog box.

If **Auto Save Host Configurations** is *not* checked, clicking the **OK** button in the Session Properties dialog box simply connects you to the remote system. (The profile is not saved.)

5. (Optional) Check **Show Connect Dialog on Startup** to display the Session Properties dialog box when WS_FTP Pro first starts.

6. (Optional) Use **Double Click Action** to determine what happens when you double click a filename. **Transfer** transfers the file to the other system. **View** displays the file using the text viewer. If the file is on a remote system, it is transferred in ASCII mode to the local system’s Windows temporary directory and then displayed. **Nothing** means no action is taken when you double click a filename.

7. (Optional) Use the **Network Buffer Size** text box to determine how many bytes of information are received and transmitted.

   **Receive Size** — Controls how many bytes are read from the network in each read (recv). This can vary from 80 to 4096, with best results from 4096. On slow connections, try lower values and work your way up until you find the optimum rate. Note that the actual number of bytes read in each read is determined by the TCP/IP stack and the amount of information available.

   **Transmission Size** — Controls how many bytes are written to the network in each send. This can vary from 80 to 4096, with the optimum dependent on your TCP/IP stack. If you have a direct connection, 4096 is best. If you have a SLIP or PPP connection, you probably want to set it to the MTU size. On slow connections, try lower values and work your way up until you find the optimum rate.

8. Set the **Transfer Rate Display** to the desired transfer rate in bits per second or bytes per second. The transfer rate is displayed in the Transfer Status dialog box.
Editing the Display Options

To edit the settings for the WS_FTP Pro window display:

1. In the main window, click the **Options** button.

2. Click the **Display** tab.

3. (Optional) Check **Alternate Screen Layout** to split the WS_FTP Pro main window horizontally, with the local directory and file list on top and the remote directory and file list on bottom. (Make sure this option is not checked if you want the window split vertically.)

4. (Optional) Check **Show Buttons at Top of Screen** to move to the top of the window the buttons that are normally across the bottom.

5. (Optional) In the 32-bit version of WS_FTP Pro, check **Hide Directory Buttons** to hide the buttons (ChgDir, MkDir, etc.) for directory and file operations. These operations will then be available only from the right-mouse menu.

6. (Optional) Check **Auto Scale Fonts** to reduce the size of fonts outside the list boxes when you reduce the window size. The font used will always be the ANSI Variable font.

7. (Optional) Check **Enable button balloon help** to show a descriptive popup when the cursor is placed over a button.
8. (Optional) Select the desired **Date Format** options to determine how WS_FTP Pro displays dates.

9. (Optional) Use **List box Font** to change the font used in the list boxes. **System Variable**, a variable font, is the default. **System Fixed**, a fixed font, improves the alignment of columns in the boxes. **ANSI Variable** and **ANSI Fixed** are narrower than the System fonts. Selecting **Custom Font** displays the Windows Font dialog box from which you can select a specific font family, style, and size.

**Editing the Sounds Options**

To edit the default settings for the audio files that notify you of FTP session events, do as follows:

1. In the main window, click the **Options** button.

2. Click the Sounds tab.

3. (Optional) Check **Connection Success** to play the specified wave file (or sound a beep) when a connection succeeds.

4. (Optional) Check **Connection Failure** to play the specified wave file (or sound a beep) when a connection fails.

5. (Optional) Check **Transfer Complete Success** to play the specified wave file (or sound a beep) when a file transfer succeeds.
6. (Optional) Check **Transfer Complete Failure** to play the specified wave file (or sound a beep) when a file transfer fails.

7. (Optional) Check **Other Failures** to play the specified wave file (or sound a beep) when an error occurs during the retrieval of directories, renaming or deleting files or directories, or at other times. To have the same sounds as earlier versions of WS_FTP Pro, turn off this option.

8. (Optional) Use **Sounds** to specify the sounds to use on connection, completion of file transfer, or an error. *None* means no sound is played. *Beeps* means the system beep sound will be used. *Wave* means the specified .wav files will play.

**Editing the Session Options**

You can edit Session options for just the current session, or for all sessions.

To edit the settings for the current session:

1. In the main window, click the **Options** button.

2. Click the Sessions tab.

3. (Optional) Select the **Host Type** of the remote system from the drop-down list.
4. (Optional) Check **Update Directories After Transfer** to automatically refresh the remote directory list after uploading a file, deleting a file or directory, or creating a directory. If this option is not checked, you can use the **Refresh** button.

5. (Optional) Check **Show Transfer Progress Dialog** to display a Transfer Status dialog box during file transfers. This dialog box displays the status of the transfer (shown as the percent done) and provides a **Cancel** button that lets you cancel the transfer at any time. Note that the percent done bar is only displayed if the file size is sent from the remote host on receives.

6. (Optional) Check **Use Passive Transfer Mode** to force data connections to be established by the local system. Normally, when you connect to an FTP site, the FTP server establishes the data connection to your local system (the FTP client). However, if the site allows passive transfers, you can have your local system establish the data connection.

   You’ll want to use passive transfers for local area networks that are behind some types of router-based firewalls or behind a gateway that requires passive transfers. You should also use passive transfers if you keep getting “failed data channel” errors.

7. (Optional) Check **Use Firewall** if you want to go through a firewall. Note that you can also set the **Use Firewall** option for individual session profiles. (See Step 12 below to determine whether this setting affects just what you’re currently working on, or is always in effect.)

8. (Optional) Check **Force Lowercase Remote Names** to convert all file names to lower case when doing uploads.

9. (Optional) Check **Convert Extensions** to enable the automatic conversion of the file extensions set up on the Convert tab.

10. (Optional) Check **Remember Directories** (pro) to show the directories you’ve visited in the current directory drop-down lists.

    These directories are added to the lists as long as you click the **Close** button to exit a session.
11. (Optional) Check **Save Current Directories as Connection Directories** to save the local and remote directory names in the *current* session profile and log into them the next time you connect to the host.

12. (Optional) If you want the settings on this tab to remain in effect when you re-start WS_FTP Pro, click **Set as default**. If you want the settings to remain in effect only until you exit WS_FTP Pro, do not click **Set as default**.

**Editing More Session Options**

To access more session options, do as follows:

1. In the main window, click the **Options** button.

2. Click the **Session (continued)** tab.

3. (Optional) For a UNIX host, check **Send Unique (host assigns name)** to cause uploaded file names to not conflict with existing files if the remote host supports the STOU FTP command. The new filename is determined by the remote host.

4. (Optional) Check **Receive Unique (PC assigns name)** to cause downloaded file names to not conflict with existing files. The new filename is changed so that the sixth through eighth characters of the filename will be a number from 000 to 999.
5. (Optional) Check Prompt for Destination File Names to enable local/remote filename prompting: as each file is transferred, you are shown the proposed destination filename and allowed to change it. You can enter a full pathname to a different directory if you want.

6. (Optional) The Startup Transfer Mode area is where you determine transfer modes.

   ASCII is used to transfer text files. The end-of-line character is different on different types of computers. ASCII mode insures that the end-of-line character is translated properly. If you know that the remote host is the same operating system as your local host, you can always use binary mode and never use ASCII.

   Binary is used to transfer non-text files. Executable programs, word processing documents, spreadsheets, databases, graphics files, and sound files are some examples of files that must be transferred in binary mode. If you know that the local and remote hosts are the same operating system, you can always use binary mode and never use ASCII.

   L8 is used to transfer VMS non-text files.

   Auto Detect When this option is selected, WS_FTP Pro transfers in binary mode unless the file extension is listed on the Extensions tab, in which case it transfers the file in ASCII mode. Note that extensions can be up to 10 characters long and can contain periods. These are not DOS extensions, but the ending characters of a filename. If you expect it to match on a period, you must specify a period. Some example extensions are: .lst.txt,.me, readme. See “Setting Extensions,” below, for more information.

7. (Optional) In the 16-bit version of WS_FTP Pro, check View links to view links (for example, UNIX symbolic links) on the remote system as directories or as files. (This option does not appear in the 32-bit version of WS_FTP Pro because links are handled automatically there.)
8. (Optional) If you want the settings on this tab to remain in effect when you re-start WS_FTP Pro, click Set as default. If you want the settings to remain in effect only until you exit WS_FTP Pro, do not click Set as default.

Editing Conversion Properties

You can convert file extensions of transferred files to a new extension. For example, if the remote system uses .html for HTML files and your system uses .htm, you can specify that all files with the extension .html are converted to .htm on transfer.

To view the conversion options, do the following:

1. In the main window, click the Options button.

2. Click the Convert tab.

![WS_FTP Pro Properties]

Note:
The source and destination are dependent on the file transfer direction. For example, when downloading files, the source is the remote system, and the destination is the local system.
To add an extension conversion:

1. In the **Source** text box, enter the file extension of the source file.

2. In the **Destination** text box, enter the file extension to convert to (the destination file).

3. Click the **Add** button.

   The extension conversion appears in the list box. The list box shows all the defined extension conversions.

WS_FTP Pro automatically converts these extensions when transferring, if the **Convert Extensions** option in the Session Properties is enabled.

To delete an extension conversion, select it in the list box and click the **Delete** button.

**Setting Extensions**

You can specify the transfer mode for different file extensions. When **Auto Detect** is selected for the transfer mode, WS_FTP Pro transfers all files in binary mode, unless the extension is entered on this tab (which stores entries in the ws_ftp.ext file). The extensions listed here use the ASCII transfer mode. In the main window, click the **Options** button and then click the Extensions tab.
To add a file extension to the **Auto Detect** list:

1. In the **ASCII Filenames and Extensions** text box, enter the file extension. The extension can be up to nine characters long and can contain periods.

2. Click the **Add** button.

   The extension appears in the list box. The list box lists all file extensions that WS_FTP Pro transfers in ASCII mode when using Auto Detect transfer mode.

3. Click the **Apply** button to save your changes. Click the **OK** button to save your changes and close the dialog box.

To delete a file extension from the list box, select the extension and click the **Delete** button.

**Setting Associations**

You can associate files that have a particular extension with an executable file. In this way, you can map file types to an application that can open (execute) that type of file.

On a remote system, when you click the **Exec** button, the file is transferred to the local system and executed by Windows. The associations you set on this tab tell Windows how to execute files of a particular extension. In the main window, click the **Options** button and then click the Associations tab.
To set up an association:

1. In the **Files with Extension** text box, enter the file extension to be associated with the executable program.

2. In the **Associate With** text box, enter the executable program to run when the **Exec** button is clicked.

   You can use the **Browse** button to browse your directories and files to locate the executable program.

---

**Note:**
The 32-bit version of WS_FTP Pro calls ShellExecute to execute the file through the shell. If this fails, then the associations specified on the Associations tab are used. These associations are unique to WS_FTP Pro in the Windows 95 and NT 4.0 or later environments.

3. Click the **Apply** button to save your changes. Click the **OK** button to save your changes and close the dialog box.

---

**Preferences (“Pro” Options)**

The “Pro” options determine your preferences for how WS_FTP Pro works. To set these options, in the main window, click the **Options** button and then click the Pro tab.
Enable drag and drop between windows

When enabled, you can transfer directories and files between systems by dragging them with the mouse from one list box to the other.

Enable auto reget of failed transfers

Most, but not all, FTP servers allow the auto reget option. It works like this: when a file transfer is interrupted while in progress because of a lost connection or because it was cancelled, WS_FTP Pro tries to resume the transfer the next time you reconnect to the remote system.

When you reconnect, WS_FTP Pro asks if you want to resume the transfer; for example:

![Auto Reget Prompt]

Note:

If you choose not to resume the transfer, you will be left with a partial file in the destination directory. You should delete this file.

Preserve file time on transfer from remote

When this is enabled (in the 32-bit version of WS_FTP Pro), and when you download a file from a remote system, the file maintains its original creation date and time. If not enabled, the file date and time are updated to the date and time of the download.

Prompt for overwrite of same or newer files

When this is enabled (in the 32-bit version of WS_FTP Pro), if you transfer a directory or file for which there is the same or a newer version (by date and time) in the destination directory, WS_FTP Pro asks if you want to overwrite the file. Note that this feature will not work with some FTP servers.
Don’t transfer older or same date files (downloads only)

When this is enabled (in the 32-bit version of WS_FTP Pro), if you download a directory, WS_FTP Pro downloads only those files having a later date and time than files on the destination directory with the same names.
Chapter 3: Using the Explorer Interface

The Explorer interface of WS_FTP Pro is an extension to Windows Explorer. With the Explorer interface, you can:

- Copy files from an FTP site to your local system (download).
- Copy files from your local system to an FTP site (upload).
- Copy files from one FTP site to another.

Starting WS_FTP Pro Explorer

This section describes how to start WS_FTP Pro Explorer and how to create a connection to an FTP site.

To start WS_FTP Pro Explorer, do one of the following:

- Start Windows Explorer, locate the WS_FTP Pro Explorer icon in the tree view (left pane), and click it.
- Double click the WS_FTP Pro icon on the desktop.
- Click the Start button and select Programs->WS_FTP Pro->WS_FTP Pro Explorer.

If you opened WS_FTP Pro Explorer from the Windows Explorer, you see a two-pane window.
If you opened WS_FTP Pro Explorer from the desktop icon or from the Start menu, you see a single-paned window.

The way you navigate differs slightly in the two windows, but both follow standard Windows conventions. Navigating in the two-paned window is exactly like using Windows Explorer; navigating in the single-paned window is exactly like navigating in the window you see when you double click My Computer on your Windows desktop.

Using Site Profiles

A site profile is a collection of information about an FTP server and how you want to work with it. Each site profile is represented by an icon.

To create a connection to an FTP site remote system, you either double click an existing site profile icon or enter information to create a new site profile. The site profile tells WS_FTP Pro the name of the remote system, its platform or host type, and the login information (among other things).

Creating a New Site Profile

You can create a new site profile as follows:

1. Double click the Add Site icon, or select Add Site from the File menu.

2. Follow the prompts in the Add FTP Site Wizard.

   You’ll first enter a name to identify the site profile you’re creating. (This can be any name you want.)
For **Host Name or IP Address**, enter the name of the FTP site to which you want to connect. (This must be either a fully qualified Internet host name or an IP address.)

3. On the third panel of the **Add FTP Site Wizard**, do one of the following:

   - Unless you have special privileges on this FTP site, check **Anonymous**. This automatically enters “anonymous” as your user name. If your e-mail address is not already entered as the password, enter your full electronic mail address.

     You can place a minus (-) sign in front of your e-mail address to reduce the number of messages you’ll receive from the site administrator.

   - If you have an account on the FTP server, make sure **Anonymous** is not checked and enter the user name and password for your account.

       **Note:**
       Do not check the **Save Password** box unless you are the only user of your computer and no one else has access to your WS_FTP directory!

4. Click the **Finish** button.

   WS_FTP Pro Explorer connects you to the site and displays the default directory as determined by the user name in the site profile. For example, if you connected using “Anonymous,” you see the default directory for anonymous logins. You can change this as well as many other default settings in the site profile using the procedures described in the “Editing...” sections below.

**Saving and Deleting Site Profiles**

When you create a site profile as described above, WS_FTP Pro Explorer adds it to your site profile list. The site profile is represented by a site icon with the name you entered. Once you have created a site profile, you can connect to the same site again by double clicking the site icon.

To delete a site profile, highlight the site icon and select **Delete** from the File menu.
Using Preconfigured Site Profiles

WS_FTP Pro Explorer comes with a number of preconfigured site profiles for some of the popular FTP sites. Double click the preconfigured site icons to connect to any of these sites. You can customize these profiles and add new ones.

Editing the General Options for Site Profiles

The general options for a site profile include the host name, host address, host type, and a comment on the site.

1. Select the site icon.

2. Select Site Properties from the File menu.

3. Click the General tab.

4. (Optional) To change the name of the site profile, enter a new name in the Site Name text box.

5. (Optional) To edit the FTP site’s name or address, enter a new name or address in the Host Name/Address text box. (This must be either a fully qualified Internet host name or IP address.)

6. (Optional) To change the server type, select the type from the Host Type drop-down list. If you don’t know the server type, try “automatic detect.”

7. (Optional) To add a comment about the site, type into the Comment text box.
Editing the Login Options for Site Profiles

The login properties of a site profile determine the way you log on to an FTP site.

1. Select the site icon.

2. Select Site Properties from the File menu.

3. Click the Login tab.

4. Do one of the following:

   - To log in as an anonymous user, make sure Anonymous is checked. WS_FTP Pro Explorer enters your e-mail address as your password.

   - If you have special access privileges to the site, you must enter the appropriate user name, so make sure Anonymous is unchecked. Enter User Name (or ID), Password, Confirm Password, and Account (if applicable).

   **Note:**
   Do not check the Save Password box unless you are the only user of your computer and no one else has access to your WS_FTP directory!
Editing the Startup Options for Site Profiles

You can specify what you view when you first log onto an FTP site.

1. Select the site icon.

2. Select **Site Properties** from the File menu.

3. Click the Startup tab.

4. (Optional) In the **Initial remote folder** text box, enter the path you’d like to view when you first connect to this site.

5. (Optional) In the **Initialization command** text box, enter any commands you want to issue to the FTP site at the beginning of the session. Separate multiple commands with a semi-colon (;). For example, the command SITE UMASK 022 changes the UMASK used when creating files (on some UNIX systems).

6. (Optional) To limit the number of files you see on the FTP site, you can enter a file mask in the **Remote file mask** text box. See “Viewing Only Certain Types of Files” below.

7. WS_FTP Pro Explorer can adjust the display of file dates and times on an FTP site so they represent the times and dates in your time zone. For example, if an FTP site is in a time zone three hours earlier than your time zone, you can enter ~3 to have WS_FTP Pro Explorer adjust a date and time of 11/10/97 1:00 AM to 11/9/97 10:00 PM.
(Optional) In the **Time offset in hours** text box, enter the difference in whole hours between your time zone and the time zone of the FTP site. Use a positive number if the site is in an earlier time zone (west), a negative number for a later time zone (east).

**Editing the Firewall Options for Site Profiles**

The firewall options for individual site profiles are closely related to the overall firewall options for WS_FTP Pro Explorer, so they are covered near the end of this chapter in the “Using Firewalls” section.

**Editing the Preferences for Site Profiles**

The preferences for individual site profiles are closely related to the overall preferences for the WS_FTP Pro Explorer application, so they are covered later in this chapter in the “Preferences” section.

**Editing the Advanced Options for Site Profiles**

You can control advanced network functions.

1. Select the site icon.
2. Select **Site Properties** from the File menu.
3. Click the Advanced tab.

4. (Optional) The **Connection Retry** text box lets you tell WS_FTP how many times to try again to connect to an FTP server if the initial attempt fails. The maximum number of retries is 40.
5. (Optional) Enter the **Network Timeout**, the number of seconds that elapses before WS_FTP Pro Explorer stops waiting for an FTP site to respond. Normally, the network timeout is determined by your Winsock DLL. (You can set it to *less* time than your Winsock DLL, but setting it higher won’t affect anything.)

6. (Optional) The **Remote Port** for the FTP protocol is normally 21, however, it may be something different if you are going through a firewall, or if the site administrator has assigned the FTP protocol to another port.

7. (Optional) Use the **Passive Transfers** text box to specify passive transfers. Normally, when you connect to an FTP site, the FTP server establishes the data connection to your local system (the FTP client). However, if the site allows passive transfers, you can have your local system establish the data connection.

   You’ll want to use passive transfers for local area networks that are behind some types of router-based firewalls or behind a gateway that requires passive transfers. You should also use passive transfers if you keep getting “failed data channel” errors.

---

**Connecting and Disconnecting**

To connect to an FTP site, double click the site icon. WS_FTP Pro Explorer connects to the FTP site and displays its contents.

To disconnect from an FTP site, select **Disconnect** from the File menu. To disconnect from all sites to which you are connected, select **Disconnect All**.
Working with Files and Folders

After connecting to an FTP site, you use standard Windows Explorer techniques to view and browse files and folders on the site.

Changing Disk Drives

If the server allows it, you can change disk drives: select Change Folder from the File menu, enter the drive letter and a semicolon (for example, d:), and click OK. Don’t enter a trailing slash (/).

Changing Folders

To change folders, do one of the following:

- Use standard Windows techniques.
- Select Change Folder from the File menu.

Creating and Removing Folders

Usually, FTP clients who log on to a site anonymously can view and copy files, but not add, edit, or delete files and folders. However, the actual anonymous privileges depend on how the site administrator has set up the rules. If you’re allowed to, you create a folder by selecting New Folder from the File menu; to delete a folder, highlight the folder and select Delete.

Viewing Directories and Files

If you’re new to FTP, you’ll need to know how to determine what files are available on a site. Look for a file called readme, readme.txt,
index, or 00index to get a description of the available files, as well as other site information. You can also try the pub directory.

After performing folder or file operations outside of WS_FTP Pro Explorer, you can refresh the window to display any recent changes to the current folder, or to unselect any selected files or folders. To refresh, select Refresh from the View menu (or press F5).

**Viewing Only Certain Types of Files**

If the FTP site has a large number of files, you can limit the types of files displayed by using a remote file mask. However, this option also masks folders, so don’t use it if you’ll need to browse the hierarchy on the site to find the files you want.

If you use a remote file mask, you should know exactly which directory you want to work with on the site and enter it as the Initial Remote Folder on the Startup tab of Site Properties.

To view only certain types of files:

1. Select Site Properties from the File menu.
2. Click the Startup Tab.
3. Enter the file extension in the Remote file mask text box. For example, to display only files with the extension .txt, enter *.txt as the remote file mask.

   If you are connected to a UNIX host, you can use -al or -la in the remote file mask to view all files, including hidden (.) ones. Or, you can use -altz to receive filenames in date sequence. [For those who are familiar with DOS FTP clients: You can also enter any argument string you would use with a “Dir” command.]

4. Select Refresh from the View menu (or press F5).
Sorting Files and Folders

You can view files and folders several different ways. Select Arrange Icons from the View menu, and select Name, Domain Name, or Last Visit.

If you are viewing file details (select Details from the View menu), you can sort files and folders further by name, size, type, or date modified; you do this by clicking a column heading to toggle the sorting of that column between ascending and descending order.

Transferring Files and Folders

Before you transfer a file or files, open a window showing the source files, as well as a window on the destination folder.

Downloading Files and Folders

Downloading a file or folder copies it from an FTP site to your local system.

To transfer files (or folders) from an FTP site to the Default Download Directory (on the Directories tab of WS_FTP Pro Explorer Properties):

1. Select the file(s) you want to transfer. (Shift-click or Ctrl-click to select multiple files.)
2. Select **Open...** from the right-mouse menu.

   ![FTP Explorer Window](image)

3. Click **Save it to disk**.

4. Click **OK**.

   **To transfer files (or folders) from an FTP site to a location other than the Default Download Directory:**

   1. Connect to the FTP site where the file(s) are located.

   2. Locate and select the file(s) to download, and then select **Copy** from the Edit menu.

   3. Locate and select the folder to which you want to copy the file(s), and then select **Paste** from the Edit menu.

   For information on dragging and dropping instead of copying and pasting, see “Using Drag and Drop,” below.

   **Uploading Files and Folders**

   Uploading a file or folder copies it from your local system to an FTP site.

   1. Connect to the FTP site to which you want to upload the file(s), then locate the desired destination folder.

   2. Locate and select the file(s) you want to upload, and select **Copy** from the Edit menu.
3. Highlight or open the destination folder on the FTP site, and select **Paste** from the Edit menu.

For information on dragging and dropping instead of copying and pasting, see “Using Drag and Drop,” below.

**Moving Files and Folders**

You are able to move a file only when you have access privileges allowing you to delete files from the source location, and write access to the destination location.

Moving a file copies the file to a destination location and then *deletes* it from the source location. You move files by dragging and dropping using either the Shift key or the right-mouse button.

---

**Note:**

You can move files only by dragging and dropping. You can not move files using menu commands.

---

By default, the move option is disabled; to turn it on:

1. Select **WS_FTP Pro Explorer Properties** from the File menu.
2. Click the Preferences tab.
3. Make sure **Allow files and directories to be moved** is checked.

To move a file (once moving is enabled and if you have access privileges as described above), do one of the following:

- Hold the Shift key down while you drag the file.
- Drag the file using the right-mouse button, and then select **Move Here** from the right-mouse menu.

To get prompted for path/filename while moving files, see “Getting a Path/Filename Prompt” later in this chapter.

---

**Note:**

To specify the file transfer mode when you move a file, you’ll need to copy the file first using the procedure in “Using Transfer Modes,” below. After the file is copied, delete it from the source location.
**Using Drag and Drop**

For uploads, downloads, and the moving of files, you can use drag and drop. This is handy if it’s easy to arrange the source and destination locations so you can see them both. You have these options:

- Drag and drop with the left mouse button.
- Drag and drop with the right-mouse button to get a pop-up menu with various options on it.
- Shift-drag to move the file. See “Moving Files and Folders” above for information on moving files.

The cursor changes when you drag and drop, depending on whether you’re moving or copying.

If it’s difficult to display both the source and destination locations at the same time, use Copy and Paste for uploading or downloading.

1. Select the file(s) you want to transfer. (Shift-click or Ctrl-click to select multiple files.)
2. Select Copy from the Edit menu.
3. Highlight or open the destination folder.
4. Select Paste from the Edit menu.

Most procedures in this chapter tell you to use Copy and Paste, but you can always drag and drop instead. Likewise, most procedures tell you to select a command from the menu bar, but you can also use the right-mouse menu or a keyboard shortcut whenever you like.
Using Transfer Modes

Files can be transferred in ASCII or binary transfer mode. **Binary** transfer mode transfers a file as an exact copy of the original. A binary file can run only on the machine for which it was compiled. Binary mode contrasts with **ASCII** mode, which treats a file as text, translating the end-of-line characters during the transfer to accommodate differing operating systems. **ASCII** transfer mode is appropriate for a file that appears to be plain text, postscript, or other ASCII format.

Binary transfer mode is appropriate for a file that appears to be data, an image, an executable, or compressed. (Examples are applications, word processing documents, databases, spreadsheets, graphics files, and sound files.) Binary mode should also be used if there is no file extension, the file extension is not registered, or you are unsure of the file type. Furthermore, if you know that the FTP site and your local system use the same operating system, you can use binary mode for both text and data files.

**Auto** mode transfers all files in binary mode unless the extension is entered on the Extensions tab of the **WS_FTP Pro Explorer Properties**, in which case the file is transferred in ASCII mode.

To enter the file extensions that indicate ASCII files, select **WS_FTP Pro Explorer Properties** from the File menu and click the Extensions tab.
To specify the transfer mode when copying or saving:

1. Select the file.

2. Select **Open...** (with ellipses) from the File menu.

3. Select the desired transfer mode (**ASCII**, **Binary**, or **Auto**).

4. Do one of the following:
   - To open the file, select **Open it**.
   - To copy the file to the Default Destination Directory, select **Save it to disk**.

**Opening (Executing) a File**

When you open (execute) a file on an FTP site, **WS_FTP Pro** Explorer transfers the file to the Temporary Directory of the local system (indicated on the Directories tab of **WS_FTP Pro Explorer Properties**) and then opens the file in the associated application.

To open (execute) a file:

1. Connect to the FTP site and locate the file you want to open.

2. Do one of the following:
   - Double click the file.
   - Select **Open** from the File menu.
• Select Open... to change the file transfer mode.

WS_FTP Pro Explorer copies the file to your Temporary Directory with a new unique name and then opens it in the application associated with the file extension. (To see where your Temporary Directory is located, select WS_FTP Pro Explorer Properties from the File menu and click the Directories tab.)

If you want to keep the file you opened, you can usually save it with a new name by selecting Save As... from the File menu of the application that opened it. (If you do this, delete the temporary file as described in the next paragraph.) Or, you can just close the file and leave it in the Temporary Directory, but the file will have the name assigned by WS_FTP Pro Explorer. You can also rename the temporary file and move it somewhere else.

If you don’t want to keep the file you opened, go to your Temporary Directory, locate the file, and delete it. (To see where your Temporary Directory is located, select WS_FTP Pro Explorer Properties from the File menu and click the Directories tab.)

Remote-to-Remote Transfers

You can transfer files from one FTP server to another if the destination site supports third-party transfers.

1. Connect to the destination site and locate the desired destination folder.
2. Connect to the source site and open the folder from which you want to copy the file(s).

3. Locate and select the file(s) you want to copy, and select **Copy** from the Edit menu.

4. Select the folder to which you want to copy the file(s), and select **Paste** from the Edit menu.

**Editing Files**

You can edit a file on an FTP site if you have permission to do so. When you edit a file on an FTP site, WS_FTP Pro Explorer transfers the file to the Temporary Directory (indicated in the Directories tab of **WS_FTP Pro Explorer Properties**) and then opens the file in the associated application. To edit a file on an FTP site:

1. Connect to the FTP site and locate the file you want to open.

2. Do one of the following:
   - Select **Open** from the File menu. WS_FTP Pro Explorer copies the file to your Temporary Directory (indicated in the Directories tab of **WS_FTP Pro Explorer Properties**) with a new unique name, and then opens it in the application associated with its file extension.
   - Select **Open...** to change the file transfer mode.

Select the desired transfer mode and select **Open it**.
3. Edit the file and save it with its original name by choosing **Save As...** from the File menu of the application that opened the file.

4. Upload the file to the FTP site, as described in the “Uploading Files” section earlier in this chapter.

**Naming and Renaming Files**

You can rename a file on an FTP site if you have write access to that site. To rename a file, highlight the file and select **Rename** from the File menu. Enter the new name for the file and click **OK**. If you selected multiple files, you are prompted to rename each file.

You can also have WS_FTP Pro Explorer prompt you for a path/filename at the time of transfer. See “Getting a Path/Filename Prompt” later in this chapter.

**Using chmod**

To change the mode or permissions for a UNIX file on an FTP site (provided you have permission):

1. Select the file.

2. Select **chmod** from the right-mouse menu.

   The Remote File Permissions dialog box appears. Select whatever options you want and click **OK**.

**Deleting Files**

If your access privileges allow you to delete files, highlight the file and select **Delete** from the right-mouse menu.
Program Options

You can set a number of options to determine how WS_FTP Pro Explorer works.

Editing the Directories Options

To check or specify the location of your WS_FTP Pro Explorer directories, select **WS_FTP Pro Explorer Properties** from the File menu and click the Directories tab.

The **Program Directory** shows where the WS_FTP Pro Explorer application is installed.

The **Temporary Directory** is the folder on your local system to which WS_FTP Pro Explorer copies files you open. By default, this directory is named WS_FTPE and is located in your *Temp* folder.

The **Default Download Directory** is the folder on your local system to which a file is copied if you open it using the **Open...** command and then select **Save it to disk** in the dialog box.
Editing the Site Profile List Options

The Site List tab lets you specify where to store your FTP site profiles.

WS_FTP Pro Explorer can store your FTP site profiles in either the ws_ftp.ini file or in the Windows Registry. If you have the WS_FTP Pro classic user interface installed, or if you think you might install it someday, use ws_ftp.ini file to store site profiles. This way, both programs share the same FTP site profiles (referred to as “session profiles” in the classic interface); a profile added in one program will appear in the other.

Note:

If you store your site list (Explorer interface) in the Windows registry, and you later run the classic interface of WS_FTP Pro, the two interfaces will not be able to share the same session/site profiles.
Editing the Logging Options

The logging tab lets you keep a log showing the date, time, source, and destination of all file transfers.

Setting Extensions

When Auto is the transfer mode, WS_FTP Pro Explorer transfers all files in binary mode, unless the file extension is listed as ASCII. Select Site Properties and then click the Extensions tab.
The list box lists all file extensions that WS_FTP Pro Explorer transfers in ASCII mode when Auto mode is selected. The list displayed here is stored in the *ws_ftp.ext* file.

To add a file extension to the list:

1. In the **ASCII Filenames and Extensions** text box, enter the file extension. The extension can be up to nine characters long and can contain periods.

2. Click the **Add** button.

   The extension appears in the list box.

To delete a file extension from the list box, select the extension and click the **Delete** button.

---

**Preferences**

There are a number of preferences you can set to make WS_FTP Pro Explorer work just the way you like. There are Preferences tabs in both the **WS_FTP Pro Explorer Properties** and in the **Site Properties** for each FTP site. Thus, you can determine the way the application performs all transfers, as well as customize the way it transfers files to and from particular sites.
The Preferences settings in **WS_FTP Pro Explorer Properties** become the default for all new site profiles. Furthermore, if you click **Apply to All** on this tab, the settings are applied to all existing site profiles.

On the other hand, if you click **Apply to All** on the Preferences tab of an individual site’s **Site Properties**, the settings are applied to the **WS_FTP Pro Explorer Properties** Preferences tab, as well as to all other site profiles.

**Monitoring the Status of a Transfer**

**WS_FTP Pro Explorer** can monitor the status of a transfer.

To display this notice:

1. Do one of the following:
   - To monitor the progress of transfers to or from *a particular site*, select the site icon and select **Site Properties** from the File menu.
   - To monitor the progress of *all* transfers, select **WS_FTP Pro Explorer Properties** from the File menu.

2. Click the Preferences tab.

3. Make sure **Display transfer status dialog** is checked.
Displaying a Notice When a Transfer is Complete

WS_FTP Pro Explorer can display a notice when a transfer has been completed.

To display this notice:

1. Do one of the following:
   - To display a notice when a transfer to or from a particular site is complete, select the site icon and select Site Properties from the File menu.
   - To display a notice when any transfer is complete, select WS_FTP Pro Explorer Properties from the File menu.
2. Click the Preferences tab.
3. Make sure Display transfer complete dialog is checked.

Getting an Alert Before You Overwrite a File

WS_FTP Pro Explorer can alert you when you’re about to overwrite a file.
To get this alert:

1. Do one of the following:

   • To get an alert before you overwrite a file when you’re working with a particular FTP site, select the site icon and select Site Properties from the File menu.

   • To get an alert before you overwrite any file, select WS_FTP Pro Explorer Properties from the File menu.

2. Click the Preferences tab.

3. Make sure Confirm file overwrite is checked.

**Getting a Confirmation Before You Delete a File**

WS_FTP Pro Explorer can alert you when you’re about to delete a file.

To get this alert:

1. Do one of the following:

   • To get a confirmation before you delete a file from a particular site, select the site icon and select Site Properties from the File menu.

   • To get a confirmation before you delete any file, select WS_FTP Pro Explorer Properties from the File menu.

2. Click the Preferences tab.

3. Make sure Confirm file delete is checked.
Getting a Path/Filename Prompt

WS_FTP Pro Explorer can prompt you for a path and filename when you transfer files.

To get this prompt:

1. Do one of the following:
   - To get a path/filename prompt when you transfer files to and from a particular site, select the site icon and select Site Properties from the File menu.
   - To get a path/filename prompt when you transfer any file, select WS_FTP Pro Explorer Properties from the File menu.

2. Click the Preferences tab.

3. Make sure Prompt for destination name is checked.

Updating or Retaining File Date and Time

By default, when you download a file, the file date and time are updated to the date and time of the transfer. You can change this so the original date and time are retained.

Note:
You can not retain the date and time when uploading; on uploads, the file date and time are always updated.

To specify how the file date and time are handled:

1. Do one of the following:
   - To determine whether the file date and time are updated when you download to a particular site, select the site icon and select Site Properties from the File menu.
• To determine whether the file date and time are updated when you download any file, select **WS_FTP Pro Explorer Properties** from the File menu.

2. Click the Preferences tab.

3. Do one of the following:

   • To retain the file dates and times, make sure **Retain file date and time** is checked.
   
   • To update the file date and time to the date and time of the transfer, make sure **Retain file date and time** is unchecked.

### Converting Filenames to Lower Case

Some UNIX sites support only filenames that are all lower case letters. For example, if you want to upload a copy of *MyText.txt* to one of these sites, you’d want the transferred filename on the FTP site to be *mytext.txt*.

---

**Note:**

You can not automatically convert filenames to lower case when downloading files. However, you can do the automatic conversion when transferring from one FTP site to another.

---

To convert filenames automatically to lower case as you upload:

1. Do one of the following:

   • To determine whether or not to convert uploaded filenames to lower case on a particular site, select the site icon and select **Site Properties** from the File menu.

   • To determine whether or not to convert uploaded filenames to lower case on any file, select **WS_FTP Pro Explorer Properties** from the File menu.

2. Click the Preferences tab.

3. Make sure **Convert filenames to lower case** is checked.
Using the Explorer Interface

Resuming a File Transfer after Failure

When a download is interrupted because of a lost connection or because it was cancelled, WS_FTP Pro Explorer can resume the transfer the next time you reconnect to the FTP site. If you choose to resume the transfer, WS_FTP Pro resumes it at the point of interruption.

If you choose not to resume the transfer, you will be left with a partial file (from the interrupted transfer) in the destination folder. You should delete this file.

Not all FTP servers allow resumption of transfers, although most servers do.

To view or change the state of this option:

1. Do one of the following:
   - To enable resumption of failed or interrupted downloads from a particular site, select the site icon and select Site Properties from the File menu.
   - To enable resumption of failed or interrupted downloads from any site, select WS_FTP Pro Explorer Properties from the File menu.

2. Click the Preferences tab.

3. Make sure Automatic re-get of failed transfers is checked, or, to disable this feature, uncheck it.

Using Firewalls

Some organizations separate their networks from the rest of the world with a firewall. If your company uses a firewall, and the firewall is configured to block FTP transfers, you can configure WS_FTP Pro Explorer to go through the firewall. To do this, you’ll need to get information about your firewall from your network administrator; you’ll need the firewall type, as well as the following information.

- For a “SITE hostname” firewall type, you’ll need Host Name (or IP Address) and User Name (User ID).
• For a “Transparent” firewall type, you’ll need **User Name** (User ID) and **Password**.

• For “USER with no logon” or “Proxy OPEN” firewall types, you’ll need the **Host Name** (or IP Address). The User Name and Password are ignored.

• For “USER after logon,” “USER remoteID@remoteHost fireID,” or “USER fireID@remoteHost” firewall types, you’ll need **Host Name** (or IP Address), **User Name** (User ID), and **Password**.

Use the Firewall tab of **WS_FTP Pro Explorer Properties** to set the same firewall settings for all new sites, or to reset firewall settings for existing sites. Use the Firewall tab of **Site Properties** to specify the firewall settings for a particular site.

1. Select **WS_FTP Pro Explorer Properties** or **Site Properties** from the File menu and click the Firewall tab. (If you are setting firewall properties for a site, check **Use Firewall**.)

![Firewall tab screenshot]

2. Select the **Firewall Type** from the drop-down list.

3. Enter the **Host Name** or **IP Address** of the firewall.

4. Enter the **Port** number.

5. Enter the firewall **User Name** and **Password**.

---

80  
*User's Guide*  
**WS_FTP Pro**
Note:
Do not check the **Save Password** box unless you are the only user of your computer and no one else has access to your WS_FTP directory!

The next time you attempt to connect to an FTP site, your local system connects to your firewall, and (usually) the firewall actually makes the connection to the FTP site.

---

**Working with Sounds**

You use the Windows Control Panel to change or turn off sounds in WS_FTP Pro Explorer.

1. Click the **Start** button on the Windows taskbar.
2. Select **Settings**, and then **Control Panel**.
3. Double click the **Sounds** icon.
4. Locate the WS_FTP Pro Explorer area of the scrolling list box.
5. Select the sound you want to change.
6. Select (none) or a new sound from the **Sound Name** drop-down list, or **Browse** to find another sound.
Chapter 4: Using Command Line Parameters

If you installed the "classic" interface, you can use WS_FTP Pro command line parameters to start and run WS_FTP Pro.

This chapter describes the syntax and arguments of the WS_FTP Pro command line parameters.

Command Line Examples

You can use WS_FTP Pro command line parameters to upload files, download files, invoke session profiles, or download a URL to a local file. A number of examples are shown below.

The following command uploads a file to a remote file:

```
ftp95pro local:\upload\file.zip  ftp.ipswitch.com:\upload\file.zip
```

The following command downloads a file to a local file:

```
ftp95pro ftp.ipswitch.com:\upload\file.zip
local:\download\file.zip
```

The following command downloads all zip files in the `download` directory on ftp.ipswitch.com to a local directory:

```
ftp95pro ftp.ipswitch.com:\download\*.zip  local:\download\`
```

The following example invokes the Session Profile dialog box with the profile named `download`: (You can use this command to create an icon that launches a profile, and then connect to the system by clicking the Connect button.)

```
ftp95pro -p download
```

The following example displays a dialog box that prompts for the command line:

```
ftp95pro -ask
```
The following commands download a URL file to a local file. Use the file or ftp parameters depending on the type of URL:

ftp95pro file://www.ipswitch.com/download/file.zip
    local:/download/file.zip

ftp95pro ftp://www.ipswitch.com/download/file.zip
    local:/download/file.zip

### WS_FTP Pro Command

The command for using WS_FTP Pro from the command line differs depending on which version you installed. The command for each version is shown below:

- **ftp95pro** — 32-bit version for Windows 95 and NT 4.0 or later
- **ftppro** — 16-bit version for Windows 3.x and NT 3.51

### Command Syntax

Use the following syntax to transfer a file using the command line parameters. Use the -m argument for transferring multiple files.

Items enclosed in brackets, for example [args], are optional. Italics indicate a variable, for example `hostname`. The bar character “ | ” indicates OR, for example `hostname | local` means enter either a hostname or the word `local`.

To transfer a file from the remote system to the local system:

**ftp95pro** [args] `hostname | profilename:pathname/filename`
    `local:pathname/filename`

In [args] you can specify any of the arguments described in the “Arguments” section of this chapter.
hostname: or profilename:

hostname must be the full domain name or the IP address of a remote host. The userid will be anonymous and the password will be the specified e-mail address. hostname must be followed by a colon.

profilename must be the name of a session profile created in the Session Properties dialog box. If the profile contains your username and password (and you checked the Save Password box), these are used. If the profile is not in the default .ini file, use the -i argument to specify another .ini file. profilename must be followed by a colon.

pathname/filename

You enter the pathname, including the drive letter, and the filename for the file on the remote system. (For example, c:\docs\report.txt)

local:pathname/filename

You enter the pathname, including the drive letter, and the filename for the file on the local system. (The pathname/filename is preceded by the word local followed by a colon, local:)

To transfer a file from the local system to the remote system:

ftp95pro [args] local:pathname/filename
hostname | profilename:pathname[/filename]

In [args] you can specify any of the arguments described in the “Arguments” section of this chapter.

local:pathname/filename

You enter the pathname, including the drive letter, and the filename for the file on the local system. (The pathname/filename is preceded by the word local followed by a colon, local:)

Using the DOS Command Line
hostname or profilename:

*hostname* must be the full domain name or the IP address of a remote host. The userid will be anonymous and the password will be the specified e-mail address. *hostname* must be followed by a colon.

*profilename* must be the name of a session profile created in the Session Properties dialog box. If the profile contains your username and password (and you checked the Save Password box), these are used. If the profile is not in the default *ini* file, use the *-i* argument to specify another *ini* file. *profilename* must be followed by a colon.

pathname[/filename]

Enter a pathname, and optionally a filename, to which you want to copy the file on the remote system. If you do not specify a filename, the local (original) filename is used.

File Transfer Notes

Please note the following:

- If the *hostname* or *profilename* does not specify an anonymous FTP session and the host requires a password, but it is not specified in the session profile, you will be prompted for the password (and account if applicable).
- The * and ? wildcards can be used in filenames to transfer multiple files.
- The **Preserve Date** (Pro tab) and **Convert Extensions** (Session tab) options do not work with command line transfers.
- During transfer of files, a dialog box displays the transfer status. You can click the Cancel button to cancel the transfer. The partial file is not deleted automatically.
- You can use the following construction to make WS_FTP Pro prompt for the command line.

    ftp95pro [args] -ask
Arguments

You can use the following arguments with the `ftp95pro` command. Note that the `-i` argument must precede the `-p` argument when both are used, and both of these arguments must precede any other arguments used.

- `i inifile` Forces WS_FTP Pro to use the specified `.ini` file, where `inifile` is the name of the `.ini` file. Use this option if the path is not known to your system or when you want to specify a particular `.ini` file that contains the profile you want to use. This argument must precede all other arguments.

- `p profilename` Run the profile to connect to a remote system, where `profilename` is the name of a session profile (created in the Session Properties dialog box). If the profile contains your username and password (and you checked the Save Password box), these are used. The profile must be in the default `.ini` file or in an `.ini` file specified with the `-i` argument. This argument must precede all other arguments, except `-i`.

- `c account` Specifies an account for those systems that require an account to log on or access partitions.

- `ascii` Specifies the file transfer mode. Use this argument when transferring text files.

- `binary` Specifies the file transfer mode. Use this argument when transferring non-text files, such as executable programs, word processing documents, spreadsheets, databases, graphics files and sound files.

- `quiet` Overrides the normal behavior of displaying a message box if an error occurs. Useful for automated transfers when you do not want WS_FTP Pro to prompt for user input when no one is there to press a key.
-lower Forces all local to remote file transfers to use lower case versions of the local filenames.

---

**Note:**
The -lower argument must be at the end of the command line.

---

-s hostname | local:pathname/filename

or

-s profilename | local:pathname/filename

Specifies the directory path and name of the file to be transferred (source file). For example:

- -s profilename:c:/pathname/filename
  (Remote source)
- -s hostname:c:/pathname/filename
  (Remote source)
- -s remote:c:/pathname/filename
  (Remote source)
- -s local:c:/pathname/filename
  (Local source)

-d hostname | local:pathname/filename

or

-d profilename | local:pathname/filename

Specifies the directory path and filename to which the source file is copied (destination file). For example:

- -d profilename:c:/pathname/filename
  (Remote destination)
- -d hostname:c:/pathname/filename
  (Remote destination)
- -d remote:c:/pathname/filename
  (Remote destination)
- -d local:c:/pathname/filename
  (Local destination)
-m filename_of_file_containing_args

Transfers multiple files. See the following section for more information.

Transferring Multiple Files

There are two ways to transfer multiple files:

- Use the * or ? wildcards in the filename.
- Use the -m argument and place the transfer commands in a file.

Using Wildcard Characters to Transfer Multiple Files

You can use the * and ? characters in filenames to specify multiple files. The following command downloads all zip files in the download directory on ftp.ipswitch.com to a local directory:

```
ftp95pro ftp.ipswitch.com:/download/*.zip  local:/download/
```

Using the -m Argument

```
-m filename_of_file_containing_args
```

where file is a file that contains the file transfer commands specified using the syntax shown above. Note that you do not enter the command itself (ftp95pro) in this file. For example, you can specify the command as:

```
ftp95pro -m transfer.txt
```

where transfer.txt contains the following lines:

```
ftp.wicket.com:/etc/hosts  local:/vmunix
ftp.wicket.com:/etc/hosts  local:/vmunix2
```

Each text line must contain only one command line. You can use any of the command line arguments in the transfer file. Multiple lines will be treated as a connect/transfer/disconnect for each line. If a directory transfer is specified, it will complete in one connection.
Invoking a URL with WS_FTP Pro

You can start WS_FTP Pro and invoke an FTP URL (Uniform Resource Locator) to access an FTP site. For example, you can use the following construction:

\texttt{ftp95pro [args] ftp://hostname | profilename.pathname}

where you enter the \textit{hostname} of the remote system or a \textit{profilename}, and the \textit{pathname} of the directory on the remote system where you want to start.

You can use the following constructions to download a file defined by a URL.


\texttt{ftp95pro [args] file://hostname | profilename:pathname/filename [local:pathname/filename]}

where you enter the \textit{hostname} of the remote system or a \textit{profilename}, the directory \textit{pathname} and \textit{filename} on the remote system, and the directory \textit{pathname} and \textit{filename} on the local system.
Chapter 5: Troubleshooting

This chapter lists some of the common FTP connection and file transfer problems. For more information, see the Support area of the Ipswitch web site, www.ipswitch.com.

Problems Connecting to an FTP server (Remote System)

Problem: I cannot connect to a remote system.
Solution: Make sure you have an active dial-up or direct Internet connection. WS_FTP Pro is not a dialer; it calls the Winsock DLL and uses the dialer or direct connection specified there.

Problem: I cannot log on to the remote system.
Solution: Check your directory and file access permissions on the remote system. These permissions may only be set by the FTP server administrator; they cannot be changed by WS_FTP Pro.

Problem: My connection closes after n minutes of inactivity.
Solution: The FTP server determines the connection timeout, and most FTP servers close the connection after a few minutes of inactivity. This setting can be changed only by the FTP site administrator, not from WS_FTP Pro.

Problem: WS_FTP Pro can only connect to the WS_FTP site and nothing else.
Solution: Configure the DNS (Domain Name Server) in your stack. Talk to your network administrator or your Internet provider for the proper values for DNS.

Problem: WS_FTP Pro doesn’t work with my AOL connection.
Solution: AOL uses a 16-bit TCP/IP stack and will not work with 32-bit TCP/IP applications. For more information on AOL’s Winsock support, see the FTP section in your AOL application. You will need to run the 16-bit version of WS_FTP (FTPPRO.EXE).
Problems Viewing Directories and Files

**Problem:** When I connect to a remote system, the list box for the remote system is blank or contains garbage.

**Solution:** Change the host type. Try looking in the message log to see if the host type of the remote system is identified. If you can’t figure out the host type, you can try common types such as “UNIX (standard),” “Sun Solaris,” or “WinQVT/Net.” If those don’t work, try “Auto-detect.” If you are still having problems, see the **Directory Display Problems** topic in the on-line help.

**Problem:** When I connect to a remote system, the list box for the remote system is blank. In the status window the last thing I see is “DoDirList returned 4”.

**Solution:** Contact your Internet provider to get the proper setting for the Maximum Transfer Unit (MTU) of your network stack. (You can try 552 or 576 as they seem to be common proper values.)

Problems Transferring Files

**Problem:** I’ve received one or more “Blocking call cancelled” messages and the file transfer is incomplete.

**Solution:** If you are using the Microsoft TCP/IP stack (which is part of the Windows 95 and NT operating systems), try setting the Maximum Transfer Unit (MTU) to 576.

**Problem:** I cannot open a directory on the remote host or transfer a file.

**Solution:** Make sure you are using a valid login name and password. Otherwise, try selecting the Anonymous check box in the session (site) profile; or, contact the system administrator of the FTP server to which you are trying to connect.

**Problem:** WS_FTP Pro only returns NNNNN bytes of a file and can never retrieve the whole file.

**Solution:** Set your Maximum Transfer Unit (MTU) in your program stack to 576.
**Problem:** WS_FTP Pro does not always return a complete file and leaves off from 50 to 512 bytes.

**Solution:** Some network stacks do not properly handle data packets that have the FIN flag set. If you're not using the Microsoft TCP/IP stack (part of the Windows 95 and NT operating systems), contact your network stack provider for an updated version of the network stack.

**Problem:** How can I transfer a hidden file or a file with a filename containing special characters?

**Solution:** In the classic interface, make sure nothing is selected, and then click the transfer arrow; you will be prompted for the filename.

**Problem:** The files I transferred are corrupted.

**Solution:** You may have transferred a binary file in ASCII transfer mode; this can damage the file. Make sure you transfer text files in ASCII mode and most other files in BINARY mode. If you still have problems, verify that you have hardware flow control enabled on your modem. If you are not using the Microsoft TCP/IP stack (part of the Windows 95 or NT operating system), contact your stack vendor.

**Problem:** Running Windows 3.x, I find that uploading any file over 25K often takes more than 30 minutes, after which I am timed out and disconnected.

**Solution:** You can solve the slow transfer problem by adding the following to your SYSTEM.INI file (for WIN3.x):

```
[VNTSPSD]
MaxFramesSize=1000
```

**Problem:** I keep getting failed data channel errors.

**Solution:** Try passive transfers.

**Problems with WS_FTP Pro Settings**

**Problem:** WS_FTP Pro won’t save the internal window sizes when I press the Save Window Locations button.

**Solution:** When WS_FTP Pro starts, it may be using an erroneous INI file. Search your Windows directory and your executables directory.
for multiple WS_FTP.INI files. Determine which one you want and copy it into the WS_FTP executable directory. Delete or rename any other ones.

**Problems Renaming and Deleting Files**

**Problem:** I can’t rename a file on an FTP server.

**Solution:** You may not have renaming privileges on the server.

**Problem:** I can’t rename a file on an FTP server, even though I have renaming privileges.

**Solution:** You may be trying to use a long name on an FTP server that doesn’t allow long names. Try a name of eight characters or less.

**Problem:** I can’t delete a file from a remote system.

**Solution:** You may not have deletion privileges on the remote system.
Index

A
account on an FTP server, 6, 15, 16, 55
adding a session/site profile, 14, 52
alerts
before deleting, 35, 76
before overwriting, 48, 75
when transfer complete, 75
anonymous FTP, 6, 14, 15, 16, 35, 53, 55
AOL, 91
appending files, 30
application development
using command line, 83
using WS_FTP Pro Development Kit, 10
ASCII
transfer mode, 43, 65, 72
viewing files, 33
associating files with applications, 32, 46
B
binary. See transfer modes
blank list box, 92
blocking call cancelled, 92
buffer, 37
C
changing
directories and folders, 25
comments, 16
dates and times, 48, 56
default directories, 18, 70
directories and folders, 59
disk drives, 25, 59
double click action, 37
e-mail address, 35, 53
fonts, 39
FTP server name, 16, 54
host type, 16, 54
IP address, 16
name of session/site profile, 15, 54
name you log on with, 16, 55
names of files, 33, 69
password, 16, 55
session/site properties, 18, 54, 55, 56, 57
sounds, 39, 81
user ID, 16
ChgDir button, 25, 26
chmod, 34, 69

command line
arguments, 87
temporary directory, 32, 33, 70
examples, 83
functions, 44–49
syntax, 84
commands, initialization, 18, 56
commenting on an FTP server, 15, 16, 54
commenting on an FTP server (remote system), 54
common questions. See troubleshooting confirmations. See alerts
connecting
messages, 15
problems, 57, 91
retry, 20, 57
to an FTP server
(remote system), 17, 24–26, 52, 53, 58
converting, file extensions, 41, 44
corrupted files, 93
cursors. See dragging and dropping
D
dates and times
adjusting, for a different time zone, 19, 56
older or same, 49
retaining, 48, 77
updating, 48, 77
default
download directory, 61, 70
for new session/site profiles, 53
initial local directory/folder, 18
initial remote directory/folder, 18, 56
program properties, 34, 70, 73
temporary directory, 32, 33, 70
deleting
a file from an FTP server (remote system), 34, 69
a session/site profile, 17, 53
confirming before, 35, 76

Bold page numbers refer to the Explorer interface.
directories and folders, 26, 59
files from the default download directory, 48
files from the temporary directory, 67
icon from desktop, 8
problems, 94
developing applications, using WS_FTP Pro
Development Kit, 10
developing applications, using the command line, 83
directories and folders
changing, 25, 70
creating, 26, 59
default, 19, 70
default download, 61
deleting, 26
downloading, 29, 61
information, 27, 36
initial local, 18
initial remote, 15, 18, 53, 56
listing, 22, 24
problems with, 92
refreshing, 24–26, 41
remembering, 25, 41, 42
sorting, 28, 61
temporary directory, 32, 33, 66, 67, 68, 70
uploading, 29, 62
viewing links, 43
viewing, 15, 22, 24, 25, 53, 59, 61
DirInfo button, 27, 35
disconnecting from an FTP server (remote system), 24, 58
disk drives, changing, 25, 59
display properties, 38
double click action, 37
downloading files, 29, 61
dragging and dropping, 31, 48, 63, 64
drives. See disk drives
E
e-mail address, 14, 35, 53
changing, 16
editing
See also changing remote files, 32, 36, 68
executing files, 32, 66
extensions. See associating files with applications; converting file extensions
F
failed data channel errors, 93
failed transfers, resuming, 48, 79
file associations. See associating files with applications
file extensions
and transfer modes, 45, 72
converting, 41, 44
file mask. See mask
file transfer protocol. See FTP (File Transfer Protocol)
files. See associations; converting; dates and times; deleting; downloading; dragging and dropping; executing;
extensions; hidden; mask; moving; transfer modes; uploading
filter. See mask
firewalls, 20, 41, 79
folders. See directories and folders
fonts, 39
FTP (File Transfer Protocol), 1, 58
FTP server
account on, 15, 16, 53, 55
address, 14, 53, 54
connecting to, 24, 58
disconnecting from, 24, 58
issuing commands to, 18, 56
name, 14, 53
remote-to-remote transfers, 67
type, 14, 40
using a file mask on, 19, 56
viewing contents of, 15, 22, 24, 53
FTP site. See FTP server
FTP-to-FTP transfers. See remote-to-remote transfers
H
hidden files, 27, 60, 93
host
See also FTP server address, 14, 54
ame, 14, 54
type, 14, 40, 54
host-to-host transfers. See remote-to-remote transfers
I
icon, removing from desktop, 8

Bold page numbers refer to the Explorer interface.
incomplete transfers, 91, 92
ini file (wsftp.ini), 71
initial remote directory/folder, 18, 56
initialization command, 18, 56
installing WS_FTP Pro, 7
interrupted transfers, resuming, 48, 79
Ipswitch, Inc.
e-mail address, 11
giving feedback to, 10
product updates, 10
web site, 10, 91

L
links, 43
local system
initial directory, 18
viewing contents of, 22
logging on, 15, 55
problems. See troubleshooting
logs, 23, 35, 72

M
mask, file, 19, 27, 56, 60
messages. See alerts
MkDir button, 26
mode. See transfer modes
moving files, 30, 63

N
names. See converting; FTP server; logging on; naming and renaming
naming and renaming
files as you transfer, 41, 42, 43, 77
files on FTP server (remote system), 33, 42, 69
files using lower case letters, 41, 78
problems, 94
session/site profiles, 15, 16, 54
network timeout, setting, 20, 58
notices. See alerts

O
opening a file, 32, 66
overwriting, confirming before, 48, 75

P
passive transfers, 20, 41, 58
password, 14, 16, 35, 53, 55, 81
patch. See software patch
path, 25, 30, 35, 43, 77
port (remote), 20, 58
problems. See troubleshooting
profile. See session/site profiles
progress. See status

Q
questions. See troubleshooting

R
re-getting. See resuming
refreshing, 41, 60
registry, Windows, 71
remote file mask. See mask
remote system. See FTP server
remote-to-remote transfers, 67
removing. See deleting
renaming. See naming and renaming
resuming failed or interrupted transfers, 48, 79
retrying a connection, 20, 57

S
session profile. See session/site profiles
session/site profiles
automatically saving when you connect, 37
creating, 14, 52
customizing, 18, 19, 20
defined, 14, 52
deleting, 17, 53
naming, 14, 52
preconfigured, 6, 17, 54

Bold page numbers refer to the Explorer interface.
renaming, 15, 54
saving, 17
storing, 71
using, 17
site list, 71
site name. See session/site profiles
site profile. See session/site profiles
site-to-site transfers. See remote-to-remote transfers
slow transfers, 93
software patch, 10
sorting, 28, 61
sounds, 39, 81
status, monitoring, 41, 74
symbolic links, 43
system requirements, 6

temporary directory, 32, 33, 67, 68, 70
text files. See ASCII
text viewer, 33, 35
time zone, 19, 56
timeout, network, setting, 20, 58
transfer modes
and file extensions, 45, 72
ASCII, 43, 72
auto, 31, 43, 65
binary, 43, 65
changing, 29, 31, 63, 66
defined, 65
L8, 43
passive, 20, 58
transferring files
from FTP server to FTP server. See remote-to-remote transfers
from FTP server to local system. See downloading
from local system to FTP server. See uploading
in passive mode. See passive transfers
troubleshooting, 91

Uuninstalling, 8
UNIX, 18, 19, 27, 34, 41, 42, 60, 78
uploading files, 29, 62
user ID, 14, 16, 55
user name, 14, 55

V
viewing directories and files, 22, 59

W
warnings. See alerts
window layout, 36, 38
window locations, 93
window sizes, problems saving, 93
Windows
File Manager, 32
registry, 71

Bold page numbers refer to the Explorer interface.