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Addendum to WhatsUp V2.5 Manual

This addendum describes the new features and enhancements in
Version 2.5 of WhatsUp — the network monitoring tool for
Windows. Please read the following for information on changes and
additions and keep this addendum with your WhatsUp manual.

In This Addendum

• New in Version 2.5 — describes new features in WhatsUp
Version 2.5.

• System Requirements — lists changes to the system resources
and software required for running WhatsUp.

• Documentation Notes — lists updates and corrections to the
WhatsUp User’s Guide.

WhatsUp 2.5 Release Notes — The release.txt file, found in the
directory where you installed WhatsUp, provides a detailed list of
enhancements and bug fixes.

WhatsUp Help — the WhatsUp help system has been updated to
reflect the changes in Version 2.5. To display help topics, select
Help–>Contents from a WhatsUp window, or press the F1 key in
dialog boxes and windows that don’t have a Help menu.

Support Knowledge Base — visit the Ipswitch web site
(http://support.ipswitch.com) and read articles about using WhatsUp.

New in Version 2.5

This version of WhatsUp contains the following new features:

• IPX monitoring. WhatsUp can now monitor a network element
that uses Novell NetWare’s IPX protocol.

• Enhanced the Auto Scan feature with options to resolve
hostnames, re–check a missed poll, and set a timeout after
which the scan continues to the next address.
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• Added options to help in configuring monitoring of a specific
service such as Internet Relay Chat (IRC) or Remote
Authentication and Dial–In User Service (RADIUS).

• Corrected NetBIOS checking so it works on Windows NT (with
NetBEUI installed) and for checking Windows NT systems.

System Requirements

To poll IPX network elements, Microsoft’s NWLink IPX/SPX
Compatible Transport must be installed and running on the
WhatsUp system. You can add this transport in the Control Panel’s
Network applet as follows:

For Windows 95 In the Control Panel, select Network,
then click Add, double–click Protocol,
click Microsoft, select IPX/SPX–compat-
ible Protocol.

For Windows NT 4.0 In the Control Panel, select Network,
then click Protocols, add NWLink IPX/
SPX–compatible Protocol.

For Windows NT 3.51 In the Control Panel, select Network,
click Add Software, select NWLink IPX/
SPX.

Documentation Notes

This section contains changes and corrections to the WhatsUp
User’s Guide. The changes in this release are also integrated into
the WhatsUp help file.

• Page 15. In the section, “Creating a Network Map,” the
following information about using the
Tools–>Import–>AutoLoad feature should be included.

Use AutoLoad to automatically scan your system’s hosts file
and the Windows registry (both of which list hostnames and
their associated IP addresses) and create icons for all network
elements found in those files.
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1. From the File menu, select New, or click the Create New
Map button in the button bar.

2. From the Tools menu, select Import–>AutoLoad . WhatsUp
scans the hosts file and the Windows registry and creates an
icon for each network element it finds. Make sure the host file
is located where the TCP/IP stack can find it.

3. Convert any PC icons to the appropriate icon (server, router,
bridge, LAN box, etc.) To change a network element’s icon,
click the Tools button to switch to Map Edit mode, select the
icon, and then select the appropriate icon type from the
Edit–>Convert To menu.

4. Enter or modify information about the network elements. See
“Setting Up Properties” in Chapter 3 for more information.

5. Use the Map Editor to move network elements and draw
connecting lines. See “Using the Map Editor” in Chapter 3 for
more information.

• Page 17. In the “Automatic Scan” section, three new options
are now available:  
Resolve names. Shows the hostnames for any active IP
addresses found. Note that selecting this option causes the scan
to take longer.

Double Check. Causes Scan IP to immediately check the host a
second time when the host misses a ping. This option applies
only on the first poll that fails.

ICMP Timeout.  If a network element does not respond to a
scan within this time, the Scan IP continues on to the next IP
address. The default is 500 milliseconds. You may want to
increase the timeout value for slow networks.

• Page 27.  In the “Defining Host Properties section,” Steps 2 and
6 should read as follows:

Step 2. In the Address/Name text box, if the polling type (see
Step 6) is TCP/IP, enter a hostname that can be resolved or an
IP address. If the polling type is NetBEUI or IPX, enter a
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NetBEUI or IPX name. This text box is limited to 49
characters.

Step 6. Select the Type for the polling method: TCP/IP (the
default), NetBEUI (used for Windows networks), or IPX (used
for Novell NetWare networks). This defines how the system
talks to the network element.

• Page 30.  In the “Monitoring Services” section, note that the
Services properties are disabled for IPX and NetBEUI network
elements. This applies to both monitoring the predefined
services (which are TCP/IP services) and monitoring a specific
service defined by the user.

• Page 32.  In the section “Setting Up a Specific Service,” there
are two new options available in the Services dialog box. The
Send command on connect and Expect after connect options
let you check the availability of a service by sending a
command recognized by the service and specifying the
expected reply.

For example, to check an IRC (Internet Relay Chat) service,
you can send the command “Version\r\n” and the expected
response from the IRC service is “:irc ” .

Name:  IRC

Port:    6667

(Select the TCP option.)

Expect on connect: leave blank

Send command on connect:  Version\r\n

Expected command response: :irc

Send to disconnect: QUIT\r\n

Another example is monitoring a RADIUS (Remote
Authentication and Dial–In User Service) service.

Name:  RADIUS

Port:  1645

(Select the UDP option.)

Expect on connect: leave blank

Send command on connect: \aD\@,0123456789012345\a\f

Expected command response: \cD\@

Send to disconnect: QUIT\r\n
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Make sure that the computer running WhatsUp is in the clients file
of the RADIUS server, and that it does not try to log in as a valid
user of the RADIUS computer.

Also note that you can use special characters to encode
commands in the “send” and “response” options. WhatsUp uses
ASCII characters where possible. \@=0, \a=1, \b=2, \c=3, etc.
with the exception that \r=0x0a, \n=0x0d, and \t=0x09. You can
also use %nnn where nnn is any value from 0 to 255.

The \r (carriage return) and \n (line feed) are the conventions
for sending these control characters to terminate a string. It is
up to the user to determine the proper strings to expect and send
in a user defined service.

• Page 34.  In the section “Defining Pop–up Menu Items,” note
that the default Menu properties are removed for IPX and
NetBEUI network elements.

• Page 39. In the section “Defining Beeper Notification,” there
are two new Code options in the Beeper section of the
Communications Setup dialog box. When the status of a
network element changes, WhatsUp sends one of these codes
along with the Beeper code to the specified beeper. The Up
code indicates that a network element has come back up after
being down (the default value is 0*). The Down code indicates
the element is down (the default value is 9*). The asterisk
character separates the codes from a subsequent message.

(The beeper code tells you which network element the
notification is for. You enter a beeper code when adding the
notification.)
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Also, in the Communications Setup dialog box, there is now a
Modem Init String  option in which you can specify the
commands to initialize your modem. The default string is
ATEOQOV1X4. What is expected in this string are the modem
commands for “Command Echo Off” (EO), “Result Codes On”
(QO), “Verbal Results” (V1), and “Extended Status” (X4).

• Page 42.  In the section “Defining Pager Notification,” there is
now a Parity  option in the Pager section of the
Communications Setup dialog box. Use this option to select the
parity setting used by your pager. The TAP protocol requires
the 7–E–1 setting. Some pagers require the 8–N–1 setting.

• Page 52.  In the section, “Using the Mini Status Window,” a
Quiet button now appears on the Mini Status — you can click
this button to turn off an alarm. 

Also, the Exit  button is now called the Map button. The
button’s function is the same — when clicked, WhatsUp closes
the Mini Status and opens the Map window.

• Page 58. In the “Program Options” section, two new options are
available:

Animate Icon. Check this box if you want to animate the Tools
icon in the toolbar (the Tools icon will flash). If you are using
Windows NT version 3.5 or 3.51, you must exit and restart
WhatsUp to implement this option.

Start in Mini Status Mode. Check this box to start WhatsUp in
Mini Status mode. Mini Status mode saves screen space by
providing a simple listing of the network elements (in place of
the main window).

• Page 66. In the section “WhatsUp Options,” in the Add/Edit
WhatsUp Reports dialog box, the report frequency is now
measured in minutes. Instead of sending the report “after every
nn system checks,” WhatsUp sends the report “after every nn
minutes.”  You specify the number of minutes (nn).
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Chapter 1: Introduction

With the rapid proliferation of computer networks, you need a tool to
easily monitor the status of networked components. If you are the
person responsible for installing, configuring, monitoring, and
correcting problems with an organization’s network and computer
assets, WhatsUp can make your job easier. WhatsUp is designed to
help you monitor the status of network resources.

What is WhatsUp ?

WhatsUp is an easy–to–use tool for monitoring TCP/IP and Netbeui
networks. WhatsUp initiates both visible and audible alarms when
monitored network elements do not respond to polling. WhatsUp will
even notify you by digital beeper, alphanumeric pager, and e–mail.

Designed for PCs operating with Windows 95 or Windows NT,
WhatsUp can be installed wherever needed and does not require
expensive, dedicated hardware. It could easily run in the background
on your PC. WhatsUp will work with any 32–bit TCP/IP stack, such
as those bundled with Windows NT and Windows 95. You can
configure WhatsUp and start monitoring your network without any
special training.

WhatsUp monitors vital network elements and system services and
generates an alarm when there is a problem. It also facilitates remote
support and diagnosis by allowing users to easily access all network
elements.
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WhatsUp Features

WhatsUp provides the following capabilities:

• Graphical display of components being monitored and their
status

• On–going confirmation of network connections

• Monitoring of a wide range of network elements, including
hosts, servers, workstations, bridges, routers, hubs, LAN
concentrators, and printers

• Monitoring of the availability of one or more predefined services
(e.g., SMTP, POP3, FTP, Telnet, WWW, or News) on a host

• Monitoring of the availability of a specific service on a remote
host (e.g., an alternate Web server on a non–standard port)

• Initiation of visible and audible alarms when any network
element does not respond to polling

• Remote notification by digital beeper, alphanumeric pager, and
e–mail

• Monitoring of hierarchical (multitiered) networks

• Automatic detection and display of all connected elements in a
subnet

• Ability to Telnet from WhatsUp to a monitored host using your
favorite Telnet program

• Monitoring of unmanageable as well as manageable network
devices

• Requires no additional agent technology on monitored network
elements

In addition, WhatsUp includes a versatile set of integrated tools that
let you search for and display information about organizations,
networks, computers, or people on a network. WhatsUp tools include
Lookup, Ping, Traceroute, Whois, and Finger.
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You can also configure WhatsUp to use your favorite FTP and Telnet
programs (such as WS_FTP Professional or VT320W for Windows
available from Ipswitch) to connect to networked hosts from within
WhatsUp.

Read Me First Information

Please reference the release notes included with this product for
information regarding enhancements and restrictions.

Please Send Us Your Feedback

We welcome your feedback on this product. Please send the results of
your evaluation and your comments and suggestions to the following
e–mail address:  feedback@ipswitch.com

System Requirements

WhatsUp requires the following system resources:

• An Intel 386, 486, or Pentium processor.

• Windows NT 3.51 or greater (not 3.5); or Windows 95 operating
system

• A TCP/IP protocol stack. Supported stacks include those from
Microsoft  (Windows 95 an NT) and Ipswitch (Windows 95).

Note:

To monitor Netbeui networks, you must run WhatsUp
on a Windows 95 system.
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Installation

1. Install a Windows TCP/IP stack on your system. Microsoft
provides a TCP/IP stack with Windows 95 and Windows NT.
Ipswitch also offers Acadia/VxD and CyberSuite that run on
Windows 95.

2. Insert the WhatsUp disk into a floppy disk drive.

3. Do one of the following:

– For Windows 95, click the Start button, select Run, and then
enter the diskette path followed by install.exe. For example:

a:install.exe

– For Windows NT, select Run from the File menu, and then

enter the diskette path followed by install.exe. For example:

a:install.exe

The installation program asks where you want to install
WhatsUp.

4. Enter a directory where you would like to install the WhatsUp
executables, release notes, and help file.

The installation program installs the files and creates a shortcut
for WhatsUp.

You are now ready to proceed to “Chapter 2: Getting Started.”
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Files Installed

The WhatsUp installation places the following files on your system:

whatsup.exe The WhatsUp executable program.

ipswsupt.dll Supports serial communications.

whatsup.bmp The default bitmap file used as the main
window background.

whatsup.txt Release notes for this version of WhatsUp.

down1.wav The sound file for the alarm activated when
a low–priority network element does not re-
spond to polling.

down2.wav The sound file for the alarm activated when
a medium–priority network element does
not respond to polling.

down3.wav The sound file for the alarm activated when
a high–priority network element does not
respond to polling.

up.wav The sound file for the alarm activated when
a network element comes back up after a
failure.
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Chapter 2: Getting Started

After completing the installation, you can start WhatsUp, create a
network map, and start monitoring your network.

Starting WhatsUp

To start WhatsUp:

• In Windows 95, click the Start button, and then select
Programs–>WhatsUp.

• In Windows NT, open the WhatsUp folder and click on the
WhatsUp icon.

The WhatsUp main window appears.

The WhatsUp Main Window

The WhatsUp main window graphically displays the database of
network elements and connections being monitored and provides
access to other WhatsUp features.
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Title bar
Menu bar

Button bar

Network map

Status line

The components of the WhatsUp main window are described below:

Title bar

Shows the name of the active network map and the polling
countdown when polling.

Menu bar

Provides menu choices for opening windows and accessing
commands.

Button bar

Provides quick access to frequently used commands. Position your
mouse pointer over a button to display a description of the button’s
action. You can display labels for each button, by enabling the Label
Toolbar option in Program properties (select File–>Properties).

Network map

Shows the active network map. You can load and save network maps
by selecting the Load or Save items from the File menu, or clicking
on the appropriate button bar button.

Status line

Shows any status or error message associated with the current polling
action.

Window 
Components
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On initial start up, WhatsUp reads the Windows registry and the
system hosts file on your system and creates a network map that
contains icons for the network elements found in these files. You can
use the Map Editor to add network elements, draw connecting lines,
and convert elements to a different icon type. You can also create a
network map by scanning a range of IP addresses or by reading a
hosts file.

For each network element, you can choose from a set of options in a
Properties window to determine how it is monitored and define what
action to take if the element does not respond to polling.

Once you have created or loaded a network map, you can set
WhatsUp to continuously monitor the network elements, or you can
initiate a single check of the network.

WhatsUp monitors each of the network elements defined in a
particular map/database by sending a set number of ICMP echo
requests to the specified IP address and then tracking the responses.
During monitoring operations, WhatsUp makes effective use of
colors to indicate the status of the various network elements. By
convention, those that respond to polling are displayed in green, those
that have missed one polling request are displayed in light green,
those that have missed two polling requests are displayed in yellow,
and those that are not accessible or have not responded to four
consecutive polling requests are displayed in red. You can easily
change these default color selections to fit your preferences.

While monitoring, you can display up–to–the–minute status
information about a particular network element by simply pointing to
it and clicking the left mouse button to display a status window.

How WhatsUp
Works



 10 User’s Guide

WhatsUp

Tutorial: Testing WhatsUp on your Network

The following procedure shows how you can quickly create and set
up a map of some of your network elements so you can test the
functionality of WhatsUp. If you have a large network, you will not
want to create each element manually — you can use the
Tools–>Import–>Scan IP or Tools–>Import–>Host File features to
more easily create a network map. The chapters that follow provide
detailed information on the different methods for creating a network
map and the options available for monitoring network elements.

To create a new network map:

1. Select New from the File menu, or click the Create New Map
button in the button bar.

2. In the button bar, click the Tools button. WhatsUp displays an
empty map with a grid and displays the Tools window, which
contains buttons to help you create a map.

3. In the Tools window, click the Add PC button, and then click on
the map to create an icon for the PC; or click the right mouse
button and select New–>PC from the pop–up menu.

4. In the Tools window, click the Configure button, and then click
on the PC element; or click the right mouse button on the
network element and select Properties from the pop–up menu.

The PC Properties dialog box appears.
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5. Enter the information in the Properties dialog box as shown. Set
the Display Name to Monitor or whatever name you would like
for the network monitor station. Set the Address/Name to
127.0.0.1 for this host.  (This is the local “loopback” network
address used by a network device when referenced from that
same device.) In the Type options, select TCP/IP.

Toggle on the Monitor check box to enable monitoring.

6. Click the OK button or press Enter.

7. To create an icon for one of your file servers: Click the Server
button in the Tools window, and then point to the desired
location on the map and click once to create the icon.

8. In the Tools window, click the Configure button, then click on
the Server icon. The Properties dialog box appears.
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9. Set the Address/Name text box of this new host to the IP
address or name of system on your network. (Note: If you use a
name, it must be able to be resolved by the network stack either
from a local hosts file or by looking it up on a Domain Name
Server, which is a server that lists hostnames and their IP
addresses. This name is looked up whenever the map is loaded.)
In the Network Type options, select TCP/IP. Click OK .

Toggle on the Monitor check box to enable monitoring.

After finishing the configuration of the new host system, you
should save the map by selecting Save As from the File menu.
Save the map with the name of “WhatsUp.db.” (You can use any
name here.)

10. After saving the map, click the Tools button to exit Edit mode
and enter Monitor mode. You can check the functionality of
WhatsUp by clicking on the green Check Mark in the button bar
or by selecting Check from the Tools menu.
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Your screen should look something like this screen.

Hints

• To move an icon, click the Tools button, click the Select button
in the Tools window, and then click and drag the icon to a new
position.

• To view information about the icon: in Monitor mode, click on
an icon to display status information.

• To change information about the icon (in Monitor mode), click
on the icon, and then select Properties from the dialog box.

• To draw connecting lines between network elements (in Edit
mode), click the Line button in the Tools window, and then click
and drag the mouse to create a line.

• To erase a line or icon (in Edit mode), click the Erase button in
the Tools window, and then click on the line or icon you want to
delete. Be careful to change out of Erase mode before clicking
on any other network elements.

• To undo your last edit, select Undo from the Edit menu.

If WhatsUp has not begun monitoring your network, you may need to
change some system parameters. See “Chapter 5: Setting System
Properties” for information on these parameters.



 14 User’s Guide

WhatsUp



 15Setting Up the Network Map

WhatsUp

Chapter 3: Setting Up the Network Map

This chapter describes how to get started using WhatsUp to monitor
your network. Before WhatsUp can monitor the PCs in your network,
you need to do the following:

1. Create a network map.

2. Set up properties for network elements (hosts, routers, bridges,
etc.).

3. Save the network map.

4. Set system options to determine how WhatsUp will monitor the
network elements.

The following sections describe each task in detail.

Note:

Do NOT monitor host systems, workstations, or other
network elements that you do not have control of with-
out the expressed permission of the owners of those net-
work elements.

Creating a Network Map

The network map is a graphical representation of the elements in your
network that you want to monitor. Network elements can be PCs,
hosts, servers, routers, bridges, hubs, LAN boxes, printers, or
subnetworks (subnets). The following shows a typical network map.
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There are three ways to create a map for your network:

• Use Scan IP to automatically detect and list all of the network
elements currently in your network. Then, you can select from
the list those elements that you want to appear in the map.

• Load a hosts file and WhatsUp will create an icon for each host
found in the file.

• Create an icon for each network element and enter information
about the element.

In all cases, you have the option of showing how network elements
are connected by using the Map Editor to draw connecting lines
between the network elements.

Automatic Scan

The Scan feature automatically detects and displays icons for the
systems in your network. You specify a range of IP addresses to be
scanned, and WhatsUp polls each address. If WhatsUp finds an active
host, it creates an icon for it on the map. After completing the scan,
you can arrange the network elements as you want them to appear
and draw connecting lines. By default, WhatsUp creates a PC icon
type to represent each system it scans. You can change the icon type
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(to a router, bridge, server, host icon, etc) to better represent the
network element.

A scan can also identify the network services (such as FTP, WWW,
SMTP) that are available on each system.

To start a Scan:

1. From the File menu, select New, or click the Create New Map
button in the button bar.

2. From the Tools menu, select Import–>Scan IP. The Scan Net

dialog box appears.

3. Enter a range of network addresses to scan.

For example, if your network addresses range from 156.21.50.1
through 156.21.50.254, you would enter the range as shown in
the dialog box above.

4. Click Start. (You can click Cancel at any time to stop the scan.
Note that it may take a few seconds for the system to respond to
a Cancel request)

WhatsUp scans the IP addresses and creates an icon for each
system it finds on the network. The Scan Net dialog box shows
the current address being scanned. The scan is completed when
the current address shown is the last in the specified range.

The Scan Net lists all network elements in a list box in the Scan
Net dialog box.
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5. Select the network elements you want to include in the map, and
then click the Add button.

Click on a system in the list to select it. Use the  Shift or Ctrl
keys to select multiple items.

WhatsUp creates icons for all selected network elements and
uses the network element’s hostname as the display name.

6. Click Exit  to close the Scan Net dialog box.

7. Convert any PC icons to the appropriate icon (server, router,
bridge, LAN box, etc.).

To change a network element’s icon, click the Tools button to
switch to Map Edit mode, select the icon, and then select the
appropriate icon type from the Edit–>Convert To menu.

8. Enter or modify information about the network elements. See the
“Setting Up Properties” section in this chapter for more
information.

9. Use the Map Editor to move network elements and draw
connecting lines. See the “Using the Map Editor” section in this
chapter for more information.

Load Host File

You can load a hosts file (which lists hostnames and their associated
IP addresses) and WhatsUp will create icons for each system listed in
the file.

1. From the File menu, select New, or click the Create New Map
button in the button bar.

2. From the Tools menu, select Import–>Host File.

The Browse dialog box appears.

3. Locate the hosts file and click OK .

WhatsUp scans the hosts file and creates an icon for each
network element it finds in the host file. Make sure the host file
is located where the TCP/IP stack can find it.
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4. Convert any PC icons to the appropriate icon (server, router,
bridge, LAN box, etc.)

To change a network element’s icon, click the Tools button to
switch to Map Edit mode, select the icon, and then select the
appropriate icon type from the Edit–>Convert To menu.

5. Enter or modify information about the network elements. See the
“Setting Up Properties” section in this chapter for more
information.

6. Use the Map Editor to move network elements and draw
connecting lines. See the “Using the Map Editor” section in this
chapter for more information.

Manually Draw a Map

You can create network elements manually by using the Map Editor.

1. From the File menu, select New, or click the Create New Map
button in the button bar.

2. In the button bar, click the Tools button. WhatsUp displays an
empty map with a grid

3. Use the Map Editor to create network elements. See the “Using
the Map Editor” section in this chapter for more information.

4. Enter information about the network elements. See the “Setting
Up Properties” section in this chapter for more information.

Using the Map Editor

You use the Map Editor to create, move, and delete individual
network elements and connecting lines. You can also use the Map
Editor to change the information associated with a particular network
element.

To access the Map Editor, in the button bar, click the Tools button.
The map background changes to a grid and the Tools window
appears.
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You can use the grid to help you align network elements. The Tools
window provides the map edit functions. These functions are also
available from a pop–up menu.

The Tools Window

To display the Tools window, click the Tools button in the button bar
or select Tools Window from the View menu.

Select

Configure

Add PC Add Host

Add Bridge

Add Lanbox

Add Printer

View

Eraser

Add Server Add Router

Add Hub

Add Subnet

Add Line
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Position the mouse pointer over a Tools Window button to display a
description of the button.

Select tool (arrow icon)

When the Select tool is active, you can click and drag a network
element to a new location on the map, or you can click and drag the
end point of a line to a new location.

View tool (magnifying glass icon)

When the View tool is active, you can click on a network element to
display its properties and status.

Configure tool (computer icon)

When the Configure tool is active, you can click on a network
element to view and modify its properties. See the “Setting Up
Properties” section in this chapter for more information.

Erase tool (eraser icon)

When the Erase tool is active, you can click on a network element or
line to erase it. The Undo button on the button bar can undo the last
change that you made.

Add Icons tools

The Tools window provides icons for eight types of network
elements: PC, Host, Server, Router, LAN box, Bridge, Hub, Printer,
and Subnet. When you click on one of these icons in the Tools
window, it becomes the active Add tool. This Add tool remains active
until you click on another button in the Tools window. Click on the
icon type (for example Add PC), and then click on the map to add the
icon.

Add Line tool

When the Add Line tool is active, you can click and hold the mouse
button on the map, and then drag the line to place it.
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Map Editor Pop–Up Menus

As an alternative to the Tools window, you can also use the Map
Editor pop–up menus to perform many of the Map Editor functions.
There are two pop–up menus available while working with the map
in either Edit mode or Monitor mode.

Click the right mouse button on a network element to display the
network element functions (such as Properties, Attach to, and
Delete).

Click the right mouse button on an empty area of the map to display
the create element functions and the map and color functions.

Creating Network Elements

In the Tools window, click on the type of network element that you
want to create, and then click on the map. WhatsUp creates the
network element on the map.

For example, click the Add PC button, and then click on the map. A
PC icon is added to the map. Click on the map again to add another
PC icon. The Add PC tool remains active until you click another
button in the Tools window.

To enter information (such as the hostname and IP address) for a
network element, see the “Setting Up Properties” section of this
chapter.

Drawing Connecting Lines

There are two types of lines you can use to show connections
between network elements: free lines and attached lines. Free lines
are separate elements; they do not move when you move a network
element. Attached lines attach one network element to another; if you
move one of the elements, the line moves with it and is resized to the
new position.

You can assign a different color for either attached or free lines to
make it clear which type it is. To assign colors, select Properties
from the File menu, and then select the Colors options.
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To draw free lines:

In the Tools window, click the Line button, then press and hold the
mouse button on the map location where you want the line to start,
drag the mouse to where you want to end the line, and then release
the mouse button.

To draw attached lines:

1. Click the right mouse button on a network element to display the
pop–up menu.

2. Select Attach to from the pop–up menu.

3. Click on the network element to which you want to attach the
first element.

Or:

Select a network item, and then click the right mouse button on
another network item and select Attach to selected item from the
pop–up menu.

WhatsUp draws the attached line between the network elements.
Each network element can attach to only one other network element,
but a particular network element can be attached to by many
elements.

Modifying the Map

You can move network elements and lines to new positions on the
map. You can erase network elements and free lines. You can also
cut, copy, and paste network elements within a map or from one map
to another.

You can click the Undo button in the button bar to undo the last
single change that you made.
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To move a network element or line:

1. In the Tools window, click the Select button.

2. To move a network element, press and hold the mouse button on
a network element, drag it to its new location, and release the
mouse button. If the element has an attached line, the line moves
with it.

To move one end of a free line, click and hold the mouse button
on the line, drag the end point to its new location, and release the
mouse button.

To erase a network element or line:

1. In the Tools window, click on the Eraser button.

2. To erase a network element, click on the network element. To
erase a line, click on any point of the line.

As an alternative, you can select a network element and press the
Delete key to delete it.

Note:

When erasing network elements or lines that are close
together, you can avoid selecting the wrong item by
clicking near the center of the network element or line.

If you erase the wrong network element, click the Undo button
in the button bar to undo the last change.

To cut or copy and paste a network element:

1. Click on a network element to select it.

2. From the Edit  menu, select Cut or Copy.

3. After you cut or copy an item, select Paste from the Edit menu to
paste it.
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To select a range of network elements:

1. In the Tools window, click on the Select (arrow) button.

2. Press and hold the mouse button on the map, drag the select box
around the network elements you want to select, and then release
the mouse button.

3. You can apply any of the edit functions to the selected network
elements, including move, cut, copy, paste, and convert icons.

Note:

To select all network elements in a map, from the Edit
menu, select Select All. To select individual network
elements, press the Ctrl  key and click on the desired
elements.

Viewing and Modifying a Network Element’s Properties

While in the Map Editor, you can view a network element’s
properties and status and modify its properties as follows:

To quickly view a network element’s properties and status:

1. In the Tools window, click on the View button.

2. Click on a network element.

The status dialog box appears.

To modify a network element’s properties:

1. In the Tools window, click on the Configure button.

2. Click on a network element.

The Properties dialog box appears. See the “Setting Up
Properties” section in this chapter for more information.
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To connect to a network element:

1. In the Tools window, click on the View button. The status dialog
box appears.

2. Click the Connect button to launch the Connect program. This
program (which is not part of WhatsUp) can be Telnet or some
other connect program. See “Setting Up Properties” in this
chapter for more information.

Exiting Map Edit Mode

To exit Map Edit mode and return to Monitor mode, click on the
Tools button on the button bar. The grid background and Tools
window disappear.

Setting up Properties

After you have created the network elements that you will monitor on
the network map, you can enter information about each element, set
up the properties that determine how you will monitor each element,
and define what action WhatsUp should take if the element does not
respond to polling. You can use the Properties dialog box to set the
following types of options:

Define — Define the display name, hostname/IP address, and type of
network.

Notes — Enter any notes that you want to associate with the network
element.

Services — Set up monitoring of services (such as SMTP, POP3,
FTP, Telnet, WWW, or News) on a network element.

Menu — Specify additional programs or network utilities that you
would like to appear on the pop–up menu for the selected host.
Defaults include the Connect program for this host, Ping, and
Traceroute.
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Down Action — Specify the down actions to take when a network
element does not respond to polling (for example, sound an alarm,
write to log file, activate a beeper, or send a message to a pager or to
an e–mail address).

Notifications — Define the notification actions that you will use to
report a failure (for example, set up the telephone number for beepers
and pagers, and set up the automated message to be sent to a pager or
e–mail address).

To open the Properties dialog box, do one of the following:

• Click on a network element to display the status dialog, and then
select Properties.

• In the Map Editor, from the Tools window, click the Configure
button, and then click on a network element.

Defining Host Properties

In the Properties dialog box, click Define to display the Define
options.

1. In the Display Name text box, enter a name using up to to 8
characters. This is the name displayed on the network map.

2. In the Address/Name text box, enter a name that can be resolved
or an IP address. This text box is limited to 25 characters.
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3. In the System Type text box, select the desired type from the
drop down list. This option is used to select the icon to display
when the Use Icons option is enabled.

4. In the Info Line 1 and Info Line 2 text boxes, enter any
information you want to associate with the network element. For
example, you can enter a name that is the “point of contact” for a
system or location. This information is displayed in the status
dialog box during monitoring operations (as described in Chapter
4) and can be included in notifications.

5. In the Connect Prgm, enter the command to be executed when
you select Connect from the status dialog box or pop–up menu
for a network element. The IP address of the network element is
included as the last argument on the command line. The Connect
program is not included with WhatsUp. Typically, the Connect
program is a terminal emulator, such as Ipswitch’s VT320W for
Windows.

You can use the following special values when defining the
Connect Program:

[LOAD]database_file_name%
This causes the specified database to be loaded. You need to
include the brackets as shown. This is intended to be used in
conjunction with an item that has a System Type of Subnet. See
“Linking Network Maps” in this chapter for more information.

%l
This is replaced with the contents of the Display Name text box
of the network element’s properties.

%n
This is replaced with the contents of the Address/Name text box
of the network element’s properties.

%a
This is replaced with the IP address of the network element.

%1
This is replaced with the contents of the Info Line1 text box of
the network element.
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%2
This is replaced with the contents of the Info Line 2 text box of
the network element.

Examples

d:\csuite\apps\imosaic.exe http://%a/

d:\csuite\apps\telnet.exe %a

d:vt320w @connect winsock %a

[LOAD] subnet.db%

6. Select the Network Type. Currently, TCP/IP and Netbeui are
supported. This defines how the system talks to the network
element. Netbeui is available on Windows 95 only.

7. Select the Monitor  check box to check the network element’s
status on each poll. If this is not checked, the network element is
displayed in grey.

8. Select the Critical Item  check box if you want to cancel the
polling of other network element when this network item is not
reachable.

The remaining elements in the polling sequence will not be
checked if a “critical” host is not reachable (if a service is down,
but the host is up, it won’t stop). Remaining elements in the poll
are marked as missing one poll to force a color change.

9. Click OK  or press Enter.
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Entering Notes

You can enter notes in text format that you want to associate with the
network item. Select Notes in the Properties dialog box and enter any
text information.

Monitoring Services

WhatsUp allows you to check if a service (such as SMTP, POP3, or
WWW) is running on a remote host. You set up service monitoring in
the Services options of the network element’s Properties dialog box.
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There are two ways to set up service monitoring:

• You can use the services checked in the Predefined Services
(SMTP, POP3, WWW, etc.) list on the left side of the Services
page.

• You can set up monitoring for a specific service by entering
information about the service on the right side of the Services
page. This is useful if a service does not appear  as a Predefined
Service, or if it uses a nonstandard port number.

WhatsUp will check that the selected services are running whenever
it polls the network item. If a predefined service is down, the network
element will change color to purple. If a specific service is down, the
regular color codes are used (green = up, red = down).

The status window (shown below) also shows the status of polled
services: green = up, red = down.

See Chapter 4 for more information on polling options and status
displays.

Setting Up Predefined Services

You can select the services to be monitored from a list of predefined
services.

1. Select a network element. In the Properties dialog box, click the
Define button. The Define options appear. Set the Network Type
to TCP/IP; and enable the Monitor  option. All other options set
in the Properties dialog box remain in effect.
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2. In the Properties dialog box, click the Services button. The
Services options appear.

3. Select the services you want to monitor.

If you did a Scan Net to create the network map, you may have
already scanned each network element for available services. In
this case, when you open the Services options of a network
element’s Properties, the list of Predefined Services will show
the services available (those that are checked) on that network
element. You can toggle off any  services that you do not want to
monitor.

You can click the Scan button on the Services page to scan the
network element and determine if any of the predefined services
are available on that machine. Services found on the machine are
marked with a check (see the Services properties screen at the
beginning of this section).

4. Click Apply  (You must click the Apply button to save changes).

Setting Up a Specific Service

You can also monitor for a specific service that does not appear in the
list. To do this, the Specific Service option must be enabled and a port
must be set in the Services options.

To set up monitoring of a specific service on the network element:

1. In the Properties dialog box, click the Define button. The Define
options appear. Set the Network Type to TCP/IP and enable the
Monitor  option. All other options in the Properties dialog box
are honored.

2. In the Properties dialog box, click the Services button. The
Services Options appear.

3. Select the Enable check box to enable monitoring of a specific
service.

4. In the Port text box, enter the TCP/UDP port that you wish to
monitor. (For example: 21=FTP, 23=TELNET, 25=SMTP,
53=DNS, 80=WWW, 110=POP3, 119=NNTP)
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5. Optionally, in the Expect on Connect text box, enter a message
that the remote service will send back to you on connect. The
field length is limited to 19 characters. This is an absolute match
starting from the beginning of the received message. For
example, if you expect to get “220 hostname.domain.com Imail
v1.3\r\n” back from the host, you could enter “220 host” as an
expect string. To find the proper string here, telnet to the desired
port on the host when it is working properly, and see what comes
back.  Note that some services (such as DNS) will not provide
you with a string.

Note:

The \r  (carriage return) and \n (line feed) are the con-
ventions for sending these control characters to termi-
nate a string.

6. Optionally, in the Send to disconnect text box, enter a command
string to disconnect from the service properly. For most TCP/IP
servers, the string “QUIT\r\n ” is proper. If a command string is
not specified, the connection is closed by sending a FIN packet
and then an RST packet.

7. Optionally, in the Timeout text box, change the default timeout
(5 seconds) for the service status. This is separate from the
timeouts used for polling and is specified in seconds.

8. Click Apply (you must click the Apply button to save changes).
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Defining Pop–up Menu Items

When you click the right mouse button on a network element, a
pop–up menu appears. You can use the Menu properties to add or
delete items in the pop–up menu and to define the command executed
when a menu item is selected.

To add a menu item to the pop–up menu:

1. In the Menu Item text box, enter the name that you want to
appear in the menu.

2. In the Command Line text box, enter the command that executes
the program.

You can use the following arguments on the command line:

%l
This is replaced with the contents of the Display Name text box
of the network element’s properties.

%n
This is replaced with the contents of the Address/Name text box
of the network element’s properties.

%a
This is replaced with the IP address of the network element.
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%1
This is replaced with the contents of the Info Line1 text box of
the network element.

%2
This is replaced with the contents of the Info Line 2 text box of
the network element.

3. Click the Add button.

The item appears in the list of menu items.

4. Click the Save button.

To delete a menu item, select it in the list of menu items on the left of
the Menu Properties page, and then click the Delete button.

Setting the Down Action

WhatsUp sounds an alarm (.WAV file) when a network element fails,
or it invokes a bell sound when it starts up after having failed. You
can set the priority of the alarm for each network element. You can
set the notifications you want to occur when the network element is
down. These notifications can activate a beeper, send a message to a
pager, or send an e–mail message.

You can globally enable and disable alarms for a network map. Select
Properties from the File menu, and then select Map options. The
Enable .WAV Playing option is checked by default. To globally
disable alarms, toggle off this option.

To hear the alarm, you must have a sound card installed on your
system.

To set the Alarm options:

1. In the Properties dialog box, click the Down Action button. The
Down Action options appear.
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2. Select the Log Activity  check box to write an entry in the
mapname.LOG file in the same directory of the map when the
item has missed 4 polls and when the item recovers after missing
3 or more polls.

3. In the Sound check box, select the sound file that will be played
when the network element goes down.  None=no sound, Low
priority=down1.wav, Middle priority=down2.wav, High
priority=down3.wav. When multiple network elements go down
simultaneously, the highest numbered sound has priority.

Before you can add a notification action to a network element’s
Down Action properties, you need to define the action in the
Notifications properties. See the following section, “Defining
Notification Actions” for information.

After defining notifications, you can enable them in the Down Action
properties. To enable the Notification actions to be performed when
the network element does not respond to polling:

1. To enable a notification action, click the New button. The Add
Notification dialog box appears. All notification actions that have
been defined are available from the Notify drop–down list. Select
an action, such as Default Beeper or Default Pager, from this list.
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You can also set the following options in the Add Notification
dialog box:

system checks

After this number of failures on system checks, send notification.
This is an exact match of the down count for when the
notification should be activated. This number should be greater
than 4. The default is 15 greater than the sound activation trigger.
(sound activation trigger is 4)

when system comes back up

When checked, performs notification action when the system
comes back up after a down notification.

send only if

When checked, sends notification only if no one silenced the
alarm from the console.

Beeper code (for beeper only)

This is the number that is sent to the beeper or passed as arg 3 to
the external program (see the section “Using an External Beeper
Program” in this chapter.)

2. Select the Enable check box to enable the Notification actions
shown in the Notification list box.

3. Click on Apply.

To edit an existing notification action, select it and click the Edit
button. To delete a notification action so that it is not applied for the
network element, select it and click the Del button.

Setting Up Notification

When the network element does not respond to polling,  WhatsUp
can send notification via a beeper, a pager message, or an e–mail
message. Setting up notification for a network element involves two
steps:

1. You first need to define the notification actions that you will
want to use, such as activating a network administrator’s beeper
or sending e–mail to an individual.
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2. Then, you can enable notification actions for a network element,
which is just a matter of selecting from the defined actions. You
can set options that determine when a notification is sent. For
example, you can specify that a notification be sent when the
network element does not respond to 10 system checks.

See the previous section “Setting the Down Action” for
information on enabling notification actions for a network
element.

You can also set up a notification to send a network status report at a
specified time interval. See WhatsUp Properties in the “Setting
System Properties” section.

You can access the Notifications properties in either of the following
ways:

• Open the network element’s Properties dialog box and click
Notifications.

• From the File menu, select Properties, then click Notifications.

The following sections describe how to set up the different types of
notification.

Defining Beeper Notification

You can define beeper notification to activate a beeper when the
network element does not respond to polling.
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1. Enter a unique name to identify the beeper notification, for
example “Beep Bob.”

2. Select the Beeper notification type.

3. In the Phone text box, enter the phone number to dial.

4. Click Comm Setup. The Communications Setup dialog box
appears.

Enter the information in the Beeper section of the dialog box::

Dial String

The default dial string is:  ATDT%s,,,,%s#   
The first %s is replaced by the phone number and the second %s
is replaced by the beeper code. Most modems and beepers
support the use of ’#’ to terminate the message and ’* ’ to print
out a dash. You may find a need to increase the number of
commas in the dial string if it dials the code too soon or decrease
the number of commas if it waits too long.

Baud Rate

Select the speed (measured in bits per second) at which the serial
port will communicate with the modem.

COM Port

Select the port to which your modem is attached.

Timeout

The timeout value determines how long the system waits after
sending the last character before it hangs up the phone, if a
transition is not recognized.
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When you have entered the information, click OK .

5. Click the Add button to add the new beeper notification.

6. The beeper notification appears in the list of Notifications.

Click the Test button to test the notification.

Using an External Beeper Program

You can also use an external program of your own to handle beeper
notification. The presence of an external program name in
notification enables the external program.

The following information is made available to the external program
via the command line.

arg 1: either DN or UP

arg 2: the phone number as specified in the Notification 
options

arg 3: the beeper code as specified in the Down Action options
(in the Add Notification dialog box)

arg 4: the IP address of the host

External program example arguments:

0: beeper.exe 1: DN 2: 8694297 3: 3333 4: 127.0.0.1

0: beeper.exe 1: DN 2: 8694297 3: 2222 4: 127.0.0.1

0: beeper.exe 1: UP 2: 8694297 3: 2222 4: 127.0.0.1

The external program is executed with SW_SHOWMINNOACTIVE.

The external beeper program will not be activated if someone
silenced the alarm before the system check is reached.

The UP message will only be sent if the packets lost is greater than
system checks when the network element comes back up.
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Defining Pager Notification

You can define pager notification to send a message to a pager when
the network element does not respond to polling. WhatsUp supports
PageNet and other TAP (Telocator Alphanumeric Protocol) pagers.

To define a pager notification action:

1. Enter a unique name to identify the pager notification, for
example “Page Bob.”

2. Select the Pager notification type.

3. Enter the following information:

Terminal

Enter the phone number to dial.

Password

Enter the pager password, if required.

Pager ID

Enter the pager identification number.

Message

Enter a text message plus any of  notification variables (see the
Notification Message Variables at the end of this section).
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4. Click Comm Setup. The Communications Setup dialog box
appears.

Enter the information in the Alpha Pager section of the dialog
box:

Modem Initialization String (ATEO)

The default string is ATEO. What is expected in this string are
the modem commands for “Command Echo Off” (EO), “Result
Codes On” (QO), and “Verbal Results” (V1). The recommended
string to use is: ATEO QO V1

Baud Rate

Select the speed (measured in bits per second) at which the serial
port will communicate with the modem.

COM Port

Select the port to which your modem is attached.

When you have entered the information, click OK .

5. Click the Add button to add the new pager notification.

The pager notification appears in the list of Notifications.

Click the Test button to test the notification.
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Defining E–mail Notification

You can define e–mail notification to send a message to an e–mail
address when a network element does not respond to polling. To
define an e–mail notification action:

1. Enter a unique name to identify the e–mail notification, for
example “Mail to Netadmin.”

2. Select the Mail  notification type.

Enter the following information:

Address

Enter an e–mail address that is accepted by the Gate IP. (This can
be a simple name.)  The Address should not contain brackets,
braces, quotes, or parentheses.

Gate IP

Enter an IP address of a host running SMTP.

Message

Enter a text message plus any of  notification variables (see the
Notification Message Variables at the end of this section).
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3. If you need to change the Mail From Address, click Comm
Setup. The Communications Setup dialog box appears.

The Mail From Address defines the sender of an e–mail
notification as: <whatsup@%s>, where %s is the local
hostname. In most cases, you will not need to change this
address. If you do change the address, be sure to keep the angle
brackets (<  >) in place.

4. Click the Add button to add the new mail notification.

The mail notification appears in the list of Notifications.

Click the Test button to test the notification.

Notification Message Variables

In pager and e–mail notification messages, you can use the following
variables to encode information about a network element from 
WhatsUp.

   %u = “UP” or “DOWN”

   %n = Display Name

   %h = Address/Name

   %a = IP Address

   %c = System Type
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   %1 = Info line 1

   %2 = Info line 2

   %t = time (hh:mm:ss)

   %d = date (yy.mm.dd)

   %S = status (such as “timed out”, “did not respond”)

   %s = integer status (these are Winsock error codes)

   %v = down services

   %V = down services with “services” printed

   %N = notes

   %L = log file (or %Lnn where nn=last nn lines of the log file)  
           (This variable can be used in e–mail messages only.)

Updating Notification

To update an existing notification action, select it in the list of
Notifications, edit any of the options, and then click the Update
button.

Testing Notification

You can test a notification action by selecting it in the list of
Notifications and clicking the Test button. The test results are
displayed in the right side of the Notifications page. To return to the
original display, click on a Notification Type.

Connecting to a Network Resource

You set up the Connect Program (for example, Telnet) in the Define
options of  the network element’s properties. You can then connect to
a network resource by clicking on a network element to display the
status window, and then selecting Connect.
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Linking Network Maps

You can create a subnet to link one network map to another to
represent a hierarchical network. To link the network maps:

1. Create a Subnet icon in the top–level network map.

2. Open the subnet element’s Properties, and enter the following
command in the Connect Program text box:

[LOAD] database_file_name %

where database_file_name is the name of the database file of the
network map to be linked.

The following example loads the network map defined by the
subnet.db file.

[LOAD] subnet50.db%

When you select the Connect program for the subnet, WhatsUp loads
the database file and displays the network map.

Saving the Network Map

When you have finished setting up the network map, you can save it
by selecting Save from the File menu. The Save dialog box appears.
Enter a name with the extension .db to save the network map and
click OK .

Setting System Options

You can set system options to determine how WhatsUp will monitor
your network. You can set automatic polling or initiate polling
manually. See “Chapter 4: Monitoring a Network” and “Chapter 5:
Setting System Properties” for more information.
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Chapter 4: Monitoring a Network

This chapter describes how to initiate polling of the network elements
in your network map and how to display network status information.

Establishing a Currently Active Network Map

Before monitoring a network you need to establish a currently active
network map in one of the following ways:

• Load a previously defined network map — Select Load from the
File menu or click the Load Database (open folder) button on
the button bar.  The Open dialog box will appear to assist you in
locating the network map database file to open.

• Define a new network map — Select New from the File menu or
click on the Create New Map (sheet of paper) button on the
button bar. Click on the Tools button in the button bar to enter
Map Edit mode. You can now define a new network map.

• Use the WhatsUp autoscan feature to automatically create a
network map — Select Import–>Scan IP from the Tools menu.
The Scan Net dialog box will appear. Modify the network
addresses if necessary and click the Start button to start the
automatic scan. When the scan completes, you can select the
network elements that you want to appear in the map.

• Load a hosts file to automatically create a network map  —
Select Import–>Hosts File from the Tools menu. WhatsUp
scans your hosts file and creates an icon for each host listed in
the file.

See “Chapter 3, Setting Up the Network Map” for information on
performing these operations.
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Setting up the Network for Monitoring

Once you have established an active network map, you should disable
the monitoring of any network element that you do not want included
in the polling by toggling the Monitor  check box to off in the Define
page of the Properties dialog box for that network element.  (Note
that the icon for that network element will be displayed in a different
color, dark gray by default, to indicate its inactive status.) Also, you
should set any options that you want to be in effect during network
monitoring by selecting Properties from the File menu and changing
any Program, Map, or Colors options. See Chapter 5, Setting System
Properties, for more details on setting up system options or display
colors).

Initiating Polling

You can initiate a single check of the network, whereby WhatsUp
makes a single pass through the elements in the network map, polling
each element. You can also initiate automatic polling, whereby
WhatsUp polls the network elements continuously, starting each new
pass after a specified time interval.

To Initiate a Single Check

When you are ready to begin monitoring your network, you can
initiate a single check or polling of currently active network elements
by clicking the Check button (green check mark) on the button bar or
by choosing Check from the Tools menu. These two actions are
equivalent and result in WhatsUp sending a set number of ICMP echo
requests to the specified IP address for each active network element
and tracking the responses.

To Stop a Single Check

To stop a single check or polling of currently active network
elements, simply click the Stop button (crossed–out check mark) on
the button bar of the WhatsUp main window.
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To Initiate Automatic Polling

To initiate automatic polling of currently active network elements,
choose Properties from the File menu. The Properties dialog box
will appear. In the Map options, set up the number of seconds you
want between checks, the number of seconds to wait before time–out,
and any other options you may want to change. When you are ready,
toggle off the Disable Automatic Checks check box and click OK  to
start automatic polling. WhatsUp closes the Properties dialog box and
returns to the main window to allow you to follow monitoring
operations if you choose.

To Stop Automatic Polling

To temporarily stop polling of currently active network elements,
click on the Poll (timer clock) button in the button bar. To resume
polling, click the Poll button again.

To stop automatic polling of currently active network elements,
choose Properties from the File menu. The Properties dialog box
appears. In the Map options, toggle on the Disable Automatic
Checks check box and click the Save As Default button to stop
automatic polling. WhatsUp closes the Properties dialog box and
returns to the main window.

Monitoring the Network Display

By convention, network elements that respond to polling are
displayed in green, those that have missed at least one polling request
are displayed in light green, those that have missed two polling
requests are displayed in yellow, and those that are not accessible or
have not responded to four consecutive polling requests are displayed
in red. You can change the default colors in the Colors options,
described in Chapter 5.

If you enabled the Show Timer in Title check box in the Map
options of the Properties dialog box, WhatsUp displays a count–down
timer in the title bar of the main window. WhatsUp resets this timer
after each polling.
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Alarms

An alarm will sound when the network element fails to respond to
four consecutive polling requests, provided alarm priority in the
element’s Down Action properties is set to low, medium, or high
priority. A different sound file is played for each level of priority. To
hear the alarm, you must have a sound card installed on your system.

To turn off an alarm, click the Alarm  button in the button bar, or
select Quiet Alarm  from the Tools menu.

Status Information

To display status information associated with any of the displayed
network elements (active or inactive), click on the network element.
The status window appears.

The status window shows the hostname and IP address of the network
element, and displays a current status message. It also displays the
status of packets sent by WhatsUp to poll this network element:

Lost — the number of packets lost and the total number of
packets sent .

RTT — (Round Trip Time) the time (in milliseconds) that it took
the last packet sent to arrive at the network element and return,
and the average RTT for all packets sent.

A graph at the bottom of the dialog box shows the RTT information
for the latest packets sent.
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You can position, minimize, or delete the status window. In addition,
buttons are available to make it convenient for you to select other
options from here. These include accessing the Connect program for
this host, Ping and Traceroute utilities, the Properties window for
this host, or related Notes. You can toggle another button to change
from a Graph of monitored results (as shown above) to a visual
indicator of the status of the Services being monitored. (Note that the
appearance of this button changes depending on which of these
modes you’re in.)

You can click on the Services button to show the status of any
services that you are monitoring for that network element (as shown
below). Services that respond to polling are displayed in green, those
that are not accessible or have not responded are displayed in red.
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Using the Mini Status Window

The Mini Status shows a list of all the network elements in the
currently active map, and displays the status using the same colors
used on the network map.

From the View menu, select Mini Status. The Mini Status window
appears and the network map is closed.

Click the Poll button to initiate a single check of each network
element. Click the Exit  button to close the Mini Status and redisplay
the network map.
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Viewing and Changing Polling Order

WhatsUp polls network elements in the order that they were created
on the map. You can view the polling order in the Mini Status
window (select View–>Mini Status) or in the database file (select
View–>Information–>Database). You can also change the polling
position of a network element.

To read the polling order:

In  the Mini Status, the polling order starts at the top and goes down
the list of network elements. If there are two columns, it starts in the
left column, and continues at the top of the right column.

In the database file, the first number on each line indicates the polling
position of the network element.

To change the polling position of a network element:

In  the network map, click the right mouse button on the network
element that you want to move in the polling order. A pop–up menu
appears. Select from the following menu items:

Start of poll

Make the network element the first element to be polled.

Earlier in poll

Move the network element up one position in the polling order.

Later in poll

Move the network element down one position in the polling order.

End of poll

Make the network element the last element to be polled.
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Viewing Network Information

WhatsUp provides easy access to information about your local
system (the installed TCP/IP stack and your system’s operating
environment), the network map database files, and the activity log
file that logs when any network element goes up or down.

You can display this information by selecting the appropriate item
from the View menu.

Stack Information

From the View menu, select Information–>Stack to view
information about your local system’s TCP/IP stack.

The stack information includes: the type of stack you are running, its
status, version number, the maximum number of sockets, and the
maximum length of a UDP packet.

Local Information

From the View menu, select Information–>Local  to view
information about your local system’s operating environment.

The local information includes: the system’s operating system and
version, its CPU and version, the current map window bitmap size
(useful when using a bitmap for the map background), the Windows
name, the hostname, and the IP address of the local system.

Database Information

From the View menu, select Information–>Database to view the
database of network element information.

The database file lists all of the network elements in the network map
and shows the following information:

Number — the network element’s position in the polling order.

Name — the network element’s hostname.
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Address — the network element’s TCP/IP address.

Status — the network element’s last read status

Last —  round trip time (RTT) of the last poll

Min — minimum RTT of the last 50 polls

Max — maximum RTT of the last 50 polls

Avg — average RTT of the last 50 polls

TLost — current count of lost polls, if the element is down

TTotal — total count of lost polls since the map was loaded

STotal — current count of lost service polls, if a service is down

The database information that follows the STotal field is used for
debugging purposes.

Log Information

Each time a network element goes down, or comes back up after
going down the event is recorded in the Log file.

From the View menu, select Information–>Log to view the Log file
information.

The Log file shows the following information: the date and time the
event occurred, the hostname and TCP/IP address of the network
element, whether the event was the element going down or coming
up (down/up), and the reason for the failure, such as “timed out,” or
“not responding.”
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Chapter 5: Setting System Properties

You can change a number of system options by selecting Properties
from the File menu. From the Properties dialog box, you can select
the following options categories:

• Program Options

• Map Options

• Tool Options

• Colors Options

• Notification Options

• WhatsUp Options

Each category is discussed in more detail below.

Program Options

Default map

This is the map database that WhatsUp loads on start up.
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Telnet

Program to execute when you select Tools–>Network and then
Telnet from the pop–up menu that appears. Also the default tool used
for the Connect pop–up menu option. (Available separately from
Ipswitch, the VT320W Telnet Terminal Emulator is an excellent
choice.)

FTP

Program to execute when you select Tools–>Network and then FTP
from the pop–up menu that appears.  (Available separately from
Ipswitch, WS_FTP Professional� – Windows FTP Client is an
excellent choice.)

Raw socket ICMP ping

This should be selected if you are using a stack that supports raw
sockets, such as Acadia/VxD from Ipswitch, OnNet from FTP
Software, or Trumpet Winsock.

Microsoft ICMP ping

This should be selected if you are using Microsoft’s TCP/IP 32 on
Windows NT or Windows 95. If this is checked and you are not using
Microsoft’s stack, you will get an error on ICMP.DLL.

TCP/IP echo

This should be selected if the other poll options (Raw socket ICMP
ping or Microsoft ICMP ping ) will not work. Note that some hosts
may not respond to this type of check.

Show Timer in Title

Enables or disables display of the timer in the title bar of the
WhatsUp main window. See the related information about the
Seconds Between Checks option in the “Map Options” section.

Label Toolbar

Checking this box results in larger, labeled buttons being used in the
toolbars in the WhatsUp main window and map–edit window.
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Map Options

Bitmap

Allows you to specify a bitmap image file to be used as a
background for the WhatsUp map. This could be a floor plan, a
geographical map (city, state, or country), or any bitmap image that
you want.

Seconds between checks

This is the number of seconds between polls. A count–down timer
that resets to this number is displayed in the title bar of the main
window if the Show Timer in Title option is enabled (see the
Program Options section). Note: You should experiment to find the
optimal value for your network.

Seconds to wait before time–out

This is the number of seconds to wait for a response from a polled
network element. This should be set to the smallest possible value.
For a local network, a time–out of two seconds is usually valid. For a
long–distance (or slow–path) network, this time–out may need to be
as high as ten seconds.
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Disable automatic checks

If this box is checked, WhatsUp will not automatically poll network
elements for their status. You can still press the green check mark
button in the main window’s toolbar to check the current status of
network elements with a single polling.

Enable WAV Playing

Globally enables and disables the alarms that sound when a host goes
down or comes up. This option is enabled (checked) by default.

Fixed Fonts in map

Changes the handling of fonts in the display of network elements.

Use Icons

WhatsUp will display icons in place of the simple host name if this
box is checked. The type of icon is determined by the System Type
property of the network element (specified in the Properties
window).

Label Icons

The simple name will be displayed below the icon when the Use
Icons option and this option are both enabled. The Label Icons
option can also be used to show labels only, when the Use Icons
option is not enabled. Note that the color of the background under an
icon is the nearest solid color to the current color of the icon.

Save as Default

Click this button to save the current values for all Map options.
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Tool Options

Fixed Fonts in Tools

Changes the handling of fonts in the tools’ displays.

Verbose

Provide full information in the tools’ displays.

Ping Options

The following options are set for the Ping tool.

Count

The number of data packets sent by the ping command.

Data Length

The length in bytes of each packet sent by the ping command.

Time out

The ping will fail if the host does not respond after this number of
seconds.

Trace Options

The following options are set for the Trace tool.
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Max hops

The maximum number of hops to trace before ending the traceroute.
When an IP packet passes from one host to another, it is referred to as
one hop.

Show Names

The hostnames of each router along the route will be displayed.

Automap Trace

When this option is enabled, when you launch a trace to a network
element, WhatsUp draws a map of the route, displaying an icon for
each router and showing the connections from router to router until it
reaches the network element. See the “Traceroute” section in Chapter
6 for more information.

Trace when ping fails

When a ping fails, launches a traceroute to map the route to the failed
network element.

Colors Options

You can change certain WhatsUp display colors in the Colors options.
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Note:

Not all colors are available for use in all systems or for
all fields. You will need to experiment for the best re-
sults on your system.

To change a color, select the color name in the list box and click the
color patch that you want. The current setting for a name is displayed
to the right of the list box, above the color patches. Colors that can be
modified include:

Responding

This is the color used to paint the icon or text background of a
network element that is responding to active checks. The default is
solid green.

Lost 1 pkt

This is the color used to paint the icon or text background of a
network element that has timed out on one active check. The default
is solid light green.

Lost 2 pkts

This is the color used to paint the icon or text background of a
network element that has timed out on two consecutive active checks.
 The default is solid yellow.

Lost 3 pkts

This is the color used to paint the icon or text background of a
network element that has timed out on three consecutive active
checks.   The default is solid yellow.

Lost 4–7 pkts

This is the color used to paint the icon or text background of a
network element that has timed out on four to seven consecutive
active checks. The default is solid light red.

Lost 8+ pkts

This is the color used to paint the icon or text background of a
network element that has timed out on eight or more consecutive
active checks and for elements that have a network error such as
network unreachable. The default is solid dark red.
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Service down

This is the color used to paint the icon or text background of a
network element that has a predefined service that is down. The
default is solid purple.

Inactive

This is the color used to paint the icon or text background of a
network element that is not being monitored (the Monitor option in
the Define properties is disabled). The default is solid dark grey.

Background

This is the color used to paint main window background. The default
is solid light grey.

Text

This is the color used to paint the text used in labels in the main
window. The default is solid black.

Attach lines

This is the color used to paint lines created in the network map using
the Attach to item from the pop–up menu. The default is solid yellow.

Free lines

This is the color used to paint lines created in the network map using
the Add Line button on the Tools window. The default is solid yellow.

Grid lines

This is the color used to paint the lines that make up the grid on the
window background when in map edit mode. The default is solid
dark grey.

Notifications Options

When the network does not respond to polling, WhatsUp can send
notification via a beeper, a pager message, or an e–mail message. You
define these notifications in the Notifications options. See the
“Setting Up Properties” in Chapter 3 for information on using these
options.
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WhatsUp Options

The WhatsUp options let you send a network status report as a pager
or e–mail message at a specified time interval. You can set up these
options so that you receive up–to–date status reports at a remote site,
so you can be assured the network is running smoothly, or so you can
be quickly apprised of any problems.

To set up the status report notification:

1. Click the New button. The Add/Edit WhatsUp Reports dialog
box appears.
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2. Select a notification action from the drop–down list.

For example, if you created a notification action that sends
e–mail to the network administrator, you can select that action
from the drop–down list. If you need to create a notification
action, see “Setting Up Properties” in Chapter 3 for information
on using the Notifications options.

3. Enter how often (specified as the number of poll requests) you
want to send the report.

This number is effected by the Seconds between checks option
set in the Map options. If you select to send a report after every
10 poll requests, and the Seconds between checks is 60 seconds,
then the report will be sent every 10 minutes (60  seconds X 10).

4. Check any options you want to use.

5. Click the OK  button to apply the new notification and close the
Add/Edit WhatsUp Reports dialog box.

The new notification appears in the Notifications list on the
WhatsUp options page.

6. Toggle on the Enable check box to enable all notifications
shown in the list box.

7. Click on Apply.
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Chapter 6: Network Tools

WhatsUp includes a versatile set of tools that enable users to search
for and display information about organizations, networks,
computers, or people on a network. Accessed from the Tools menu,
WhatsUp tools include Lookup, Ping, Traceroute, Finger, and Whois.
You can also link your favorite Telnet and FTP program to the Tools
menu.

Lookup

What is Lookup?

Lookup is a tool that lets you query Internet domain name servers for
information about hosts and name servers. You can use Lookup to
print just the name and Internet address of a host or domain, query
the name server for information about various hosts and domains, or
print a list of hosts in the domain.

Lookup Query

To initiate a Lookup query:

1. In the WhatsUp main window, from the Tools menu, select
Network–>Lookup. The Lookup window appears.

2. In the Host Name/IP Address text box, type a hostname or IP
address.

3. Click the Lookup button. The hostname and IP address are
displayed in the Results window.
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Ping

What is Ping?

Ping is a network diagnostic tool that is used to verify connectivity to
a particular system on your network. Ping sends an ICMP “echo
request” in the form of a data packet to a remote host and displays the
results for each “echo reply”. This exchange is referred to as
“pinging.” The Ping command also displays the time for a response
to arrive in milliseconds (this will vary depending on network load),
and debugging information about the network interface. You can have
multiple instances of the Ping application active simultaneously.

Ping Options

Ping options are set by default. You can change Ping Options from
the Options dialog box.

Count

The number of data packets sent by the ping command.

Data Length

The length in bytes of each packet sent by the ping command.

Time out

The ping will fail if the host does not respond after this number of
seconds.

To change your Ping Options and access the Options dialog box, do
the following:

1. Click the Options button and make the desired changes.

2. Click OK  to confirm the new Options settings.
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Pinging a Host

To Ping a Host:

1. In the WhatsUp main window, from the Tools menu, select
Network–>Ping. The Ping window appears.

2. In the Hostname/IP Address box, type a hostname or IP
Address (for example, denmark.com).

3. Click the Ping button.

The Ping application sends an echo request and waits for the
echo reply.  If the Ping was successful, summary lines are
displayed in the Ping window, indicating the result of the Ping.

If the reply is not received within the timeout value, the Ping
fails. This means there has been a failure at one of several points
from your PC to the remote host.  The host may not be
functioning and therefore is unable to respond, a network or
gateway in the path from the user may not be working, or the
host may not implement the service you are requesting.

Traceroute

What is Traceroute?

Traceroute is a network diagnostic tool that allows users to trace and
view the actual route an IP packet follows to an Internet host.
Response times are displayed in milliseconds and will vary
depending on network load. Traceroute is useful for finding potential
trouble spots on large and complex networks that are connected
together by routers.

Traceroute Options

Traceroute options are set by default. Traceroute Options can be
changed from the Options dialog box.

Max hops

The maximum number of hops to trace before ending the traceroute.
When an IP packet passes from one host to another, it is referred to as
one hop.
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Show Names

When enabled, the hostnames of each router along the route will be
displayed along with the IP addresses. When disabled, only the IP
addresses are shown. Showing the hostnames will add time to  the
traceroute as it requires that the IP addresses be resolved.

Automap Trace

When this option is enabled, when you launch a trace to a network
element, WhatsUp draws a map of the route, displaying an icon for
each router and showing the connections from router to router until it
reaches the network element.

Trace when ping fails

When a ping fails, this option launches a traceroute to map the route
to the failed network element.

To change your Traceroute Options and access the Options dialog
box, do the following:

1. Click the Options button and make the desired changes.

2. Click OK  to confirm the new Options settings.

Traceroute Search

To initiate a Traceroute search, do the following:

1. In the WhatsUp Main Window, from the Tools menu, select
Network–>Traceroute. The Traceroute window appears.

2. In the Host Name text box, enter a host name.

3. Click the Traceroute button.

The results of the Traceroute search are displayed in the Results
window.

If the Auto Map Trace option is enabled, WhatsUp draws a map
of the route. The following example shows the map of the route
from the Supernet server to the localhost generated by an Auto
Map Trace.
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Finger

What is Finger?

Finger is an application that identifies and displays information about
all users on a network host.  This information includes a display of
current users (IDs and usernames) and related information including
the home directory, login time, idle times, office locations, as well as
the last time a user received mail, the last time a user read their mail,
and any plan contained in the file .plan or any project on which they
are working in the file .project in their home directory.

If the specified host does not have a Finger Server, the Finger client
displays the message:  Connection not made

Finger a Host

Use the Finger command to display the usernames of people logged
on to a specified host.

The display produced by the Finger command may change depending
on the specified host
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To initiate a Finger query, do the following:

1. In the WhatsUp main window, from the Tools menu, select
Network–>Finger. The Finger window appears.

2. In the Finger String text box, enter a hostname or IP address.

3. Click the Finger button.

The Finger client contacts the host’s Finger server.  The results of
the query appear in the window.

Whois

What is Whois?

An Internet username directory service, Whois provides additional
information to that provided by Finger about users or hosts on a
network.  The information includes a contact name, mailing address,
telephone number, and network mailbox for all users and
organizations who are registered with the Network Information
Center (NIC) database.

Note:

The host server for Network Information Center (NIC) is
RS.INTERNIC.NET.
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Whois Search

To initiate a Whois search, do the following:

1. In the WhatsUp main window, from the Tools menu, select
Network–>Whois.  The Whois window appears.

2. In the WAIS Host text box, enter a hostname or username.

3. In the Search String text box, enter a search string.

4. Click the Whois button.

The Whois client contacts that host’s Whois server. The results of the
query appear in the window.
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